Jump to content

Golem bug

Guest jaZz-

Recommended Posts

Guest jaZz-



First of all.. thanks for checking.


I've already tried a search, but there was only one topic describing a bug with a juggernaut golem.


At the moment I'm playing Throne of Bhaal with the Tweak- and Fixpack installed... I've installed them in the correct order...


I'm stuck inside the Fire Giants cave/temple/dungeon and at a certain point when you loot some sort of purplecolored object (which contains a rune and book by Elminster, describing monsters) several Golems appear. The clay one doesn't seem to be bugged. However.. the first time I started attacking the Adamantite one everything went slow, the music started skipping and eventually BG crashed. I'm not sure if it's the Adamantite golem that's bugged, haven't had the opportunity yet to try it a second time, but the purple magic golem is bugged for sure.


Please note that the game starts having trouble when I'm actually attacking the magic golem.


I hope something can be done here, cause I'm really disappointed and I think that I wouldn't be experiencing these bugs if I didn't install them addons. No disrespect or something.. but just stating the reason why I'm posting this here. If I need to post another topic in the forum for the tweakpack please let me now.


I'll try checking back here, but it would be cool if someone could email me.... even if only to say that there's a reply in this topic. This way I won't have to keep checking here all the time like some addict (which I am :) )




you may email me at jedimindtrickzs<at>hotmail<dot>com


thank you in advance for your help..


Link to comment
Guest Guest
Just warped to the Marching Mountains (ar5201) and checked it out--no issues at all. Could you post your weidu.log?

thanks for the fast reply.. and yes of course..

// Log of Currently Installed WeiDU Mods

// The top of the file is the 'oldest' mod

// ~TP2_File~ #language_number #component_number // [subcomponent Name -> ] Component Name

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #0 // BG2 Fixpack - Core Fixes

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #1 // BG2 Fixpack - Game Text Update

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #3 // BETA Core Fixes (please check the readme!)

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #101 // Improved Spell Animations

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #102 // Cromwell's Forging Actually Takes a Day

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #103 // Mixed-Use Dagger Fixes

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #104 // Ghreyfain's Holy Symbol Fixes

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #106 // Giants Receive Penalties When Attacking Halflings, Dwarves, and Gnomes

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #107 // Remove Dual-Classing Restriction from Archers and Stalkers

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #108 // Remove Second Attribute Bonus for Evil Path in Wrath Hell Trial

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #109 // Corrected Summoned Demon Behavior

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #110 // Additional Script Fixes

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #111 // Bard Song Fixes

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #112 // Wizard Slayers Cause Miscast Magic on Ranged Attacks

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #113 // Additional Alignment Fixes

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #114 // Change Free Action to Protect Against Stun

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #115 // Paws from Shapeshifting Can Not Be Dispelled

Link to comment

That's basically the same setup I used for testing myself. Is anyone else having issues with magic golems?


jaZz-, try moving golmag01.cre out of your override folder and try the area again. That'll roll back any changes Fixpack has made to magic golems.

Link to comment
Guest jaZz-

Hi folks..


did what you asked camdawg and it did have an effect. this time i did get to kill the magic golem, however.. after killing it everything started to go slow, skip and eventually freeze again. The other golems were still in the chamber..


Ummm... I haven't noticed it before, but I believe the Adamantite golem releases a cloudkill or stinking cloud. So it might be this what's bothering. But the spell has been cast before by either me or NPC's. Perhaps this info might be of any use.


But as said.. it's rather weird that, this time, after having killed the Magic golem everything started going whack again.


thanks for your help guys.. and yea... rather weird that the tweakpack doesn't seem to be installed :\ I'm sure I installed both... ah well


anyway.. thanks

Link to comment

Oh, wish I had thought of this earlier--try uninstalling the Paws from Shapeshifting Can Not Be Dispelled component. The bad side effect to it is that it causes animation cycle resets (details here, though it's probably more than you want) and one the items affected is the weapon of iron and adamantite golems. It's possible the effects may be stacking too rapidly and causing the CTD.

Link to comment
Guest Guest



Well.. I've tried it all now and it just wont work.

Something that I've noticed is that the Magic Golem is stunned just prior to being killed.. then it just stands there waiting for the final blow. After being killed the game starts freezing. I'm gonna try a fresh install without the packs and I hope my savegame is still salvageable.


Thanks, I really appreciate you taking the time to help me.


I'll check back here in case you find out what might have been the problem.



Link to comment
Guest jaZz-

Well... a new problem occured. Uninstalled everything.. or at least I thought I did.


Throne of Bhaal still remains in my "add/remove programs" list. Can't reinstall it, cause Setup keeps asking me if I want to uninstall ToB.

Shadows of Amn is installed tho.. really weird.


Perhaps my initial problem with the golems had something to do with a patch I installed.. after installing ToB I also patched it with:

Baldur's Gate II - ToB - Patch_26498_ENGLISH.exe


After that I installed the Tweak- and Fixpacks


damn.. really frustrating stuff.

dunno if my current problem has something to do with the packs, so don't hate me for posting about it :)



Link to comment

For what it's worth, I think I ran into a variation of this problem on the second floor of Nalia's keep. I kept experiencing major slowdown and finally complete freezing of the game even though there were no enemies in sight. Since I knew that there are some golems on the second level of the keep, after reading this post, I decided to uninstall the 'Paws from Shapeshifting Cannot Be Dispelled" component, which seemed to solve the problem.

Link to comment

I'm fairly surprised to see this implicated in crashes (who truly knows the mind of the Infinity Engine, though?) - I've used something similar myself without any issues other than occassionally stopping the pathfinding algorithm.


I suppose limiting it to stuff in the magical weapon slot (via dupe weapons for shapechange) would be a start.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...