Jump to content

the hell's gates won't open ...

Guest greg-le-bretteur

Recommended Posts

Guest greg-le-bretteur


I'm quite new to installing mods for BG2, I discovered that one or two weeks ago.

I really love BG2 :) and is waiting for an improbable BG3. ;)

So I wanted to try some of these new mods and here is what i installed :

TOB official patch, TOB Fix patch, TDD, Ascension, Longer Road, Solaufein NPC, Valen NPC, and i saw that d0questpack and NPC Flirt Pack were already installed (not figured out how yet, surely with one of the patch).

To resume my problem, I started a game with only TOB installed, and put the mods around the the time I entered the UnderDark. I ended the UnderDark, experienced the undead solaufein (never saw anyone so strong, my strategy is to start the battle, go up the stairs, sleep, and return to battle when some of his protections are off : not very satisfying but i won't pass the day on it), and so on.

I saw a bug on the world map (all the regions were norther than usual) that I put to TDD and was right so i uninstalled it. Then I finished the game, and saw way way too many bugs in the Hell's Trial that weren't there with the original version.

To top it off, when i use the five Bhaal's tears to open the door, my PC gains characteristics as expected, but at the fifth one, the door remain closed, and when I try to open it, it still says "the eyes are watching you" like I did nothing.

And I stand there, waiting .........

BUT what the hell is this ??????

Can someone tell me what to do to fix that ?

I precise I'm using the french version of the game, and there have been mismatches in the dialogs, especially in Hell, where some sentences had no sense (they came from other situations in the game). Another problem with the dialog.tlk file but i don't know if it is related.

The point is I can't finish the game and try the longer Road mod for example !!!

Thank you for you help. :(

Link to comment
Guest Guest

Indeed i tried yesterday to import a game to TOB and it worked neatly.

But why did you say I would be lucky if I finished it ?

I've been roaming any forum or mod site I found for a week, and beyond the fact that most posts are quite outdated, I think I respected the order.

Then uninstalling TDD might be an error, and not starting the game with it (didn't know it existed by then) won't let me benefit of this massive add-on.

I've even made clean installs copying the necessary files on a back-up repertory.

The Question is how are my save files affected with all these mod ? Most weidu-mods apparently don't care for the saves.

Well it is really hard to find posts that are not outdated. I will look at your links of course.


Link to comment

It is me again. I registered in the forum.

You are mocking me Kulyok (no offense intended), i know these links by heart.

I made a clean back-up and tried my best to follow the order.

Just tell me what is wrong in what i did ?

Now i restored a clean-back up, unistalled d0questpack and npc flirt,

installed TDD, Ascencion, Longer Road, Solaufein, Valen,Fade, NPC flirt, d0Quest Pack, and Banter Pack.

Maybe i should put the Quest Pack after the Banter one.


quoting SimDing0 (quest pack v. 2.3 readme writer)



# Quest Pack should be installed AFTER Kelsey and/or Keto to allow their interjections to work correctely.

# Quest Pack should be installed AFTER the NPC Flirt Packs to prevent flirts activating in the new Underdark area.mentionned in the readme to install at the end


Well if I go on I will never stop. Wish you a nice day :(

Link to comment

Several people may have had, but it seems likely that no-one has a simple fix for it, at least not here. You might try asking at PPG and see if the makers of the Flirt and Quest packs know more (though they do show up here too).

Link to comment

As I understand, the problem in the first place was that Flirt/Quest packs were not uninstalled(see the first post). Now, however, yes, it looks more or less okay, though I'd install flirts after all other mods, as per the readme.

Link to comment

Well after reinstalling the mods in the order above (mine i hadn't seen your answers yet), the bug was fixed. The gates now open quite normally. :bday: happy indeed.


The dialogs in the hell trials are now ones that can be expected from the game, so the bug about the dialog mismatch is partly fixed. I think i saw that problem a few times elsewhere in the game, but don't remember if it was after or before the reinstallation.


Something that is quite interesting (in terms of bugs and mods, but annoying in itself), is the mix between french dialogs and english dialogs. The english ones necessarily come from the mods (or the BG3Fix don't know) and sometimes I even have solaufein start a conversation in french (with his fellow friend in suldanessar for example) and then it turns in english, and sometimes even back in french...


In the Hell's trial I have this problem, and it makes me think it comes from the Quest Pack (for the hell's trial only, solaufein's may come from dicussions not translated in his pack).


I also have a little bug in the third chamber, where the PC must choose to sacrifice himself to save one party member or to sacrifice the party member ;) . I choose not to respond to the demon which way i will choose, then I take the evil doors, Korgan (the one abducted) takes damage at each door but nothing happens when i open the third. Then I open the last door of the left way and the demon tells me i chose to sacrifice myself to save my friend and I get Korgan, hardly wounded, back in the party. Well i won't cry for it, quite the opposite, but it's still strange...

I probably will re-install the game in full english (for the fun :beer:) the next time i want to start from the beginning but that won't fix those types of bug.

Well i don't have the time to roam forums and readme files to find every solution to every bug, but i really find it interesting to try to make a clean game. (and then play it ... :( ).


I had another question concerning one game plot. It is about opening the palace doors in Suldanessar. The dialogs there (and especially the log book) introduce the idea that there is another way to enter the palace, without summoning Rillifane avatar and saving the city. I tried different methods but none worked. The scripts refer to something inside the elven temple that would open the door, but there is nothing but the altar where to deposit the three elven artifacts, and a glabrazu that don't attack me cause I'm protected against evil. I tried to dominate the demon (only once), he resisted, I had the idea to give him the items instead to open the door but ... I tried the Slayer form, even tried to summon a lvl 9 demon to destroy the door, for I got the scroll in the city and thought it might be that but....


Thank you for answering my last posts, and reading this long long one :)



Edit : Well no so happy about it in fact. Apparently TDD starts at the end of SoA, I tried it a bit, and weren't interested a bit. But the Real thing is I don't get the saldarine amulet as a reward for defeating Irenicus...

I will uninstall TDD anyway, just not convinced about it yet, maybe for a next time.

BigRob I looked at your link and the Aklon mod. You really making it ? Impressive. ???


New Edit : I had the amulet in my bagpack when I started ToB with the save above. Maybe it is not possible to use it for TDD and explains why i didn't have it at the end of SoA.

Link to comment

Mixing a French BG2 install and English mods is probably not helping with some of the scripting and speech actions, I'd guess that's why you didn't get the Amulet of the Seldarine.



The back way into the Temple is a path that lead around behind the gate on the far right of the map. You still need to kill one big demon to get the Temple doors open, however. Unless there's another way I don't know about.



And yes, I am indeed making Aklon, thank you for the little compliment. :(

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...