Jump to content

Compatibility issues


the bigg

Recommended Posts

Guest notme
Widescreen Mod v3.01 fails to install on a clean install of TotSC 1.3.5521 from 3 CD set, however, it succeeds after installing the "Intl" 5521 patch. This particular requirement isn't mentioned in the README.

 

This is the most useful thing I have read on this forum for the in the past 3 hours. Version 3.04 of the Widescreen Mod doesn't work on the native 5521 3 disc install either. I have yet to find the International Patch, but this would be key information for the README or one of the sticky posts. It sure would save time surfing through the epic rudeness from the moderator.

Link to post

Hi, dudes.

I have instaled BG2 SOA, the lastest Patch and Widescreen Mod in 2560x1440pxl. res. Everything was perfect, than I installed The Darkest Day 103 mod and the screen was cutted off...

.

.

TheDarkestDay-Issue1.jpg

.

.

TheDarkestDay-Issue2.jpg

.

.

Do you know what to do, in order run it in normal view? :laugh:

Link to post
Do you know what to do, in order run it in normal view? :laugh:
That's a know issue...

Uninstall the game, clean the game folder, reinstall the game and patch it and then install the TDD first, then the Widescreen mod.

Or use the never more up to date TDD(might require the ToB) where the GUI mod is not tied to to primary install files, and if you want to, install the GUI mod before the Widescreen mod.

...And then install the Widescreen mod.

Edited by Jarno Mikkola
Link to post

I tryed to instal " TDDv.1.14...and the program told me that need "BG2 Fixpack Core Fixes".

I downloaded - bg2_fixpack-v9.ehe from here: http://www.gibberlings3.net/bg2fixpack/

and start to install it, the last modul (4th - [bETA Core Fixes]) give me an error

.

.

TheDarkestDay-Issue4.jpg

.

.

Because of this I was not able to install TDDv.1.14 :laugh:

Both suggestions didn't work... Some other suggestions?

By the way I'm with Win7...

Link to post
I tryed to instal " TDDv.1.14...and the program told me that need "BG2 Fixpack Core Fixes".
The Core Fixes(component #0) and the Beta Core Fixes(component #3) are different thing... the Beta Core fixes need the BGII - ToB, so just install the BG2 Fixpack component 0 and TDD.

What comes to the TDD v1.03, it copies over the vanilla BGII's BGMain.exe so that it breaks the compatibility with Widescreen mod, as the .exe is not the original... the bigg would need to check that the TDD's patch doesn't brake anything, which is really idiotic to do to a mod that has a better version already available.

Edited by Jarno Mikkola
Link to post

Ah, darn, it seems that that too requires the ToB, as the string 73245 is the "Play Shadows of Amn<TM> with the new area of Watcher's Keep Dungeon"... which is there in the SoA - ToB selection box.

Link to post

So what can I do? Install TOB in BG2 directory?

 

I did it! :laugh:))

1 - install BG2 SoA

2 - Patch it.

3 - install BG ToB

4 - install bg2_fixpack-v9

5 - Install BG 2 - The Darkest Day v.1.14

6 - install widescreen-v3.04

7 - install 2 - BP-BGT_Worldmap

 

For now everything looks good!

Thanks Dude - @Jarno Mikkola! :hm:

Edited by Viktor M.
Link to post
1 - install BG2 SoA

2 - Patch it.

3 - install BG ToB

...

1-2-3... Did you patch the ToB with the (v2.5.)26498 patch, see the SoA patch is already included in the ToB, but the ToB needs to be patched with it's own patch.

Ah, you didn't say you had ToB. :laugh:

Edited by Jarno Mikkola
Link to post

my setup:

  • OpenBSD 6.6-current (Panasonic J-10 laptop)
  • gemrb (0.8.5)
  • Baldur's Gate The Original Saga (included in my GoG BG:EE purchase) (clean) (Fullscreen=1 in GemRb.cfg, 640x480)

i extracted/installed on a Linux machine and applied the mods. only 3 mods installed Widescreen, Tweaks Anthology, SCS. installed in that order. rsync the folders to OpenBSD machine.

when installing widescreen  ... the GemRB option was selected ... set 640x480 and 1440x900

running BG ... i don't get any widescreen 😞

the other mods work (i installed larger stacking numbers for items and get the bolts stacking at 120 correctly)

where did i go wrong?

Link to post

If you want to use 640x480 resolution, you don't have to install the widescreen mod at all. As for 1440x900, you need to set the resolution in GemRB.cfg to this value, too. Basically, GemRB.cfg must have the same resolution you install the widescreen mod with.

 

EDIT: BTW, GemRB 0.8.6 is out 😀

Edited by Caillean
Link to post

Thanks for taking time to reply.

Understood both points.

 

On 12/3/2019 at 5:27 PM, Caillean said:

EDIT: BTW, GemRB 0.8.6 is out

Waiting for the update to pop in the openbsd ports tree.

Local compile works though.

Thanks for all the efforts of the GemRB team.

Link to post
On 12/5/2019 at 10:56 AM, GreyBeard said:

Understood both points.

i think i might have not understood after all Orz~

for the actual gameplay ... it works ... bottom tool doesn't expand to whole screen width, left and right tools expand to screen height

character sheets destroys the UI. as well as the saving/loading UI. is this correct behaviour for the mod?

should i expect the same when i use the mod on BG2?

i keep thinking that my version is not supported by the widescreen mod.

 

TIA

Link to post
Quote

it works ... bottom tool doesn't expand to whole screen width, left and right tools expand to screen height

 

If installed correctly, the action bar at the bottom in the main game screen should expand to screen width. However, all menus (saving / loading, inventory, character record) have a fixed resolution (1024x768 I think) and do not expand. They're drawn centered on the screen, so if that's what you mean by 'destroys the UI', then yes, that's normal. So if you set it up correctly, you should be fine with GemRB 0.8.5 and the latest widescreen mod.

Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...