Jump to content

Geomantic Sorcerer Kit


Recommended Posts

I just ran the Geomantic_Sorcerer-v4.exe and it installed properly, in a way that I did not expect.

I was unable to turn Sorceror Jaheira into a GS because she was not the Protagonist. So I created a Sorceror protagonist, had the Genie turn him into a GS. I exported his file, turned the Chr into a Cre and then replaced everything in the way of gender, names and dialog. Now I have a Jaheira who is a Geometric Sorceror, so far it all seems to be working out.

Link to post

Seems to be way overthinking it, but then I have not inspected the mod's code. It could be totally archaic and weird for all I know. But:

 

- It's a kit mod, so I assume it includes an ADD_KIT command, and a bunch of .SPL files and that sort of stuff to go in its CLAB. So why not just grab this code, along with the abilities, and add the new FL#add_kit macro and voila, you have a functional EE-compatible kit! What's the problem?

 

- I suppose giving Jaheita the new kit is an issue, but that's a separate matter. Once the kit is installed, you could use a technique like that in my NPC_EE mod to assign this class/kit to her. Could be a separate component. (Feel free to use any code from my mod.)

 

- Hmm, but it's a sorcerer kit... so it will be able to select any mage spell that's not in hidespl.2da, when leveling up. And I gather this is supposed to be more like a druid? Can't help you here, the best solution is probably to hijack the entire sorcerer spell selection system and replace it with a new, dialog-based one. Like the one in Tome and Blood.

 

- Which brings me back to, why try so hard to hold onto this ancient, abandoned, obsolete mod, when you can use Tome & Blood which is excellent and designed for the EEs and under active development? And which includes a nature-oriented sorcerer kit, among many other cool sorcerer kits.

Link to post

But he's already done, happily playing. Reminds me of a certain other thread.

 

Why hold on to it? Content. Your suggestion is akin to saying something is broken with the blade, so just use the jester. Yes, they're similar, but hardly the same.

Link to post

Reminds me of a certain other thread.

 

Sorry, I've been kind of sleep-deprived lately, I don't follow.

 

He necro'd a year-old thread, posted an answer to a year-old question, saying in effect, "I got this working for myself but I'm not telling anyone how I did it." Is that really worth posting about? This is a forum for modding and discussion of modding... maybe it would be better to actually discuss *how* to get the kit working. So other people might also get the benefit of using it. Maybe actually update the mod itself to be compatible with the EEs.

 

I don't think the various mods are the same; but one is only designed to work with vanilla TOB, and one is only designed to work with the EE games. All I'm saying is, a user of one engine or the other should use the mod that's compatible with that engine. And if a user wants to make one of them compatible with the *other* engine, and posts to a forum about modding, perhaps some actual discussion of the techniques is in order. That's kind of the whole point of this entire website...

Link to post

"I got this working for myself but I'm not telling anyone how I did it."

I just ran the Geomantic_Sorcerer-v4.exe and it installed properly.

In post #149, the Spoiler shows the installation log. The details showed that I avoided the portraits, that could have been a hassle. Ditto there are no Are files with this mod...

You may find that GS has a lack of problem features, compared to other mods.

Higher level features may crash, but that is in the future.

 

How about a direct link to Tome & Blood?

Edited by Ishad Nha
Link to post

I don't understand how a kit that is successfully installed into the game couldn't be given to a character, based on whether that character is the protagonist? It goes back to Jarno's question of whether the mod is working as intended, or whether you got its assets into your game and then applied it via 'Keeper or NI or some other non-in-game method.

 

Oh, now that I think about it, it could have to do with the way the kit is scripted to be applied to characters. Maybe this was made before the little invisicre kit-change trick was standard procedure...

 

Tome & Blood is here:

https://forums.beamdog.com/discussion/31274/mod-beta-tome-and-blood-more-options-for-wizards-and-sorcerers#latest

 

It's good stuff.

Link to post

GS Readme makes it clear that the kit can only be given via a (modified) dialog with Aataqah at the start of Chateau Irenicus. Only the Protagonist can gain the kit. It has been around for a while...
NPCs are meant to gain the Kit via Level 1 NPCs mod, which is not yet ported to the EE games.

 

Kit name and description remain unchanged, they are still the texts for the trueclass Sorceror.
GS is the only kit in my installation that is not available at the start of the game.
I tried turning an NPC into a Dragon Disciple, both name and description were successfully altered.

 

This is of course a distinctly EE problem, it does not occur in the original BG2. Culprit seems to be ClasText.2da, it exists in BG2EE but not in the original version of BG2. GS is of course a mod for the original version not BG2EE.
I created a new line in the file and I was able to give the GS the class text for the Dragon Disciple. I was able to figure out an accurate entry for the GS Kit:

ca#dsorc 19 43 103237 103238 103237 -1 0 102508 -1
The numbers come from the relevant entry in Kitlist.2da:
43 CA#DSORC 103237 103237 103238 CA#DSOR 63 0x00004000 19

Edited by Ishad Nha
Link to post

GS Druid spells won't be available at the start of the game, not until party rests.
After resting, the three Quick Spell Slots all showed 0 spells available, actual totals were 6,6,4. Only way to update the spells actually available was to re-select the spell for each Quick Slot. Which only takes a few seconds.
Like the problem with Kit name and description not appearing, this bug is not found in the original BG2. Geomantic Sorceror there had Chromatic Orb, Cure Light Wounds and Shield as her three Quick Slot spells.
It is not a problem with other spellcasters.
It is not a problem for Burning Hands or the other spells that are first in their respective spell levels.

 

 

BG2EE may draw NPC files from a fixed source hence they can't be altered mid-game? Presumably the game reads the Cre files for all NPCs at the start of the game.
After the party entered Waukeen's Promenade, I drew up my own version of Aerie. I could not get the game to accept her.


Original Aerie is a multiclass Cleric/Mage. My altered Aerie is a single-class Morninglord of Lathander, she was saved in the file AERIE7.cre.
In AR0604 the party went over and killed the two "Peasants', then we picked up the disguised key. Party remained exactly where it was, out of sight of the original Aerie. CLUAConsole:CreateCreature("AERIE7") was used to summon the altered version of Aerie. She was then given the key and allowed to join the party.
Original Aerie was left where she was while party went over to the stairway.

 

Edited by Ishad Nha
Link to post

These file omits the GS Kit:
CLASCOLR.2da
CLASISKL.2da
CLASTEXT.2da
CLASTHAC.2da
CLSRCREQ.2da
CLASWPBON.2da
HPCLASS.2da
K_S_H, K_S_D, K_S_G, K_S_E, K_S_HE, K_S_HL, K_S_HO
NUMWSLOT.2da
THIEFSCL.2da

After adding GS entries to most of the files I can now create the Kit at the beginning of the game! Won't need the genie.
Still have not solved the Quick Spell display problem.

Link to post

The K_S_H files don't exist - I think even in the EEs, sorcerer kit menus are not externalized. The down side that is, there must be a scripted way to adopt the kit in-game (dialogue, innate ability, or special item). The bright side is, the GS kit code can ignore those files! :)

 

Most of that other stuff is handled by the fl#add_kit_ee code, freely available to make any kit compatible with the EEs:

https://github.com/WeiDUorg/fl-add_kit_ee/releases

 

It's quite easy to use. You can check out my mod (or DRv8, or S&Sv6) for examples.

Link to post

The K_S_H files don't exist - I think even in the EEs, sorcerer kit menus are not externalized.

Someone hasn't played with the most updated version of EE's... cause it sure does in my friends game:

2DA  V1.0
*
                    KIT
1    0
2    35

The 35 being the DRAGON_DISCIPLE ... Description. And in case you didn't notice the human monks too have kits now.

Edited by Jarno Mikkola
Link to post

I will need to learn how to use tpa files, something I have never touched before.
Altering the kit files is not hard:
2DA V1.0
*
KIT
1 0
2 35
3 43

After adding GS entries to most of the files I can now create the Kit at the beginning of the game! Won't need the genie. GS button has no label when you go to choose that class. Clicking on the button will correctly display the kit description, however.

Altering the 2da files was not hard even if they went across the page not down. I copied the contents of the file into a text editor that had provision for turning Word Wrap on and off. Once I was done, I simply copied the altered data back into the file concerned.

 

(The kit could be used in BG1, a GS can start at any level.)

I corrected ca#dsor.2da so that abilities were gained at the correct levels, not all at once.

 


2DA V1.0
****
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
ABILITY1 AP_CA#WSM **** **** GA_CA#DS202 **** GA_CA#DS302 **** GA_CA#DS402 **** GA_CA#DS401 GA_CA#DSSC GA_CA#DS502 **** GA_CA#DS607 **** GA_CA#DS704 GA_CA#DSSC GA_CA#DSTO **** GA_CA#DSSC **** **** GA_CA#DSSC **** **** GA_CA#DSSC **** **** GA_CA#DSSC **** **** GA_CA#DSSC **** **** GA_CA#DSSC **** **** GA_CA#DSSC **** ****
ABILITY2 AP_CA#XPMOD **** **** GA_CA#DS204 **** GA_CA#DS305 **** GA_CA#DS403 **** GA_CA#DS501 **** GA_CA#DS602 **** GA_CA#DS702 **** GA_CA#DS705 **** GA_CA#DSMO **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** ****
ABILITY3 GA_CA#DS103 **** **** GA_CA#DS206 **** GA_CA#DS306 **** GA_CA#DS404 **** GA_CA#DS506 **** GA_CA#DS604 **** GA_CA#DS707 **** GA_CA#DS711 **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** ****
ABILITY4 GA_CA#DS104 **** **** GA_CA#DS207 **** GA_CA#DS315 **** GA_CA#DS407 **** GA_CA#DS516 **** GA_CA#DS605 **** GA_CA#DS717 **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** ****
ABILITY5 GA_CA#DS105 **** **** GA_CA#DS210 **** GA_CA#DS317 **** GA_CA#DS410 **** GA_CA#DS517 **** GA_CA#DS606 **** GA_CA#DS720 **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** ****
ABILITY6 GA_CA#DS110 **** **** GA_CA#DS212 **** GA_CA#DS318 **** GA_CA#DS411 **** **** **** GA_CA#DS610 **** GA_CA#DSSC **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** ****
ABILITY7 GA_CA#DSWS **** **** **** **** GA_CA#DS319 **** GA_CA#DSSC **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** **** ****

 

Edited by Ishad Nha
Link to post

The concept of a .tpa file is very simple. It's just a file with more WeiDU code in it. When you INCLUDE it in your .tp2, it executes the .tpa code as though it was embedded in that spot in the .tp2.

 

I think the add_kit_ee.tpa just defines a function, so if you include it, then you can use the function.

Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...