Jump to content

Sound problem

Guest Horus

Recommended Posts



I successfully compiled and installed gemrb0.2.9 on Yellow Dog Linux working on Playstation 3(ppc).I added line EndianSwitch=1 in cfg file and specified all the paths execpt the ones which says "you probably dont want to sepecify this".

When I write gemrb in terminal

I see:



Duplicate Plug-in


message, and game(BGII) has no sound.I deleted all libNullSound files, then applicatian crashed with a Fault(a two words sentence[it was turkish ,It may be "segmentation Fault or error" but I am not sure]).What's the problem and how to fix it?


Game ran very well(near perfect) with very little problems and some invalid object errors.Intro movies dont play for me even if I set "skipintromovies" to 0.I just played for 5 or 6 minutes because I didnt want to play without sound.


This project is very promising and I am sure it will be perfect.


Link to comment
You must install openal.


I already have openal-0.0.9-0.7 and openal-devel-0.0.9-0.7 installed.There is also openalpp on the list, I have to install it too maybe?

Link to comment
that should be enough. Does the console say anything interesting when gemrb is ran (things in red ;))?



Not really,there are very few errors.

Here they are:


Searching for STONESM2.bam..[ERROR]

Searching for WMAPLAY.2da...[ERROR]


And a segmentation error if I delete libNullSound.la, libNullSound.so, libNullSound.so.0 and libNullSound.so.0.0.0 ,it gives a segmentation(this is the english translation I guess) fault and crashes.


If I dont delete nullsound, It searches for defsound.2da just before autorun starts.If I delete, it says "Music in INITIAL State. Autostarting" just before crashing.


Thanks for the help.

Link to comment

I just realised that not everything on Install cds were installed in the game directory, I will install them and try again, sorry for bothering.

Link to comment
I just realised that not everything on Install cds were installed in the game directory, I will install them and try again, sorry for bothering.


By the way, It was a full install so I am not sure if installing everything on cd will change anything.

Link to comment

I managed to get gemrb work with sound and music, the problem was caused by baldur.ini file pointing to wrong directories.I got another segmentetian fault and crash after game tried to load a music file when I tried to play from an old save game(left from windows).That save file used to work with sound disabled, that makes me think that game is unable to locate the music file, so here is my question:

I did a full installation under Windows Xp and moved it to Linux, is this enough, are there additional files I have to install from CDs, will Linux being case sensitive cause any problems with that and do I have to keep cds in cd drive to play the game with Gemrb under Linux?



Link to comment

So just making a full install under xp and moving it to Linux should be enough and I dont need any cd in the drive.

I will compile,install and configure everything from scratch and retest it with svn version and post the outcome.

Link to comment

Had the same isuue again,tried to load another save game and it crashed again after loading a bmp file, music also doesnt play at main menu.If the saved game is saved in a close area(inside a building for example), game plays fine but when I get out of the building game crashes.I dont have any programming knowledge but I think this may be an Endian issue because if I try to start to game with EndianSwitch=0 game crashes with a Segmentation Fault after dozens of error messages, open areas also crash with a segmentation fault.

I havent played new game long enough to reach an open area yet however.Maybe this is an issue with "under windows saved and tried to load under linux" :) saved games.

Link to comment

Forgot to mention:After grmrb loads Theme.mus it says in console:


Playing: Desktop/Oyunlar/BGII-SoA/music/Theme/themea.acm

WARNING: Unhandled Music state: fbb26f8

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...