Jump to content

Uh-Oh. Help with Baldur's Gate

Guest Guest

Recommended Posts

Alright, so I'm not very good with computers...or Baldur's gate for that matter, so I'll come here to adress some of my troubleshooting needs.


Firstoff, I have Vista. This may be the problem.


What's wrong is I'm trying to get the Console for cheats to open, but I can't. I can't change any of the files that are in the BG2 folder. When I do, and try to save I get (this is for the autorun file):

Cannot create the C:\Program Files\Black Isle\BGII - SoA\autorun.ini file.

Make sure that the path and file name are correct.


I cannot uninstall either when I try I get:


Setup failed to launch installation engine: Error loading type library/DLL



I somehow managed to edit the Baldur.ini file (some time ago so I don't remember how) but the system doesn't seem to notice, since I have the Debug Mode = 1 in place...but the in game console won't load...



If anyone knows how to solve my problem, thanks. For now, I'll just blame Vista.

Link to comment
Firstoff, I have Vista. This may be the problem.
For now, I'll just blame Vista.
Also correct. But don't stop at blaming it - uninstall it :).


I'm pretty sure this is a Vista "security" pain-in-the-arse. My experience with Vista consists of installing it, messing with it for half an hour or so, then reformatting the drive with Linux, so I probably can't be of much help. Maybe this'll help though. Basically you need to give yourself permission to edit the files I think.

Link to comment

The game console won't load probably because you edited the ini file in your compatibility files.


In your BG2 folder, youll see an icon on the top toolbar that says Compatibility files. I believe if you click that you will see a new set of files and baldur.ini will be one of them. Edit it as normal and save it.


If you are the administrator of your computer, you can right click on the BG folder and go to properties. From there, you can edit your settings regarding what you can and cannot do (read, write, execute, etc).


If you have acquired these settings, you can take the baldur.ini in your compatibility folder and cut and paste it to your BG2 folder. Just say yes to move and replace.


Another thing you could try is to go to My Computer. Then to Organize, then Folder Options. If you click the View tab, you can choose to view hidden extensions. Now try to edit the ini file in the BG2 folder and save it.


If that doesn't work, you can always download Banana!.


Note: DONT delete your compatibility files in the BG2 folder. This will erase your settings and saved games.

Link to comment

I run BG2 on Vista just fine, with a pretty heavy modlist. No problems whatsoever.


To do this, though, you need two things:


1. Like Ace mentioned, you need Administrator rights. This is because Weidu creates and modifies files within the Program Files folder (if you install the game there), and Vista doesn't like unauthorized programs doing that - which is just about anything except for Vista itself and Windows Installer. An Admin can ignore those constraints.


2. Turn off User Account Control (UAC). Again, this is a Vista security measure which will mess up BG2. If you have no idea how to do that, see here.

Link to comment

Yes, the trouble is vista, although XP users can also feel the joy of microsoft's treating them like a babycandy.


In Folder Options, turn on "view hidden and system files" and off "hide extensions for known types".


As for the not being able to read, yes, you need to sometimes give specific permission to a folder made by an install. Especially if you accepted the default and it installed it under Program Files, which is now guarded. I'd really suggest installing in Games\Baldur's Gate instead. Really really.

Link to comment

I have a problem too.

I still have win xp (service pack 2).

When I try to install bg 1 two process make their appearance in the task manager:



and... nothing else.


The setup doesn't start.




Anyone know something?

Link to comment
Revy, I'm running on XP sp2 as well, and have had no problems. As stated above, if you're installing to c:\program files try going to someplace else. For me it's on a different HD under f:\games.

No, you see, it's not a problem of path. It's the setup.exe, it doesn't even start.

After a few attempts, I've launched it and decided to let it run. This nearly 1 hour ago and it *is* somehow running, but nothing happened so far.


This is a portion of my task manager


When I launch the bg 1 setup.exe, those two process appears. And it doesn't even show how much memory they are using. Amusing.


Oh, maybe is relevant. My cpu is an Athlon 64, the OS though, is not 64bits

Link to comment

It could be a virus, but more likely, it's your antivirus software (which, ironically enough, can act like a virus). Try disconnecting from the Internet, disabling F-Secure (running the processes fssm32 and fih32) and then running the game.


Also, go to Start > Run and type "msconfig" and click on Startup and see how much crapware listed there you don't need. Google anything you're not sure of and disable whatever you can.

Link to comment


It's a bit different (different version maybe), and it doesn't let me deactivate that voice. :)


I'm not going to uinstall f-secure to get a free antivirus+firewall, because I already tried almost all the freeware ones and they don't protect the pc very well and/or make my pc crash. F-secure uses quite a bit of memory, but since I've installed it I completely stopped to have problems with viruses or spyware. :)


By the way, the game starts instantly (tales of the sword coast setup too). Only plain bg 1 setup has problems :)


But thank you anyways.

Link to comment

I have never used F-Secure so I have no idea if it's causing the problem. If real-time scanning is off, then you should be ok, but you still might want to go into msconfig, disable the services (fssm32 and fih32), reboot and try it then. You can always re-enable the services if that doesn't help.


Your game is installed and runs ok then? Then I guess there's no problem anymore. Maybe it was just a funny CD, or there's some option buried in F-Secure that tells it to scan an entire CD if you try to access it (again, I've no idea there).

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...