Jump to content

[solved] vanilla BG1 item - problem with spell effect


Recommended Posts

I adapted an item for vanilla BG1 (+TotSC) that grants Protection from Evil once a day.


I took the effects specifications from the scroll, and made the item recharge after resting etc. What happens, is that the first time, the granting of the spell functions as it should, but after resting, the spell doesn't work properly. After resting, it seems to be recharged, the icon reappears on the icon menu, but if klicked on it, nothing happens (except the PC looking as if she is trying to do something, but no spell is cast and the icon remains).


If someone with more experience would like to have a look at the item, I would be very grateful. I tried linking to it, but maybe it is too small, as the link won't work. Please PM me your email address, or maybe someone knows the solution without even looking..

Link to comment

There is still something wrong. I changed the charge number to five and took out the "recharges after rest". Still, I can only throw the spell once. The "5" is not shown on the icon bar (?), and if I want to use the item a second time, no spell is cast, although the icon remains and is chosable. :)

Link to comment

Although that advice is invaluable, since that would have been my next mistake; in this case I clua'd it in directly, so I'm a bit confused. I would assume something is wrong, as it didn't show the number of charges, either. I am thinking whether it could have something to do with me copying the effects from the scroll. Maybe I should look at the spell or an item that throws that spell or something like that?

Link to comment

I have a faint recall what the three charges were for. OK, thank you for this information. I didn't know this works for CLUA, too. I will try this tonight!


EDIT: Yes, if CLUAed in with the specified number of charges, it has all 5. But I am unhappy that the icon remains, although the item is used up. It would be nice to see how much charges are left, and the spell icon to disappear once all charges are used.

EDIT: Found it. If a "used item" is defined, the uncharged item can be "replaced by used item".

Thank you again for your help! Now it's working how it should.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...