Jump to content

GemRB Windows Vista X64 - no sound

Guest Guest_SharkyShark_*

Recommended Posts

Guest Guest_SharkyShark_*

greetings - im using GemRB 0.3.0 For windows


i have Vista X64 Edition - and ive got no sound in GemRB

(Baldurs Gate 1 + TotSC), also the game runs slow and fighting etc doesnt work.


any help concerning sound problems ?

Link to comment

Here is a checklist in increasing difficulty:


1. make sure nullsound.dll isn't loaded, or loaded only after the audio plugin. (simply delete/rename nullsound.dll to something not .dll in the plugin dir).


2. install OpenAL


3. upgrade to XP


4. use linux :cool:

Link to comment
Guest lynx

the same applies to you - remove libNullSound.so .


Fighting has been implemented only partly, it is far from complete afaik.

Link to comment
Guest Guest_SharkyShark_*

ok - that nosound.dll has worked

sound works

- thanks :cool:


ok - fighting hasnt been implemented fully - this is the reason why it works so crap ;)


- so 2 cheks made


point 3 : the game is stuttering

the mouse too

any ideas ?

Link to comment

The code is not optimised too much, especially not for Vista.

This includes openal/SDL/Python not just GemRB.


I don't know if it exists, but a 64 bit SDL lib and recompiling GemRB for 64 bits would surely help some.

Link to comment
I have compiled GemRB on my 64-bit system. There's definitely a 64-bit SDL lib for Fedora anyway.

I have to admit, i only speculated that 64 bit SDL would help.

So, what are your impressions, running the original 32 bit code, or running an ALL 64 bit version, 64 bit is better?

Link to comment

Uhm... frankly I can't see much difference. GemRB always ran blazingly fast on my previous 32-bit laptop and it still runs blazingly fast on my 64-bit system.


Seems just as stable too. Good work all round :cool:

Link to comment

If you want to compile gemrb on x64 vista, you'll have to use a good compiler for this, so you have to use visual or intel compiler.

By the way, I'd be interested in knowing if gemrb compiles with mingw-w64 .I can't test it, but it's worth a shot. The problem would be that not every libraries are compiled with it, since it is still very experimental.

Link to comment
I have no sound at all in 32-bit Vista.


nullsound.dll doesn't exist.


In other news, it crashed after character creation.




hmmm that's bad news...

I'll check this later, but I don't have vista at all...


For the character creation, I noticed it was broken even before entering the game. I'll try to write a patch once I finish to reinstall my computer.

Link to comment

I ran it in it's own folder, separate from any other BG folder, and the map was bright green and it stopped responding.


Upon loading an old save (ToB) in the Pocketplane, I recieved the error 'Cannot LoadBackgroud'



Link to comment


This topic is now archived and is closed to further replies.

  • Create New...