Jump to content

Version 8 released


DavidW

Recommended Posts

Version 8 of Sword Coast Stratagems II is now out.

 

Important: I've had to rearrange the component structure for version 8. This means that you need to completely uninstall version 7 (or earlier) before installing version 8; sorry for any inconvenience caused. You shouldn't need to start a new game, though.

 

Version 8 fixes all the bugs I'm aware of from version 7. In particular: we no longer home in on invisible creatures; the new dragons in Abazigal's Lair should function more smoothly; wizards use Oracle slightly less often; incompatibilities between Improved Bodhi and Ascension should now be fixed.

 

New features include:

  • A new "smarter Melissan" component.
  • A new "more staying power for Celestials" component
  • A general rearrangement of components to be more user-friendly (the old structure was getting a bit unwieldy)
  • Lots of small content additions to existing components: Solars are included in "smarter celestials", Odamaron in Sendai's lair gets some allies, Nyalee is included in Improved Minor Encounters, and others.
  • Some tactical optimisations: Azamantes makes much better use of Improved Alacrity, various spell lists are tweaked, wizard use of defensive spells is tweaked slightly, etc, etc.

edit: the mod is now "officially" released, i.e. available from the usual G3 pages etc.

The "official" upload corrects the Ascension bug caught by Temujin. If you're playing with Ascension and you downloaded yesterday, you'll want to download again; if not, don't bother.

Link to comment

Thanks for the update DavidW. I hope you had a nice holiday last week.

 

In any case, one thing I don't like about the current set up is having to choose between arrows of dispelling and improved minor encounters (or was it random?). I personally miss the connection between both, but I'm sure there is something I'm missing that links those arrows with the twisted rune.

 

Thanks again for the update (although I'm currently on a v7 run that's stalled just before going to spellhold).

Link to comment
Thanks for the update DavidW. I hope you had a nice holiday last week.

 

In any case, one thing I don't like about the current set up is having to choose between arrows of dispelling and improved minor encounters (or was it random?). I personally miss the connection between both, but I'm sure there is something I'm missing that links those arrows with the twisted rune.

 

"Improved minor content", if you like.

 

Obviously making every single bit of "minor encounters" into a separate component is unworkable, but you're the second person to make that comment so I'll bear it in mind.

Link to comment
Guest Guest_temujin_*

are all components from ascension absolutely necessary to install scsii?

 

because the "Better calls for help" component is giving some warnings. not sure how bad they are.

 

Warning at src/tpwork.ml.1562

WARNING: cannot find block matching [scsII/help/scripts/gpmage_asc.baf]

 

Warning at src/tpwork.ml.1562

WARNING: cannot find block matching [scsII/help/scripts/gphealer_asc.baf]

 

also, the "Give Ascension demons SCSII scripts and abilities" (6260) simply wouldn't install.

 

ERROR: error compiling [scsii/fiend/ssl_out/demondie.baf]: Sys_error("scsii/fiend/ssl_out/demondie.baf: No such file or directory")

ERROR: compiling [scsii/fiend/ssl_out/demondie.baf]!

Stopping installation because of error.

Stopping installation because of error.

 

// Log of Currently Installed WeiDU Mods

// The top of the file is the 'oldest' mod

// ~TP2_File~ #language_number #component_number // [subcomponent Name -> ] Component Name [ : Version]

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #0 // BG2 Fixpack - Core Fixes: 6.1

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #1 // BG2 Fixpack - Game Text Update: 6.1

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #0 #3 // BETA Core Fixes (please check the readme!): 6.1

~SETUP-ASCENSION.TP2~ #0 #0 // Ascension v1.41 (requires ToB)

~SETUP-ASCENSION.TP2~ #0 #2 // Original Tougher Demogorgon (optional, requires ToB)

~SCSII/SETUP-SCSII.TP2~ #0 #1000 // Detectable spells and effects (required for most other components): v8

~SCSII/SETUP-SCSII.TP2~ #0 #6010 // Better calls for help: v8

~SCSII/SETUP-SCSII.TP2~ #0 #6040 // Give fiends more staying power by increasing their hit points (this component has no effect unless Improved Fiends is installed): v8

~SCSII/SETUP-SCSII.TP2~ #0 #6050 // Improved fiends -> Fiends have fast, uninterruptable innate magic: v8

Link to comment

The "better calls for help" is harmless (though it ought to be fixed).

 

Sorry about the demondie thing - not sure how that one crept in. I'll upload a fix shortly; in the meantime, if you add the line

 

 

scsII\fiend\demondie

 

at line 2200 in setup-scsii.tp2, it should fix it.

Link to comment
Guest _temujin
in the meantime, if you add the line

 

scsII\fiend\demondie

 

at line 2200 in setup-scsii.tp2, it should fix it.

thanks. that worked.

Link to comment
Since you have just released version 8, you might as well re-upload it with these two fixes?

 

Yeah, but it takes 30 seconds (which I had) to describe the workaround, and 20 minutes (which I didn't have) to sort out the upload.

 

It's done now, though: current version fixes these bugs.

Link to comment

Leonardo Watson found an error in sendai/sendai.tph (around line 74):

	COPY_EXISTING 
	~gt002.bcs~ ~override~
	~gt019.bcs~ ~override~
		DECOMPILE_BCS_TO_BAF
		REPLACE_TEXTUALLY CASE_INSENSITIVE ~ANYONE~ ~GOODCUTOFF~

Missing COMPILE_BAF_TO_BCS.

Link to comment
Leonardo Watson found an error in sendai/sendai.tph (around line 74):

	COPY_EXISTING 
	~gt002.bcs~ ~override~
	~gt019.bcs~ ~override~
		DECOMPILE_BCS_TO_BAF
		REPLACE_TEXTUALLY CASE_INSENSITIVE ~ANYONE~ ~GOODCUTOFF~

Missing COMPILE_BAF_TO_BCS.

 

Thanks, will sort.

Link to comment

I found a major bug that causes installation failure (at least when I have SpellPack installed). Many of SCSII's components add/remove/shift around effects. A lot of reading and writing oftsets.

 

This sounds pretty harsh, and this also happens with detectable spells as well, is the macros tend to bring out of bounds parse errors/mess up .spl and .itm files (don't know about .cre files). The reason behind this is that effects in abilities and effect offsets sometimes (see IESDP) use SHORT instead of LONG, and you READ_LONG rather than READ_SHORT in many of the .

 

I have caught one (I went looking macro after macro since you nest so many of them). This fixed a failed installation of the component "Spellstrike affects scroll of PM" on my machine.

 

In scsII.tph, I went to the macro ~transfer_item_abilities_to_spell~ to replace this:

		READ_LONG ~0x6a~ ~item_eff_offset~
	READ_LONG ~0x90~ ~item_eff_num~

with this:

		READ_SHORT ~0x6a~ ~item_eff_offset~
	READ_SHORT ~0x90~ ~item_eff_num~

This is a lot of work, and you know where to find those macros better than I do so I will leave the rest up to you, but this would count as a major fix. Simply making sure LONGs and SHORTs are used where they are supposed to.

 

-Galactygon

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...