Jump to content

Infinite update loop (SCS and others)

Guest Noctem

Recommended Posts

Guest Noctem



When I try to install most mods on BG easytutu, I only get this infinite update loop:

(in this case trying to update from 20200 to 20600)



I've tried removing the .bat file as recommended in this thread:




Most of the problems derive from the G3 auto-update.bats, which were necessary back in the day, but now are not (because the bigg has set up weiDU to do it). The autoupdate routine gets caught in a loop. So the quicker way to do this is to find G3 mods, and take the file




out of the package before running it.


Any G3 mod packaged with .zip or winrar can be easily repaired this way (and I believe almost all follow the G3 template, which uses winrar with sfx distribution, as indicated on the wikki; yet another reason to dislike NSIS installers, as you need to try to extract the mod to the desktop, then delete that file, then move the file to the correct directory, then run the .exe).


We are working through our mods and removing the obsoleted .bat files, but that spring cleaning is going to take some time.


I still get the same problem though. Has anyone else got this? Is there any other solution? Please help. :fish:

(I use the 08 May 2008 version of easytutu)

Link to comment

Just manually update the setup-scs.exe with the newest Weidu.exe . You start by getting one of them from the mod that has one, in your case;

The setup-BG1npc.exe is one, now copy-paste it into the same directory it is in, and so you get copy-setup-BG1npc.exe, now just rename it into setup-scs.exe and you are done. Just run it and the loop is solved.

PS, you need to remove the old setup-scs.exe before the Windows allows you to do that...

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...