Jump to content

Killing Infinite WeiDU Loop Problems


Alain

Recommended Posts

Can someone help? I've tried to install this mod several times, but nothing is working. It installed fine on TuTu, but SoA is giving me so much trouble. I've tried removing and uninstalling various other mods in an attempt to get it to work, but no luck. Here is the error that I keep getting..

 

[setup-Divine_Remix.exe] WeiDU version 196

{Setup-AurenAseph.exe} Queried (pid = 1892) version = 20600 query done.

Newest WeiDU is version 20600, updating!

WeiDU files in version order:

[setup-RE.exe] version 20600

[setup-NPCFlirt.exe] version 20600

[setup-KelseyTOB.exe] version 20600

[setup-Kelsey.exe] version 20600

[setup-EdwinToB.exe] version 20600

[setup-EdwinRomance.exe] version 20600

[setup-edwinflirts.exe] version 20600

[setup-DungeonBeGone.exe] version 20600

[setup-D0QuestPack.exe] version 20600

[setup-bg2fixpack.exe] version 20600

[setup-AurenAseph.exe] version 20600

[setup-Divine_Remix.exe] version 196

Copying [setup-RE.exe] -> [setup-Divine_Remix.exe]: false

[setup-RE.exe] WeiDU version 20600

Auto-Updating on behalf of [setup-Divine_Remix.exe]

Copying [setup-RE.exe] -> [setup-Divine_Remix.exe]:

Auto-Updating on behalf of [setup-Divine_Remix.exe] (done)

[setup-Divine_Remix.exe] WeiDU version 196

{Setup-AurenAseph.exe} Queried (pid = 1880) version = 20600 query done.

Newest WeiDU is version 20600, updating!

WeiDU files in version order:

[setup-RE.exe] version 20600

[setup-NPCFlirt.exe] version 20600

[setup-KelseyTOB.exe] version 20600

[setup-Kelsey.exe] version 20600

[setup-EdwinToB.exe] version 20600

[setup-EdwinRomance.exe] version 20600

[setup-edwinflirts.exe] version 20600

[setup-DungeonBeGone.exe] version 20600

[setup-D0QuestPack.exe] version 20600

[setup-bg2fixpack.exe] version 20600

[setup-AurenAseph.exe] version 20600

[setup-Divine_Remix.exe] version 196

Copying [setup-RE.exe] -> [setup-Divine_Remix.exe]: false

[setup-RE.exe] WeiDU version 20600

Auto-Updating on behalf of [setup-Divine_Remix.exe]

Copying [setup-RE.exe] -> [setup-Divine_Remix.exe]:

Auto-Updating on behalf of [setup-Divine_Remix.exe] (done)

[setup-Divine_Remix.exe] WeiDU version 196

{Setup-AurenAseph.exe} Queried (pid = 1868) version = 20600 query done.

Newest WeiDU is version 20600, updating!

WeiDU files in version order:

[setup-RE.exe] version 20600

[setup-NPCFlirt.exe] version 20600

[setup-KelseyTOB.exe] version 20600

[setup-Kelsey.exe] version 20600

[setup-EdwinToB.exe] version 20600

[setup-EdwinRomance.exe] version 20600

[setup-edwinflirts.exe] version 20600

[setup-DungeonBeGone.exe] version 20600

[setup-D0QuestPack.exe] version 20600

[setup-bg2fixpack.exe] version 20600

[setup-AurenAseph.exe] version 20600

[setup-Divine_Remix.exe] version 196

Copying [setup-RE.exe] -> [setup-Divine_Remix.exe]: false

[setup-RE.exe] WeiDU version 20600

Auto-Updating on behalf of [setup-Divine_Remix.exe]

Copying [setup-RE.exe] -> [setup-Divine_Remix.exe]:

Auto-Updating on behalf of [setup-Divine_Remix.exe] (done)

[setup-Divine_Remix.exe] WeiDU version 196

{Setup-AurenAseph.exe} Queried (pid = 1856) version = 20600 query done.

 

Over and over. Anyway to stop this?

Link to comment

Yes!

 

  1. browse to your game folder, and find the folder "divine remix"
  2. delete the file "Setup-Divine_Remix.bat"
  3. grab a new copy of WeiDU for your operating system - I have linked a windows copy updated to v208 right here in .rar form:
  4. browse back up to your game folder, and delete the old version of setup-divine_remix.exe
  5. put the new WeiDU version in your game folder and make sure it is named setup-divine_remix.exe
  6. run that file.

 

If you still get the error, take a look in other mod directories for things named setup-<<name of mod>>.bat - these are old auto-update scripts that put new versions of WeiDU into a tailspin (they keep asking WeiDU to update itself, but the bigg has made improvements to WeiDU that allow it to update itself, so they keep saying "you go" - "no, you first, man" - "hey, I'm auto-updating here..."- "bugger off, i was here first" - "HEY - back off, buddy" forever.

Link to comment

No problem. It is happening to a number of folks. For the record, and anyone else experiencing the problem, the "generic" solution...

 

  1. browse to your game folder, and find the folder of the mod that keeps looping the process.
  2. delete the file "setup-<<Name_Of_Mod>>.bat"
  3. grab a new copy of WeiDU for your operating system - I have linked a windows copy updated to v208 right here in .rar form:
  4. browse back up to your game folder, and delete the old version of setup-<<Name_Of_Mod>>.exe
  5. put the new WeiDU version in your game folder and make sure it is named setup-<<Name_Of_Mod>>.exe
  6. run that file.

Link to comment

And another version, which I personally find easier;

 

1) Run WeiDU.exe (named WeiDU.exe)

 

2) Press enter however many times it tells you to until it gets to the arguments input

 

3) type in --noautoupdate (exactly as typed)

 

4) Download the latest WeiDU (unless you already have it)

 

5) Repeat step 2.

 

6) Type in --update-all (exactly as typed)

 

7) Install to your heart's content.

 

8) When a new version of WeiDU is released, repeat step 4-7.

 

Icen

Link to comment

Whichever version/way you use, the step that needs to be checked is making sure there are no setup-MyMod.bat files (the old Auto-update routine used by a number of mods before WeiDu became self updating) to make sure everything is ok and works well :)

Link to comment

While I'm sure the your DR mix-module works perfectly as it should, my problem is it doesn't appear to be correct version.

 

I've come across an awesome-sounding mod (Paladins of Faerun) which I'm keen to install; it requires v. 5 of DR - which, of course, is the loopy one. Your module is 20800 and isn't recognised.

 

BTW, I don't appear to have any more .bats in my BG2 folder.

Link to comment
I've come across an awesome-sounding mod (Paladins of Faerun) which I'm keen to install; it requires v. 5 of DR - which, of course, is the loopy one. Your module is 20800 and isn't recognised.
Or... So, just get the DR v5 and manually update it's setup-divine_remix.exe , by deleting it, copying some other setup-modname.exe(v208), and renaming it as the setup-divine_remix.exe .
Link to comment
I've come across an awesome-sounding mod (Paladins of Faerun) which I'm keen to install; it requires v. 5 of DR - which, of course, is the loopy one. Your module is 20800 and isn't recognised.
Or... So, just get the DR v5 and manually update it's setup-divine_remix.exe , by deleting it, copying some other setup-modname.exe(v208), and renaming it as the setup-divine_remix.exe .

 

OK, tried that & now I'm having probs with "translation":"Warning at src/dc.nl.262" :)

Link to comment
Guest asdfghjkl;'
I'm having this problem with the G3 TweakPack for BG2.

qs5w82.jpg

 

Forgive the double post. I accidentally hit return as I was entering my name and posted my message prematurely. As a guest, I am unable to edit it. Anyway, I tried icendoan's solution to no avail. The problem I'm having with cmorgan's is that in my "...\BGII - SoA\BG2_Tweaks" folder there is no "Setup-BG2_Tweaks.exe" file to begin with. I put in the newest version of WeiDU anyway and renamed it "Setup-BG2_Tweaks.exe" but it just opens an MS-Dos window for an instant and then closes it. I'm not sure what to do. Thanks in advance for any assistance.

Link to comment
The problem I'm having with cmorgan's is that in my "...\BGII - SoA\BG2_Tweaks" folder there is no "Setup-BG2_Tweaks.exe" file to begin with. I put in the newest version of WeiDU anyway and renamed it "Setup-BG2_Tweaks.exe" but it just opens an MS-Dos window for an instant and then closes it. I'm not sure what to do. Thanks in advance for any assistance.

The .exe file will not be in the BG2_Tweaks subfolder, it will be in your main BGII directory.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...