Jump to content

Just a small issue (Lovers' Ring)

Guest Eagnai

Recommended Posts



Nothing much of a problem here, but the Lovers' Ring Quest does not seem to work for me this time... I didn't throw the ring away, but Kivan failed to point me to Quataris (I tried talking to Quataris and the Jysstevs without Kivan telling me to do so, but it apparently won't work this way).

I'm pretty sure it worked fine last time I played the mod, so I don't think I've done anything wrong... but if there's any global variable I could change to get on with the quest, I'd be very happy if you let me know. :)


(Kivan does seem to know I have the ring, though, since he's complaining as soon as I sell it or throw it in the sewers.)

Link to comment
Guest guesthjtr

Hi, I also encountered problems with this quest although they were such that I have no reason to complain (and sorry if my english is a bit strange, I am not a native speaker). First time around I used the ring to get the sword and Kivan complained, so I reloaded the game and went to find the merchant. Guess what? The sword was still in my inventory even though I didn't obtain it.


Then the game crashed from something unrelated to this and I reinstalled it and started from scratch. This time I wanted to be smart so I put the hand and the ring in the pipes, then went and gave the ring to the brother of the dead lover, and THEN finished the puzzle, and got TWO swords. The second sword vanished/expired about an (in-game) month later when I killed Faldorn.

I just thought you might want to know this...


Anyway it's likely the best mod I've ever seen

Link to comment
Guest lohjd

Hi, It's me with two lilarcors again


I just returned to inform you that it wasn't a bug. Chislav Juustev (sp?) gives charname lilarcor for the ring, and then it is perfectly possible to go back to the sewers, finish the puzzle and get another. Took me a while to figure that out...


But, you are right, nobody sane (who wanted to stay sane) would want two of those

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...