Jump to content

Innate ability not showing up in game


Recommended Posts

Hey, guys. I'm doing a Wizard Slayer remix and I've given the kit Breach as an innate ability, but it's not showing up in game. Perhaps I have named the file incorrectly?


Here is the .2da:


ABILITY4 GA_TWS **** **** GA_TWS etc.


The spell file is tws.spl.

Link to comment

Have you actually turned the spell into an Innate?

You need to change it to innate at offsets 0x1c and %ability_offset%+0x2.


There's a "make innate" macro in e.g. Divine Remix you can have a look at, if you wish. It is in Divine remix/lib/macro_spell_to_innate.tpa


If you do it with DLTCEP, you need to change Spell Type (under General properties) to Innate and Location (under Extended Effects) to Innate.

Apparently, you also need to change Level (also under General properties) to 1 to avoid certain issues.

Link to comment

Thanks for your reply. The spell was already set to be innate and at level one, but no luck.


I suppose I should add that I used Near Infinity to edit the Wizard Slayer's .2da and am simply having WeiDU copy it to the override along with the edited Breach spell file (renamed).


I checked out the code. Where am I supposed to plug in the spell name, and can it be a spell from my mod folder?


Also, I realized that I do not have a tws.bam. I'm guessing that's a big oops?


I don't know any of the coding to add an ability to a kit. After looking at the code and the Divine Remix .tp2, I have a better idea of what I should be doing to make Breach an innate instead of editing the file itself, but how might I code the ability to the Wizard Slayer?

Link to comment

Here is the current code from my .tp2 concerning the abilities:


COPY ~Joe/Wizard Slayer Improvements/Clabfi03.2da~

~Joe/Wizard Slayer Improvements/spcl131.spl~


INCLUDE ~Joe/macro_spell_to_innate.tph~ // defines patch macro

COPY_EXISTING ~SPWI513.spl~ ~override/tws.spl~ // Breach

LAUNCH_PATCH_MACRO ~spell_to_innate~ // change to innate spell



Still not working. The spcl131.spl has always worked fine. Grrr.

Link to comment

1) I started DLTCEP.

2) I added a few GA_TWSs into the clabfi03 and saved it.

3) Then i took Breach and set it from 'wizard' to 'innate' and it's location from 'spell' to 'innate', then saved as tws.spl.

4) Loaded the new game - all of them were in my innate bar.


Joe, sorry, but I don't really understand what's going on with your game.

Link to comment

Weird. I tried it on EasyTutu, and instead of Breach, the WS was given the Bhaalspawn powers you get early in SoA. Even stranger, I'm only allowed to click the special abilities thing once; after I select a power, I can't use it, and then the button goes gray.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...