Jump to content

Planescape Torment (Segmentation fault)

Guest syncomm

Recommended Posts

Guest syncomm

Thanks for a wonderful product! I have used GemRB with BG2 in Linux (Fedora 9) and had no problems. However, with PST I keep running into an issue:


(only showing error output)

[KEYImporter]: Searching for projectl.ids...[ERROR]
[KEYImporter]: Searching for itemexcl.2da...[ERROR]
[KEYImporter]: Searching for itemdial.2da...[ERROR]
[KEYImporter]: Searching for BISLOGO.mve...[ERROR]
Cannot find /home/syncomm/GemRB/Torment/Install/cd2/genmovB.cbf
[KEYImporter]: Searching for TSRLOGO.mve...[ERROR]
Cannot find /home/syncomm/GemRB/Torment/Install/cd2/genmovB.cbf
[KEYImporter]: Searching for OPENING.mve...[ERROR]
Cannot find /home/syncomm/GemRB/Torment/Install/cd2/movies2.cbf
[KEYImporter]: Searching for STPNOC.png...[ERROR]
[KEYImporter]: Searching for skillsta.2da...[ERROR]
[KEYImporter]: Searching for restmov.2da...[ERROR]
[TlkImporter]: Cannot open tlk override!
[KEYImporter]: Searching for xpbonus.2da...[ERROR]
[KEYImporter]: Searching for qslots.2da...[ERROR]
[KEYImporter]: Searching for itemanim.2da...[ERROR]
[KEYImporter]: Searching for featreq.2da...[ERROR]
[KEYImporter]: Searching for randcolr.2da...[ERROR]
[KEYImporter]: Searching for spawngrp.2da...[ERROR]
[KEYImporter]: Searching for tracking.2da...[ERROR]
[KEYImporter]: Searching for ar0202.wed...[ERROR]
Cannot find /home/syncomm/GemRB/Torment/Install/cd2/AR0202.cbf
[AREImporter]: No Tile Map Available.
[GameControl]: More than one bottom window!
Segmentation fault


I did the install with wine and updated to the 1.1 patch. My GemRB.cfg contains:


GameName=Planescape Torment
VolumeAmbients = 100
VolumeMovie = 100
VolumeMusic = 100
VolumeSFX = 100
VolumeVoices = 100
GamePath=/home/syncomm/.wine/drive_c/Program Files/Black Isle/Torment/


I tried both 0.3.1 and SVN and I have the same issues in both. Any help would be appreciated.


GDB output from SVN:

Program received signal SIGSEGV, Segmentation fault.
0x00186094 in GameControl::OnSpecialKeyPress (this=0xa2410d8, Key=128 '\200')
   at GameControl.cpp:1573
1573            Point mapsize = core->GetGame()->GetCurrentArea()->TMap->GetMapSize();
Missing separate debuginfos, use: debuginfo-install SDL.i386 alsa-lib.i386 audiofile.i386 esound.i386 gcc.i386 glibc.i686 libX11.i386 libXau.i386 libXcursor.i386 libXdmcp.i386 libXext.i386 libXfixes.i386 libXrandr.i386 libXrender.i386 libogg.i386 libpng.i386 libvorbis.i386 libxcb.i386 openal.i386 python.i386 zlib.i386
(gdb) bt
#0  0x00186094 in GameControl::OnSpecialKeyPress (this=0xa2410d8, 
   Key=128 '\200') at GameControl.cpp:1573
#1  0x0018e9fa in EventMgr::OnSpecialKeyPress (this=0x9c13380, Key=128 '\200')
   at EventMgr.cpp:362
#2  0x003cc54e in SDLVideoDriver::SwapBuffers (this=0x9c15528)
   at SDLVideoDriver.cpp:378
#3  0x001bbbab in Interface::Main (this=0x9bfc008) at Interface.cpp:938
#4  0x0804884f in main (argc=1, argv=0xbfaa8f74) at GemRB.cpp:58

Link to comment
Guest syncomm

Issue solved:


All of my biff files had a ";1" at the end, for example:


"AR0202.biff" was "AR0202.bif;1"


I fixed it by running


ls | perl -ne 'chomp; if (/(.+)\;1/) { print "mv $1\\\;1 $1\n" }' | sh


in each CD directory specified in my GemRB.cfg

Link to comment

Hehe, i'm glad you did a self service :)

Maybe report this to the wine compatibility team if you haven't done so yet.


And, eventually we'll provide 'native' installers.

If you are knowledgeable, maybe you can hack one too.

Use unshield, and the existing bg1 installer as a base.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...