Jump to content

Xan Romance - game-stopping error.

Guest Katrin

Recommended Posts

I have BGTutu and the NPC Pack installed (no other mods - all I have installed is Tutu, SoA, and ToB. I don't have ToSC.), and so far have been playing through without a hitch. However, in Xan's romance, when I reach the dialogue which ends with '*the sun rises once more, bathing you in waves of light, and the morning song of birds fills the air, as you walk to the camp. The day begins.*', upon clicking 'end dialogue', the game freezes entirely, and becomes unresponsive. I've reloaded it a fair few times, and still it occurs. The game doesn't crash to desktop; just freezes. I'm hoping that I've overlooked something pretty obvious, as I can see no clear answer and am loath to uninstall and re-install the game, as starting playing from the beginning after having invested much time in it is not exactly a joyous prospect for me.


Thank you!

Link to comment

Katrin, I am still looking - I have not been able to replicate this yet. I don't see anything that would trigger something that might cause crashes/freezing under any cirumstances - will report back this afternoon.

Link to comment

cmorgan: As far as I can see, the dialogue ends with

IF ~~ XanFlirt5.DESCENT
SAY @1046
= @1047
= @1048
= @1049
= @1050 /*~*The sun rises once more, bathing you in waves of light, and the morning song of the birds fills the air, as you walk to the camp. The day begins.*~ */
IF ~~ THEN DO ~StartMovie("FLYTHR03")~ EXIT


So I'd assume there is something wrong with the movie that's supposed to play?

Link to comment

Hmm. If it's an issue with the movie, is there any particular reason why it wouldn't be functioning correctly? All movies so far in the game have been fine. Indeed, if it's not essential, is there any way it can be taken out of the equation at all?


Thank you so far for the helpful replies. :worship:

Link to comment

Hmmm... if I remember correctly, FLYTHR03 is the "enter the elven city" resource from the BG2 movies. I thought all movie references in EasyTutu/Tutu were underscore, so _NDCREDIT.MVE. We have calls to BG2 resources there?


I wonder what happens if you have FLYTHR03=1 already, and a game resource calls on it...


I think nothing bad would happen, because the rest movie plays multiple times with that on. Plus it would have turned up in testing.


Katrin, try loading up your game and seeing if you can get to the "play movies" part (someone help me out here, please, I'm not at a machine with it installed, so I am flying by memory alone).


Check to see what movies you can play back, and see if they all work.


One fix would be to simply disable that particular line, by finding it in NI and deleting that particular movie reference from that dialog transition, but before we go perform surgery, let's make sure your movies are not crashing for other reasons, or we are just going to fix this for you only to have another one clobber you again :worship:


HEY - I wonder if that is a reference to stuff that Macready did not include in EasyTutu - can someone open up a vanilla EasyTutu game in NI and see if all of the movies in the chitin.key are working? To do this (I remember this part) find the MVE list, and click on the named file. If a "play" button pops up, then it is installed on your machine. If an error message comes up, it means Macready did not include this in EasyTutu (he only gathered stuff that would be resonably expected in a BG install, and removed the bg2 movie .biffs, I think, to conserve space on a player's install).


If it is what I suspect, and Xan was created/playtested on a traditional Tutu v4 install/set of installs, then the resource would be there and there would not have been a problem. In which case, the fix is either to scrap that movie call, substitute it for another, or to distribute the .mve with the next version of BG1NPC (and in the meantime, it might be possible to grab a CD3 copy of .biff files and put it someplace, thus allowing you to continue).


(Shaitan, you were playing BGT, right? Because that and Tutu v4 both have all BG2 resources available all the time. Or were you on EasyTutu?)

Link to comment
Hmmm... if I remember correctly, FLYTHR03 is the "enter the elven city" resource from the BG2 movies.

That's right.


FLYTHR03 does appear as installed in my Easytutu directory, without the underscore, and it plays normally when accessed from NI.

Link to comment

Found some peculiar things after poking around with NI - it won't actually allow me to play back any of the movie files at all, even though up until now they have all worked, and play back under the movies section of the game menu. I don't know if it's something unique to my install at all - if it's any help, the cds I've used are quite old, and in some cases loaned to me by people who had lost some of the cd cases themselves, so they weren't exactly in the best of shape. Also, I'm running the game on Vista, which is something of the antichrist of operating systems when it comes to gaming smoothly.


However, what I've done as a quick fix is to disable movies entirely by editing the baldur.ini file, and adding the line "Disable Movies=1" under Program Options. Having done that, the game continues normally, sans movie. Not having movies doesn't bother me particularly, so I may just make do as is. Thank you everyone for your help thus far, though!

Link to comment

Katrin, you are not alone, so we are going to need to do some digging on this one.


I have a second report through Domi, and it is directly related. The user had the same problem at the same point, but I did not connect the two (she did, and pointed it out to me). In her game, instead of freezing, the game began asking for CD4 to be inserted. So, there is definitely a set o circumstances where this movie is not present/read by the engine/whatever.


I checked using NI under XP, and found my full install of EasyTutu and BGT both had the resource there. I then checked again under Vistax64, and NI said the resources were missing from the EasyTutu install.


Next step is to check with Vista users - Shaitan and Daulkman have the movie working, and accessible under NI. I will try to test this weekend, and se if it is a permissions thing, or if some distributions of EasyTutu eat up the movie .biff and others do not.


Until we get the mystery solved, that "editing the baldur.ini file, and adding the line "Disable Movies=1" under Program Options" will be a good tip for people who run into this problem :worship:



The relatively good news - there are precisely 5 StartMovie() calls in bg1npc, and this is the only one that uses BG2 resources, so the problem is not widespread.

bg1npc/phase3/xarom/dlg/x#xanlt.d:3372: IF ~~ THEN DO ~StartMovie("FLYTHR03")~ EXIT

bg1npc/phase3/dyrom/baf/x#da0125.baf:36: StartMovie("%tutu_var%NDMOVIE")

bg1npc/phase3/dyrom/baf/x#da2700.baf:9: StartMovie("%tutu_var%NDCRDIT")

bg1npc/phase3/dyrom/baf/x#dylsta.baf:50: StartMovie("%tutu_var%NDCRDIT")

bg1npc/phase3/dyrom/baf/x#dylstb.baf:51: StartMovie("%tutu_var%NDCRDIT")


(Jastey, if you could send any edits to cmorganbg @ gmail.com, I can merge them with the development copy)

Link to comment

My spacesaver EasyTutu installs (with BG2 uninstalled afterwards) indeed does not have flythr03.mve available, though it is listed in the chitin.key. It's trying to get it from movies/movend.bif, which is in bg2/english/ and isn't copied over to the EasyTutu install as of the 20080508 version.


If you don't uninstall BG2, you're probably safe. But I'd report it to Macready. The EasyTutu page says BG2 can be safely uninstalled after Tutu install, after all.

Link to comment

Excellent. Luckily I retain a saved game from right before when the conversation is supposed to trigger, so I'll keep that around in case it's useful. If it's any help, when I opened the game with NI, the movie files were all present, but if I attempted to do anything at all with them, I'd be informed that access was denied...even though they work in the game menu's movie list.

Link to comment

OK, some confirmations, and info for Domi:


erik (as usual) rocks - installing the latest EasyTutu and leaving BG2 intact shows no difficulty, but any of the following

> adding another (non-registry) EasyTutu install according to Macready's directions

> moving the EasyTutu install to another drive

> uninstalling BG2 from the machine leaving only EasyTutu

> (and of course faking a full install in any way using specific files transferred)


result in either


a. a request for CD4, or

b. a full freeze requiring reboot.


Replicated on both XP SP3 and Vista, so while I really wanted to have it be something simple like Vista permissions, it is a byproduct of EasyTutu-izing. No harm or foul, because there would not be an expectation of need for BG2 movie resources for a Tutu mod, but perhaps we can ask Macready to add that to an EasyTutu update.




For fixing it on our end, we seem to have three options -

1. ignoring this and asking Macready to change Easytutu (and expect that everyone will move up to the new EasyTutu version) which would force random folks to have to come searching for 'why does my game crash on that lovetalk'

2. deleting the movie file reference

3. adding the movie to our distributable.


For full content, 3. seems the best option, but it comes with a caveat (of course). Currently we weigh in at an sfx download of around 6MB. I just extracted the movie file, tossed it in the development copy, and did a test sfx package, and it jumped to 11MB.

Link to comment

Domi, I have Jastey and you as wanting to incorporate the movie file with the distribution, Kulyok has deferred to your wishes, so I read that as 3 yes and two undecideds. Therefore, I am adding the movie to the release version - it jumps the file size, but I have not found a better way of dealing with this (except losing the content).

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...