Jump to content

Save / reload glitch - missing monsters

Recommended Posts

Hey guys,


I just discovered the Baldur's gate games this summer. I just finished ToS and am on to Baldur's Gate II and ToB. I imported my character from the first game and have just started the opening dungeon. It seems sometimes, that when I reload (because I died or felt like trying a different tactic) the monsters I've just fought are no longer around. For instance...


After fighting my way through the library (mephits and goblins) I had gotten all the way to the Druegar, Illych and died. I reloaded right before I opened the door to the library. Much to my surprise, this time when I opened the door to the library, the goblins and mephits were missing. There was still the black fog of war, confirming that I had not yet entered the room, but no monster encounters. This has happened a second time now on the second level of the dungeon with a different mephit. I can't find this problem anywhere else on the internet, on any forum or detailed in any guide. What the hell is going on? Why are these creatures that occupied a room or a hall disappearing upon reload.


I'm running the game in Mac OSX


ToB is installed with the up to date, official patch.


I have the G3 fixpack installed.


I'm playing at 1027 resolution (unsupported)


I imported a level 9 sorcerer from BGTutu.


I can't think of a reason why this is happening. Perhaps at a higher resolution (the one I'm playing at) because more of the screen is visible and thereby I can see more fog of war on the screen, perhaps when I save, it is for some reason deleting the monsters that shouldn't even occupy blacked out screen space because they normally wouldn't be on the screen at a lower resolution. After scratching my head over the matter, thats the best I can come up with. Other than that, the game is working perfectly. The fixpack is working (tested it in a few ways), and its been smooth sailing aside from this little quicksave / reload glitch.


Lemme know what you guys think!



Link to comment

This is an engine bug with the 26499 beta update that the Mac OS X version of ToB is based on.


Basically, enemies that are randomly spawned in a certain way don't get restored when you load a saved game from after they spawned. On the PC, players can simply revert to the 26498 patch, but Mac users have no recourse.


In general, it shouldn't cause you any real issues, only a few less monsters to fight if you save and reload often.

Link to comment

Really? There is no way to fix this problem? Its very annoying. Especially if you want to prove you can beat some of the random monsters that just swept the floor with you. Is this a planned fix for future fix packs? This is a pretty lame bug that merits attention for us mac users.

Link to comment

Is there no one who can offer further assistance? Is there no alternative to the 2.1.2 patch for ToB on mac? This is such a frustrating bug! I get my ass kicked by a group of monsters, reload only to find that they've vanished as if to suggest that I shouldn't even bother trying again. The challenge feels compromised, and the challenge is what I like most about the game. It truly is a shame that this bug is ruining the game for me because I think that BG 2 may be the best game I've ever played. Come to think about it, thats probably why I'm making such a big fuss over this stuff.


Can anyone help me? Is there any way to fix this? Can we collectively figure out a way? I've played around with the options in the config menu and nothing seems to change it.

Link to comment

There really isn't anything we can do about this. The bug exists in the code the game was ported from, and it will exist with or without the 2.1.2 update. Note that random spawning is done in a number of ways, and this bug affects only one of those methods, so although you will lose some randomly spawned monsters, you're not going to be missing all (and depending how often you reload, maybe not even that many) of the fights in the game.


Playing without ToB installed would resolve this issue (although, I've never tried the 1.1.2 update which was released after ToB), but you lose access to all the enhancements provided by ToB. I don't think the trade off is worth it, but you may wish to investigate that if this bug is going to keep you from enjoying the game.

Link to comment

Such a bummer. Do you have any links to other threads about this issue? I can't seem to find any at all. Somebody on another forum (who seemed to be unfamiliar with the mac version of the game) told me to attempt a reinstall. That seems like a potential waste of time according to what you're saying. Its just very odd to me that I can't find any mention of this problem on any forum.

Link to comment

Reinstalling won't help you unless you wish to play without ToB installed.


I'm not aware of any recent mention of this problem. There was a sticky at the BioWare forums when the patch was released where this problem was detailed, but that was more than half a decade ago.


Most PC users just don't play with the 26499b patch.

Link to comment

Four years ago, I searched for an answer for just this problem. I started at the website of the group that ported ToB to MacOSX, Ideas from the Deep. After a couple of hours, I found a personal website of one of group that listed as current projects both a 2.1.3 and 2.1.4 update to ToB but the download link for them was removed. At the time, I hoped to find someone more convincing than me to talk them into letting us "test" it. I ended up not doing anything. And I've forgotten where that website was.


I guess what I'm saying is that there may be fixed versions "out there" somewhere.

Link to comment

SquidSoft. Doesn't exist anymore.


But it's a BioWare bug (from whoever tried to fix the problem where the summoned monster limit wasn't reset if summons were in a different area than the party when they expired), so it's doubtful they would have ever fixed it.

Link to comment
Guest Guest_David_*

ok i'm another pissed off mac user with this same problem and i think i've FINALLY found a way around it. it involves a little gruntwork but if you've got a couple minutes and really want that f**king battle, it should work. You just need to download near infinity for mac and edit your saved game. so go to your save and decompress it so you can select an .are file from the list. open up the area where the fight takes place-- you can find pretty good list of the areas and their filenames here. now look under "Actors" for the type of monsters who disappeared and open one up. hit the edit button at the top and then look at the first "unknown" variable on the list. the one i was doing was the hobgoblin battle at the start of the sewers under the copper coronet and mine looked like this: "Unknown 01 00 48 00 h". If it's one of the ones you need to change it'll have the 01 at the start like that. once you find one simply change that 01 to 00 and then be sure to click "update" so it actually changes. rinse and repeat for all the monster names you think applied to that battle. i guess it might be possible to choose the wrong ones sometimes but at least for the sewers section i was in those were the only hobgoblins around. also i don't know if this might prevent them from spawning as something tougher if you decided not to come back to that area until you were at a higher level. all i really cared about was that i could finally do the damn fight again!!

i have no idea really how the game architecture works in this case. I noticed the first time i loaded the game after making the changes everything was cool again, but then just to test i did a quickload and they all disappeared again. i checked the save file in NI and it was all just as i had left it so i tried quitting out to the "single-player or multi-player" screen and loading the quicksave (this was all done on a quicksave) from there and everything was fine again. i did the battle and did a real save afterward so i could test the quickload again wihout having to redo the fight (fully expecting it be screwed up again) and this time everything was fine even doing a quickload directly from in-game. sooooo..... basically i have no idea what was going on there, but i do know that changing that "unknown" variable in NI fixed the problem for me. hope this wasn't too convoluted a message and that maybe it can help some other frustrated bg2-mac lovers. cheers all!

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...