Jump to content

Every once and a while...Characters refuse to move.

Recommended Posts

This bizarre, frequent bug has occurred on two installations of mine. One with ToB and one pure SoA. It occurs with or without the G3 Fixpack. After a while of playing normally with no problems, I'll issue a movement command to my party only to find out that they aren't responding. Either they do not respond, respond slowly (two go the their positions at a time, the others wait a long while then two more go to their positions, etc) or only one will move. Also, I can't seem to make them walk across the map when this happens. The only way to get them to move at all is to select a new location very near to their current one.


This problem is solved by restarting the game, but it pops up pretty regularly, although I haven't determined if there is a pattern or a reason for this occuring in terms of game play. It is a pretty obnoxious little bug that makes me close down the game and restart from time to time. But I can quick save while the bug is happening, quit the game, re open it, reload the quick save and the problem is fixed.


I just want to know if there is a permanent fix for this nonsense.


Here is what I have installed.


Mac Throne of Bhaal 2.1.2

G3 Fixpack

Link to comment

This is a known issue with the Mac OS X ports of BG2, ToB, and IWD, running on Mac OS X 10.4 or greater.


As you note, the issue can only be worked around on affected systems by restarting the game, so you'll want to save often.

Link to comment

First thing I'd do is check the Path Search Nodes in your baldur.ini file. If the number is too low the characters can seem to get stuck at different points in the terrain.


According to the game's readme.txt file valid values are 4,000 to 400,000


I don't know if adjusting it will correct your problem, but it is a possibility...

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...