Jump to content
DeathAngel

BG2: Problems and bug reports

Recommended Posts

Fixed a bunch of stuff. One item was moderately important, others were back-burner items.

 

  • Fixed joining dialogue... again. Now PCs who broke the engagement in BG1 get more than 1 dialogue choice. (Repaired error introduced in v16)
  • Fixed Gavin's auto-heal script so that he will no longer attempt to heal an invisible or sanctuaried PC
  • Fixed Windows audio installation script so that it will install BG2 sounds on BGT installations that include BG1 Gavin
  • Any character may now create herbal concoctions
  • Minsc's belt is now usable by fighters as well as rangers
  • Replaced b!aley.* with Keldorn Romance b!aley.* to avoid installation order issues

Share this post


Link to post

Ah, OK, I see it. This isn't a fatal error. It would have just looped you back into the PID menu again. I'll fix it for the next version up. If something game-critical comes up, I'll fix it soon, but otherwise, it might be when I release ToB, which won't be terribly long.

 

Thanks for the report!

Share this post


Link to post
Guest Guest_darlarosa_*

I do not have too much time to post this

 

but High Mornmaster Arval is not appearing after Gavin has been half turned.

Share this post


Link to post

This will be addressed when the ToB version comes out, but High Mornmaster Arval isn't necessary to restore Gavin. Gavin follows the same resurrection plan that the other love interests do.

 

Originally, I thought I might do something different, here, but in the end, I decided that it's up to the deity to decide when a dawnbringer's work is done or not. So there was no need to go through any extra hoops to get Gavin restored to life.

Share this post


Link to post

I dunno if someone had already had this, but I'll post it anyway. It's a pretty minor bug, but nonetheless annoying. I have BGT installed and had Gavin in my party when we reached Ducal Palace. I talked to Belt and he transfered us to BG2, but upon closer examination, I founded that Gavin was still in my party (Chateau Irenicus). She was unselectable, but he said his voiced clips upon right-clicking upon his portrait. 'Reform Party' button had no effect, whatsoever. But I realoded the game and kicked Gavin out, before talking to Belt and everything went smoothly, upon our 'fortunate' reunion in the temple of Ilmater. :):beer:

Share this post


Link to post

Heya again :)

 

Line 1255 and 1267 in gavin_bg2\dialogue\b!pid.d:

+ ~InParty("HaerDalis") 
  InMyArea("HaerDalis") 
  !StateCheck("",CD_STATE_NOTVALID)~ + ~What do you think of Haer'Dalis?~ + pp_HaerDalis

+ ~InParty("Keldorn") 
  InMyArea("Keldorn") 
  !StateCheck("",CD_STATE_NOTVALID)~ + ~What do you think of Keldorn?~ + pp_Keldorn

The StateCheck()'s should prolly check for "HaerDalis" and "Keldorn" respectively :beer:

 

Prolly ignorable though :D

Share this post


Link to post

There's a problem with b!keldorn.baf. As it extends Keldorn.bcs for a banter with Gavin an

 

InParty(Myself)

 

is not enough. A

 

InParty("B!Gavin2")

 

is also required.

A gamer over at the kerzenburg forums reported a complete freeze of BG2, including a CTD. As the gamer didn't have Gavin in his party, Keldorn tried in vain to begin a dialogue with him.

 

10th

Share this post


Link to post

I'll look into it. Unfortunately, I can't do anything about it until the weekend.

 

Edit: Thinking about this, it's very odd. I usually add checks for both NPCs. And I usually include checks to make sure that the NPCs can see each other and aren't dead, silenced, or otherwise unavailable for dialogue. I'll check the triggers when I get home, but that won't be for many, many hours.

Edited by berelinde

Share this post


Link to post

There's the usual CD_STATE_NOTVALID condition for both NPCs in the IF part, but it appears that that wasn't enough.

 

10th

Edited by 10thLich

Share this post


Link to post

Must have originally put it in Gavin's script, changed it to Keldorn's and forgotten to switch the tags. I'm still surprised I don't have a See("B!Gavin2"), but mistakes happen. Perhaps future testing should include runs when the NPC mod is installed but the NPC is not in the party, since this seems to be the source of the last two errors. I'm still not home, and I still won't be able to update until the weekend, unfortunately.

Share this post


Link to post
Guest MysticFlame303

Hello Everyone,

 

I recently downloaded the BG2 Gavin NPC mod with a BGT installation. For some reason when I found Gavin's ring in Irencius' dungeon, the dialogue box that should have popped up, did not. I only notice it now because the box is coming up during the first dream of the Imoen romance. It is very odd, and I would appreciate it if anyone could help me with this. Is it possible to initate the ring dialogue by entering in a certain string in the CLUA console?

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...