Jump to content

BG2: Problems and bug reports


Recommended Posts

Hm, seems the dialogue got somehow stuck, so it triggered at the next possible occation (the dream), since the engine is stupid - it doesn't notice which talk is to trigger but takes the first one which trigger gives true. Logically, the dream is now stuck and will come next time instead of something else.


Try talking to your PC with another NPC, sort of "PID" but for your PC - maybe that works?

Link to comment
Guest MysticFlame303

Hi Jastey,


I think your assessment sounds about right; however, I am not a modder so I cannot be certain about anything when it comes to scripts. ;) I did try your suggestion, but it still doesn't trigger before the dream sequence. Thank you for trying!

Link to comment

Hm, did you try opening the ring description? I have Imoen pick it up by habit because she's removing the trap - and that seems to delay the dialog (at least it does in my game). When I put it to my PC's inventory that doesn't help either. But then I open the description of the ring and go back to gaming it fires as soon as I left inventory mode. -I play tutu though, so I'm not entirely sure about BGT.-

Link to comment
Guest MysticFlame303

Thank you to everyone that has been giving me advice on this issue! I really do appreciate it. ;) I managed to fix my problem, and so I will explain how I did so for anyone who encounters the same analomy.


I searched through the entire Gavin folder for something that would trigger or override the ring dialogue, and I found it within The global text document that is in the docs subfolder. It contains all the global variables for the game, and gives a short explanation of them (very helpful I must say!). Using shadowkeeper I was able to compare the global variables before and after the ring dialogue fired during the dream sequence, and I found that the ("B!GAVRINGPLACED") global was set to 1, and the ("B!GavBG1ROM") was set to 1 <That was my preference>. So I simply reloaded the game before the dream sequence, and typed this into the CLUA console: CLUAConsole:SetGlobal("B!GAVRINGPLACED","GLOBAL",2) and CLUAConsole:SetGlobal(B!GavBG1ROM","GLOBAL",1). For anyone else having this problem, I recommed you read the global text, because the variable 1 means that my PC did not romance Gavin in BG1.


So that's all there is to it! Thank you berelinde for making this great mod. ;)

Link to comment

Glad that file was able to help you! I debated for quite a while before deciding to leave it in the docs folder. A lot of times, players start changing globals because they want to speed up the romance or run multiple romances simultaneously. Since many mod events are a combination of variables, this tends to break their games instead. With this mod, I adopted an "If you can't beat 'em, join 'em" approach. I tried to keep the code as simple as possible (with mixed results), included an impossibly short romance timer, and added a multi-romance cheat as an installation option.


I'm guessing that some mod is adding an "always true" block to the area script, preventing the ring dialogue from happening, but at least you were able to find a workaround.

Link to comment

Oops. Something has gone badly wrong with my Gavin Romance. Everything was going swimmingly and there was even an engagement and talk of having children. But the romance never seemed to develop after that. I assumed that things might continue in TOB, but now that I'm in TOB, I can't even initiate conversations with Gavin -- he has nothing to say.


Just before my party went into the battle with Irenicus (on the Tree of Life) Gavin pledged undying love, so I assume all was okay at that point. I've read something about a ring in the posts above. I don't recall finding a ring. Would that be something to do with it? Where is it?

Link to comment

Gavin's got nothing to say to you in ToB because the mod has no ToB content. Yet. I'm working on it at this very moment.


If he pledged his love to you, everything is going fine, just keep your save from before the ToB transition for when the ToB part gets done. Sorry it's taking so long.

Link to comment

I think I have an issue with Gavin. Started a new game, met Gavin in the Slums Temple, (never met before), went to Temple District, cut scene started, first dlg for PC to respond I nicely opted out of the remaining talk, Gavin left party. I completed the Hendak-Slaves and Renal-Mae quests before going back to get Gavin. When I completed both quests, (multiple days later), I picked Gavin up at the Docks Temple. He said bye to Lanie, Gavin joined, got the banter between Gavin and Edwin about breaking his staff, then got two reminders about going to the Temple District to check on the spell. Any ideas what is going on here?

Link to comment

Tried it again with almost the same outcome. The only difference between this run thro and before was I did not get Gavin's banter with Edwin about breaking Edwin's staff.


The party before picking up Gavin was: PC-Fem CN F/M/T, Minsc, Kivan, Jaheira, Yoshimo and Edwin. (Might be worth noting-RE_YoshimoSex=1, AnomenRA=3, EdwinRA=1) Party killed Mae, left there and went to Docks Temple. Made the pre-Gavin save outside the temple before talking to Gavin. (PC hasn't told Renal the task to kill Mae is done.) Talked to Gavin and he joined again, (removed Yoshimo to add Gavin). Immediately got this talk from Gavin- "I don't mean to impose...you said we'd go to the Temple District...divination spell. PC-And we'll go soon, Gav-Thank you. Then Gavin-We should go soon. Do you want to go now?, PC-This isn't really a good time...not much longer. Gav-All right, I'll wait...

I made the post-Gavin save here, then just like before, the talk starting with "About the whole...incident...before w/Lanie" appeared before leaving the temple.


The B!Gav global variables in the pre-Gavin save: Bender=1, BG1Rom=1, DrunkT=60123, GoToTemple=1, Gavin2Spawn=2, Join=1, Lanie=4, Leveled=8, Love=1, Met=1, MIRT=330162, MT=3, NoBG1=1, NPC1_2_3Spawns=1, Oghma=1, RA=1, RingPlaced=2


The B!Gav global variables that changed in the post-Gavin save: GoToTemple=3, MIRT=313352, MT=4, Oghma=2

Gavin's Locals: DrunkTSet=1, Slums=1 and HealInstalled=1

Link to comment

I would like a look at your saved game? Can you zip the relevant save game (I need both the .sav file and the .gam file) and email them to my screen name, berelinde, at gmail dot com? I am on vacation in upstate New York and will not be able to check this out until Monday night, but I can find out what's going on then. Worst case scenario, I can set your globals to resolve the matter.


Since you recently updated the version, I am inclined to think this is a reinstallation issue. The code is working for many other people, so it does seem to be unique to your installation. No matter what, though, we can get it fixed.


Whenever you uninstall or reinstall a mod, you run the risk of corrupted scripts. The mod you uninstalled or reinstalled does not even have to be Gavin. You could have reinstalled a flirt or banter pack further up your installation list and run into trouble. It happens. That's why most modders, myself included, recommend a clean installation whenever you update your mods.

Link to comment

I will try a few other things between now and Monday. Maybe I can figure out a way around this. If not, I will send the saved game to you Monday. But, I can say for sure that it is not a un/reinstall issue, since I never un/reinstall. When I update mod versions, just like this time, it is always done on a clean install-no exceptions. Anyway, thanks for your time.

Link to comment



Gosh, I really didn't want to have to be a bother, but it seems like I'm in a bit of a pickle. I've heard great things about playing Gavin and so I thought to give him a try.


I downloaded 'Gavin V.20' just fine.


I even unzipped the Gavin_bg2-V20, and that too worked just as well.

I put it into the C:\Program Files\Black Isle\BGII - SoA directory.

I then proceed to install the Setup_Gavin_Bg2.


However, this is what I keep getting when I try for the Setup_Gavin_BG2:





Some sort of information on what I'm doing wrong here, or what could be the problem would be more then welcomed and appreciated.


-Thanks for your time.

Link to comment
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...