Jump to content
Demivrgvs

Hotfixes for IR v3 Beta (September 12th 2013) - OUTDATED

Recommended Posts

Hi.

I am having a CTD when I am casting SCRL09.ITM "Protection from Undead" and I think its due to IR.

 

First: An Assertion failed in CGameAIBaseActions.cpp at line number 2096 is the error message

 

Second : Weidu Log

WeiDU.txt

 

Third: Change Log

[WeiDU.exe] WeiDU version 23100
[WeiDU.exe] Using scripting style "BG2"
override/scrl09.itm
override/scrl09.itm bg2fixpack/backup/3/scrl09.itm
override/scrl09.itm item_rev/backup/0/scrl09.itm
override/SCRL09.ITM MixMod/backup/24/SCRL09.ITM

Mods affecting SCRL09.ITM:
00000: /* from game biffs */ ~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ 0 0 // BG2 Fixpack - Core Fixes: v9.13
00001: ~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ 0 3 // BETA Core Fixes (please check the readme!): v9.13
00002: ~ITEM_REV/ITEM_REV.TP2~ 0 0 // Item Revisions by Demivrgvs: V3 Beta 1.7
00003: ~MIXMOD/MIXMOD.TP2~ 0 24 // Increased Scroll Stacking -> Increase Scroll by 100%

 

Fourth: Item file in question

scrl09.txt Changed to txt so to upload

 

When replacing the scroll in question with a backup from IR folder, no CTD but crappy old version of the scroll.

If any more information is needed, just point me in the right direction.

Thanks for any help.

Share this post


Link to post

Hi.

I am having a CTD when I am casting SCRL09.ITM "Protection from Undead" and I think its due to IR. ...

 

When replacing the scroll in question with a backup from IR folder, no CTD but crappy old version of the scroll.

If any more information is needed, just point me in the right direction.

Thanks for any help.

A similar issue was reported ages ago, but it was fixed, and it seems you're using the recent Beta 1.7 so you should be fine. I tried on my install and the scroll works fine.

 

Try instead to use the one within MixMod/backup/24/SCRL09.ITM, which is IR V3 one before mixmod affects it. I really don't know what that mod does, but it could be it. Let me know if it works.

Share this post


Link to post

Hi Demi

 

A similar issue was reported ages ago, but it was fixed, and it seems you're using the recent Beta 1.7 so you should be fine. I tried on my install and the scroll works fine.

 

Try instead to use the one within MixMod/backup/24/SCRL09.ITM, which is IR V3 one before mixmod affects it. I really don't know what that mod does, but it could be it. Let me know if it works.

 

Thanks for your time in answering. Trying MixMod backup was the first thing that I tried but had the same result in a CTD.

I'm stumped and not sure what to try next. Any suggestions???

Share this post


Link to post

As soon as I get back from work I'll check if somehow the latest hotfixes uses a non-fixed scroll, but it is unlikely. Other than that I don't know, I can attach here my working scroll's files (itm and spl) so you can locally fix it, but I'd really prefer to find out what's the cause of the issue, because a possible ctd is not something I can live with.

Share this post


Link to post

Hi Demi

 

As soon as I get back from work I'll check if somehow the latest hotfixes uses a non-fixed scroll, but it is unlikely. Other than that I don't know, I can attach here my working scroll's files (itm and spl) so you can locally fix it, but I'd really prefer to find out what's the cause of the issue, because a possible ctd is not something I can live with.

 

Busy I guess?

 

I have played around with the itm and spl files for hours and am no further on. Always comes back to IR files being bugged and CTD. Going to try a new install and see if that makes any difference.

 

Thanks for taking a look.

Share this post


Link to post

Hi Demi

 

As soon as I get back from work I'll check if somehow the latest hotfixes uses a non-fixed scroll, but it is unlikely. Other than that I don't know, I can attach here my working scroll's files (itm and spl) so you can locally fix it, but I'd really prefer to find out what's the cause of the issue, because a possible ctd is not something I can live with.

 

Busy I guess?

 

I have played around with the itm and spl files for hours and am no further on. Always comes back to IR files being bugged and CTD. Going to try a new install and see if that makes any difference.

 

Thanks for taking a look.

Noooo! Sorry I'm getting old and following too many things at once made me forgot this. Unfortunatley my guess was good, though I really don't know how the hell that happened! Anyhow, I'll upload the hotfixes again after trying to understand if we messed up something by crossing up different updates.

 

In the meanwhile I'll attach here the working files for the scroll of ProUndead. Sorry again.

Edited by Demivrgvs

Share this post


Link to post

Hi Demi

 

As soon as I get back from work I'll check if somehow the latest hotfixes uses a non-fixed scroll, but it is unlikely. Other than that I don't know, I can attach here my working scroll's files (itm and spl) so you can locally fix it, but I'd really prefer to find out what's the cause of the issue, because a possible ctd is not something I can live with.

 

Busy I guess?

 

I have played around with the itm and spl files for hours and am no further on. Always comes back to IR files being bugged and CTD. Going to try a new install and see if that makes any difference.

 

Thanks for taking a look.

Noooo! Sorry I'm getting old and following too many things at once made me forgot this. Unfortunatley my guess was good, though I really don't know how the hell that happened! Anyhow, I'll upload the hotfixes again after trying to understand if we messed up something by crossing up different updates.

 

In the meanwhile I'll attach here the working files for the scroll of ProUndead. Sorry again.

 

Oh dude that is bad, as I play with several players in NZ and Australia and I have been telling them all to stay away from IR 3 (beta) has it is buggy between it's versions and has limited Modder susupport because of my exexperiences. Maybe i will look at IR 3 when it is out of beta and you have less on your plate???

Share this post


Link to post
Oh dude that is bad, as I play with several players in NZ and Australia and I have been telling them all to stay away from IR 3 (beta) has it is buggy between it's versions and has limited Modder susupport because of my exexperiences. Maybe i will look at IR 3 when it is out of beta and you have less on your plate???

 

Hi Demi

Just letting you know I have told all who I play with that the above was wrong in that IR3 is not buggy but was due to a mix up.

Thanks again for sorting this out

Share this post


Link to post
Noooo! Sorry I'm getting old and following too many things at once made me forgot this. Unfortunatley my guess was good, though I really don't know how the hell that happened! Anyhow, I'll upload the hotfixes again after trying to understand if we messed up something by crossing up different updates.

 

 

Um...

So are the hotfixes getting an update or what???

Share this post


Link to post
Noooo! Sorry I'm getting old and following too many things at once made me forgot this. Unfortunatley my guess was good, though I really don't know how the hell that happened! Anyhow, I'll upload the hotfixes again after trying to understand if we messed up something by crossing up different updates.
Um...

So are the hotfixes getting an update or what???

Hopefully tomorrow. I wanted to check a few more things before updating it, since I already provided the fix to you and to anyone following this topic.

 

Edit: Hotfixes updated. The only change is the ProUndead scroll fix.

Edited by Demivrgvs

Share this post


Link to post

Hello im trying to install laest IR with the new BWS and get an error. any ideas?

 

 

##### Item Revisions #####

### 0000: Item Revisions by Demivrgvs ###

Ready for installation

Setup-item_rev.exe --noautoupdate --language 0 --skip-at-view --quick-log --force-install-list 0 --logapp

[setup-item_rev.exe] WeiDU version 23100

[setup-item_rev.exe] Using scripting style "BG2"

Using Language [English]

Couldn't open the readme: file not found.

Installing [item Revisions by Demivrgvs] [V3 Beta 1.7]

loading 1 tra file

loading 1 tra file

Copying 1 file ...

ERROR: error loading [item_rev/itm/axiom1.eff]

Stopping installation because of error.

Stopping installation because of error.

ERROR Installing [item Revisions by Demivrgvs], rolling back to previous state

Will uninstall 0 files for [iTEM_REV/ITEM_REV.TP2] component 0.

Uninstalled 0 files for [iTEM_REV/ITEM_REV.TP2] component 0.

ERROR: Unix.Unix_error(20, "stat", "item_rev/itm/axiom1.eff")

Please submit a report regarding this problem, including the information contained in SETUP-ITEM_REV.DEBUG to Demivrgvs and Mike1072 at forums.gibberlings3.net

Automatically Skipping [item Revisions by Demivrgvs] because of error.

Using Language [English]

NOT INSTALLED DUE TO ERRORS Item Revisions by Demivrgvs

Press ENTER to exit.

Share this post


Link to post

Hello im trying to install laest IR with the new BWS and get an error. any ideas?

 

 

##### Item Revisions #####

### 0000: Item Revisions by Demivrgvs ###

Ready for installation

Setup-item_rev.exe --noautoupdate --language 0 --skip-at-view --quick-log --force-install-list 0 --logapp

[setup-item_rev.exe] WeiDU version 23100

[setup-item_rev.exe] Using scripting style "BG2"

Using Language [English]

Couldn't open the readme: file not found.

Installing [item Revisions by Demivrgvs] [V3 Beta 1.7]

loading 1 tra file

loading 1 tra file

Copying 1 file ...

ERROR: error loading [item_rev/itm/axiom1.eff]

Stopping installation because of error.

Stopping installation because of error.

ERROR Installing [item Revisions by Demivrgvs], rolling back to previous state

Will uninstall 0 files for [iTEM_REV/ITEM_REV.TP2] component 0.

Uninstalled 0 files for [iTEM_REV/ITEM_REV.TP2] component 0.

ERROR: Unix.Unix_error(20, "stat", "item_rev/itm/axiom1.eff")

Please submit a report regarding this problem, including the information contained in SETUP-ITEM_REV.DEBUG to Demivrgvs and Mike1072 at forums.gibberlings3.net

Automatically Skipping [item Revisions by Demivrgvs] because of error.

Using Language [English]

NOT INSTALLED DUE TO ERRORS Item Revisions by Demivrgvs

Press ENTER to exit.

It fails copying the very first file of IR...very strange. At first glance I have really no idea what it could be, I'll look into it.

Share this post


Link to post

It is anything but IR's own fault. Seems like BWS has failed to unpack the mod properly. I'll drop a link in their forum.

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...