Jump to content
Demivrgvs

Hotfixes for IR v3 Beta (September 12th 2013) - OUTDATED

Recommended Posts

I know that the BWS beta can't auto-download the file from Mediafire due to something on Mediafire's end. I always had to manually download it, but didn't have any problem on the install

snippet of one of my test installs with the BWS

~SETUP-ITEM_PACK.TP2~ #0 #0 // Item Pack: v1.7

~SETUP-ITEM_PACK.TP2~ #0 #1 // Extra Items: v1.7

~SETUP-ITEM_PACK.TP2~ #0 #4 // More Distinguishable Items: v1.7

~SETUP-ITEM_PACK.TP2~ #0 #5 // Familiar Faces: v1.7

~SETUP-ITEM_PACK.TP2~ #0 #6 // More Work for Cromwell: v1.7

~SETUP-ITEM_PACK.TP2~ #0 #7 // Pocket Store: v1.7

~SETUP-ITEM_PACK.TP2~ #0 #8 // Item Pack for Tutu/BGT: v1.7

~ITEM_REV/ITEM_REV.TP2~ #0 #1020 // Potion Revisions: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #1030 // Store Revisions: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #3 // Allow Spellcasting in Armor -> With Casting Speed Penalties for Arcane Casters: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #8 // Heavy Armor Encumbrance -> Dexterity Penalties: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #9 // Allow Thieving Skills in Armor: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #1050 // Revised Armor Bonuses: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #10 // Revised Shield Bonuses: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #11 // Dual Wielding Changes for Light and Heavy Weapons: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #12 // Items of Protection Can Be Worn with Magical Armor: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #13 // Halberds Can Slash, Too: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #1093 // Remove Weapon Restrictions from Multi-classed Divine Spellcasters -> Clerics and Druids, With Halved Specialization: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #15 // PnP Equipment for Druids -> Druids Only: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #17 // Weapon Changes: V3 Beta 1.6

~ITEM_REV/ITEM_REV.TP2~ #0 #18 // Backstabbing Penalties for Inappropriate Weapons -> Backstabbing Penalties Only: V3 Beta 1.6

~MIXMOD/MIXMOD.TP2~ #0 #4 // Increased Ammo Stacks -> Increase Ammo by 200%

~MIXMOD/MIXMOD.TP2~ #0 #11 // Increased Gem and Jewelry Stacking -> Increase Gem and Jewelry by 200%

~MIXMOD/MIXMOD.TP2~ #0 #18 // Increased Potion Stacking -> Increase Potion by 200%

~MIXMOD/MIXMOD.TP2~ #0 #25 // Increased Scroll Stacking -> Increase Scroll by 200%

~FREEACT/SETUP-FREEACT.TP2~ #0 #10 // PnP Free Action: v2

~ATWEAKS/SETUP-ATWEAKS.TP2~ #0 #100 // Restore innate infravision to Half-Orc characters: v3.81

 

if the person trying it didn't have the BWS beta set to pause on errors it could possibly produce what was posted a few posts above

Share this post


Link to post

If that is due to BWS vs Mediafire issues, then it explains then how the log still shows the 1.7 version - which is applied from BWP's fixpack.

 

The base mod archive is located here, you'll need to unpack it into the game directory. You'll know you've done it right if you'll see there the item_rev folder and the setup-item_rev.exe file.

 

 

Edited by Ardanis

Share this post


Link to post

The issue brought up by Sterling Archer is probably due to using v1.7 while BWP only has compatibility fixes for version up to 1.6, according to Dabus here on SHS. Hopefully Demi has time to see with the BWP people what has changed with version update and how they can fix it for BWP.

Edited by Adanedhel

Share this post


Link to post

BWS could not download the mod, so i force-used the one ifrom the start of this thread (I think that .rar are missing some files). but i willl try the mediafire one and see how it goes, if not ill wait till someone adds it in bws.

 

or maybe i could extract only the missing files and use the old installer, well see

 

Im stupid, trying to only use the hotfix without the original. sorry for the confusion.

Edited by Sterling Archer

Share this post


Link to post

Hi,

 

It seems that with the latest hotfix item_reallocation component isn't executed. I see that in base version (v3 beta 1.1) it is called from store_revisions.tpa (which is very small, with the bulk of work done in store_revisions_main.tpa). However, in the latest hotfix store_revisions.tpa is now mostly duplicate of store_revisions_main.tpa, and neither store_revisions_main nor item_reallocation are executed anymore. The effect is that in my current installation Crypt King still has Namarra instead of Albruin, Mencar doesn't have Bala Axe, etc.

 

Also I'm wondering whether IR is compatible with Unfinished Business mod? The reason I ask is - looking at the code, it seems that for instance Bala Axe should be duplicated if both UB item restorations and IR's item reallocations are installed.

 

And the final question - what is the correct install order of IR and Rogue Rebalancing mod? Compatibility thread on RR forum mentions that "main component" of IRv2 should be installed first, then RR, then the rest of IR - does that still stand for IRv3? Also, what does the "main component" really refer to - only the first component (the #0 one) or also all other components listed under "Main component" header in readme (i.e. also potion revisions and masterwork weapons)?

Share this post


Link to post

And the final question - what is the correct install order of IR and Rogue Rebalancing mod? Compatibility thread on RR forum mentions that "main component" of IRv2 should be installed first, then RR, then the rest of IR - does that still stand for IRv3? Also, what does the "main component" really refer to - only the first component (the #0 one) or also all other components listed under "Main component" header in readme (i.e. also potion revisions and masterwork weapons)?

 

 

As a general rule, any IR component that overwrites items should be installed before RR. I think that also includes "Potion Revisions".

 

OTOH, all IR components that patch items should probably go after RR.

Share this post


Link to post

GARLENA.STO, PPUMB01.STO, SAHPR01.STO are getting corrupted after installing the "Store Revisions" component. Easy to reproduce - install on ToB with fixpack (or even clean one).

Share this post


Link to post

As a general rule, any IR component that overwrites items should be installed before RR. I think that also includes "Potion Revisions".

 

OTOH, all IR components that patch items should probably go after RR.

 

Thanks!

 

 

GARLENA.STO, PPUMB01.STO, SAHPR01.STO are getting corrupted after installing the "Store Revisions" component. Easy to reproduce - install on ToB with fixpack (or even clean one).

 

Have the same problem. Investigated it a little, the logic of the store patching code looks to be incorrect. That's what happens for GARLENA.sto:

  1. Initial state - sale block of 99 items starting at offset 0x9c is followed by cure block of 10 spells (offset 0xB70 == 0x9C + 99 * 0x1C).
  2. After REMOVE_STORE_ITEM block - empty sale block (0 items) at offset 0x9C is "followed" by cure block of 10 spells (offset 0x9C).
  3. "temple" function is called - it replaces old cure block with new one containing 13 spells; "delta" variable is thus set to 3. The next condition is incorrect if some other store block shares starting offset (there are two different situations possible here - either empty cure block was "followed" by some other block, or some other empty block was "followed" by cure block - the condition doesn't account for the latter possibility). The result is that sale block start is moved 3 * 0xC bytes forward, making it clash with cure block (it should either stay "before" cure block or be moved 13 * 0xC bytes forward).
  4. Obviously, subsequent ADD_STORE_ITEM block trashes all cures except first 3.

Share this post


Link to post
Investigated it a little, the logic of the store patching code looks to be incorrect. That's what happens for GARLENA.sto:
Exactly as you say. Coincidentally, I've been looking at Garlena myself too :)

Share this post


Link to post

I dont know if this is related to what was just reported above but it looks like IR V3 beta 1.6 (BWP Fixpack'd though) broke at least TEMHELM.STO. When I open the cures tab of that store I get a crash with weird error messages.

 

Here's a pick of what shows up in NI : brokencures.bmp

Edited by Adanedhel

Share this post


Link to post

I dont know if this is related to what was just reported above but it looks like IR V3 beta 1.6 (BWP Fixpack'd though) broke at least TEMHELM.STO. When I open the cures tab of that store I get a crash with weird error messages.

 

Here's a pick of what shows up in NI : brokencures.bmp

 

I had the exact same problem but figured it was an issue on my end from all the mods I installed. I thought it might be an incompatibility with Atweak's more temple healing component so I uninstalled it but crashes kept happening when I clicked on the cures button of a temple. If I recall correctly the only temple where I could access the cures was the priest in Saradush.

Share this post


Link to post

The Temple issue ( I think I remember ) Ardanis warned against using both aTweaks and revised stores.

Share this post


Link to post

No, I have specially added compatibility code with aTweaks. This is the same thing as reported several posts above, the file corruption by my hand.

Unfortunately, a simple hotfix won't cure it, because this is already within saved games and therefore must be fixed there as well. I'll upload a patch tonight.

Share this post


Link to post

Small typo in the description of Corthala Family Armor: "he can plans his actions and pursues his targets" should be "he can plan his actions and pursue his targets".

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...