Jump to content

BG1:TotSC with Mods

Guest The_Fred

Recommended Posts

Guest The_Fred

I decided to give GemRB a whirl with some mods so I used the config file I'd used to run BG1 but pointed it to a secondary install (I have 5 - BG is actually taking up ~15% of my used hard drive space).


I never pointed its save game directory to the right place so for want of something better to do I loaded up the Mission Pack Save. Admittedly I have a plethora of mods installed and this was saved with non of them but I figured I may as well try it and see. It actually worked but there were a couple of issues which didn't show up when I used the old engine:


1) The TotSC screen doesn't show up. I get the Chapter 1 background with "GemRB v0.1.6" or somesuch as the title, and no text. I think I read this somewhere though so you probably know about it.

2) The party leader didn't get sent to Ulgoth's Beard when everyone else did. He was left in the Temple of Bhaal.


On the up-side, at least some of the mods have been working fine (as you would hope):

1) In character creation, the "Druids use 3E alignment restrictions" mod showed up OK.

2) The SCS-based "Smarter Deployment for Parties of Assassins" kicked in when Shandalar sent me to the Ice Island.


Admittedly one of these is (I think) as simple 2da change, the other a scripting thing, so it's maybe not ground-breaking that they worked. I didn't really read a lot more about using mods with the game, though, so I figured I might try running a new game and see how it goes.

Link to comment
Guest The_Fred

Started a brand new game as a Dwarven Bard. I began with 3/5 health even though I have a Con of 19, so I ought to have 8/8 (6 for Bard, +2 from Con), but I think this is a known issue.


In my few short fights, "Damage taken" would come up before a proper damage taken message, like so:

Rat - Damage taken

Rat - Damage taken (2)

I also got a "Damage taken" message without taking damage. It appeared to happen only after a critical hit message for a foe (i.e. the foe was scoring the critical hit).


As pertaining to mods, darts don't seem to want to stack beyond 10 even though I have them stacking to 50, by virtue of a mod, when I play with the original engine.

Link to comment

I fixed the initial hp gain a few hours ago (you get the max on first level). You're still left damaged though.


The empty "Damage taken" was fixed a few minutes ago. We handle it manually like the original, so this verbal constant needs to be avoided.


Oh, I also never had the problem with 2). I have the bundled mission pack save and everyone is immediately teleported to Ulgoth's Beard.

Link to comment
Guest The_Fred

OK, that's great.


I just tried the Mission Pack save again and this time it worked OK (though I had the same message screen, with Sarevok's head rather than Ulgoth's Beard, etc). However there were short pauses both before the screen came up and after, but before we went to UB, so it's possible that last time I clicked on the party leader or something and somehow disrupted his action.


I also notice that the current version is 0.6.5, right? I seem to have 0.6.4 still so I'd probably better update before going any further.

Link to comment
Guest The_Fred

A couple more notes (with v0.6.5):


1) With v0.6.5, quick spell slots do indeed seem to work just fine. Great!

2) I'm guessing the HP isn't in the release yet because an 18-Con Fighter started with 9/13HP, a 16-Con Cleric with 8.

3) As in PS:T, right-clicking on the character's portrait takes you to the inventory, but not out again.

Link to comment

Yes, the release was what, a week ago? I can do some magic, but that doesn't include time travel. :)


The next release in september will hopefully have all the known hp problems fixed. I'm in the middle of the revision of the system and plenty has been done already. We still handle the constitution bonus badly for lowlevel dualclassed characters and there are some cosmetic issues (like the one reported by Beholder in another thread).


pst needs much more love, including in the trivial department.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...