Jump to content

Version 20 comments/bug reports


Recommended Posts



First what super Mod! :D


Secondly a bug :(


But in a megamod, so prolly not the fault of SCSII :)


I thought I should let you know anyway. I have reported the problem here http://www.shsforums.net/topic/52874-big-world-project-bwp-v103-released/page__view__findpost__p__532898 .


The debug can be downloaded from there also.


Lastly... I think you are absolutely the bee's knees!


May your spells never fail!

Link to post

So basically my scsii.ini should look like this...


Mage_Level_No_Adjustments 0

Mage_Level_Add 0

Mage_Level_Scale 100

Mage_Ignore_SR 0

Priest_Level_No_Adjustments 0

Priest_Level_Add 0

Priest_Level_Scale 100

Priest_Ignore_SR 0

Sendai_Component_Is_Sendai_Only 0

AI_Does_Not_Detect_Items 0

Conceal_Prebuff_Spell_Names 0

Force_No_HLA_Repeats 0

Disable_SSL_Compilation 0

Disable_ToBEx 0


Cool gonna try a new megamod install tonight. Will let you know the results. :D

Link to post

Hi, I use the new quick install.

I chose for


Decrease the rate at which reputation improves -> Reputation increases at about 1/3 the normal rate: v20

Add high-level abilities (HLAs) to ToB mages -> Only selected ToB mages get HLAs: v20

Add high-level abilities (HLAs) to ToB priests -> Only selected ToB priests get HLAs: v20


but instead I got


Decrease the rate at which reputation improves -> Reputation increases at about 1/2 the normal rate: v20

Add high-level abilities (HLAs) to SoA mages -> Only selected SoA mages get HLAs: v20

Add high-level abilities (HLAs) to SoA priests -> Only selected SoA priests get HLAs: v20


Everything else install correctly.


I read that you are open for suggestions about more choices for the quick install.

I on the other hand would like to request an complete quick install without any choices.

That kind of standard/reference could be nice for ppl like me (maybe only minority from those playing with mods) who are not into reading wall of meta information before playing, who like discovery, surprises and beating challenges that they didnt made up themself. :)

Link to post

Thanks, that's the first feedback I've had on how it works. There're probably a couple of typos causing the problem you've found; I'll sort it out for the next release.


I can probably do something like what you're asking for - though I'd want to make sure I don't then get blamed for making the game too hard. (I'm generally keen that people read the SCS readme so they know roughly what they're letting themselves in for.)

Link to post

SCSII component Move Boo into Minsc's pack does not detect the component Move Boo out of quick access and into Minsc's pack from SCS; which I suppose it should?


Very minor, and I can't imagine installing both components will have any adverse effects :)

Link to post

th_scsbug.png th_scsbug2.png


There is a bug in;

~SCSII/SETUP-SCSII.TP2~ #0 #1000 // Initialise mod (all other components require this): v20


When installed on a fresh BG2 (GoG version) It causes the ‘Chain Contingently’ spell to misreport the targeting info... doesn’t matter if you put ‘Spell Immunity’ in the chain or even if you don’t actually know the spell.

Link to post

I decided to change some things in my install-in-progress and removed scsii per component. But I ran into this problem and now it's probably best to start completely fresh all over again. But fyi I'm posting it here.


(After uninstalling main required scsii component) Cannot uninstall following components:

Improved fiends, Smarter genies, Smarter celestials, Smarter dragons, Add HLAs to ToB mages.

Choosing the uninstall option simply loops back as if I typed an invalid key. Other components inbetween these uninstalled fine. I think there are more uninstallable components after that since there'a bit of a pattern to them, but I quit before trying them all. Thinking it was because of missing main component, I reinstalled it and tried uninstalling everything again, but it acted as if those components were not installed anymore. I'm sure they're still there, just not "on record".


Additionally, before doing this I had gone over my installs again and found that choosing "No change" didn't skip already installed components, but rather reinstalled them even though that was not what I selected. This seems to happen with the installers of a lot of other mods too. Not sure if it's a install script thing or a WeiDU thing.


Maybe these aren't bugs at all but rather some mistake of mine, or not enough for you to worry about since they don't occur if you plan and execute installation correctly. I'm opting to scrap the whole thing and start over. But thought I'd point it out.

Link to post

I cant install "More sensible choices of weapon proficiencies and kits for fighters". Something about an illegal read. Full error message below, .debug and weidu.log attached (extension changed so I can attach them). I do have a bunch of other mods installed. There also was an error about the autoinstaller when I first tried to install SCS2, but I didn't use it, so no idea if that matters.


ERROR: illegal 4-byte read from offset -1 of 1540-byte file M#YCLBM1.CRE
ERROR: [M#YCLBM1.CRE] -> [override/M#YCLBM1.CRE] Patching Failed (COPY) (Failure
("M#YCLBM1.CRE: read out of bounds"))
Stopping installation because of error.
Stopping installation because of error.
ERROR Installing [More sensible choices of weapon proficiencies and kits for fig
hters (also fixes some errors in fighter stats)], rolling back to previous state
Will uninstall 596 files for [sCSII/SETUP-SCSII.TP2] component 6015.
Uninstalled	596 files for [sCSII/SETUP-SCSII.TP2] component 6015.
ERROR: Failure("M#YCLBM1.CRE: read out of bounds")
PLEASE email the file SETUP-SCSII.DEBUG to davidw, Gibberlings3 forums
Using Language [English]



Link to post



Long time lurker, first time poster here.

I recently dug up my old BG2 discs again and have been thoroughly enjoying this oldie but goodie, especially with SCSii breathing new life into it. Great job here!


It's worked almost flawlessly through the first 6 chapters but it's sadly been crashing a lot these last couple of nights. :(


The game crashes and I get an error message that reads:

"An Assertion Failed in ChVidImage.cpp at line number 1910"


The TobEX:Tob box reads:

"Assertion Failed! Returned Address: 0 x 9CCAD1

File:ChVidImage.cpp Line: 1910 Expression: ! <cdwFlags & CVIDIMG_TRANSLUCENT> & <dwFlags & CVIDCELL_BRIGHTEST>> Message: <null>


This first happened during the Twisted Rune fight and I had to reload the fight about 5-6 times before I could complete it without a crash. The second instance was while clearing Bodhi's lair (chapter 6). I had no crashes in chapters 1-3 at all, and the only difference I can think of is that I enabled the Improved Vampires and Improved Bodhi's lair components after this. I did some searching online for solutions and found that the same thing was reported back in version 18 by user "ilot": http://forums.gibberlings3.net/index.php?showtopic=22098&st=30


Sadly, the only solution that was suggested was to uninstall the improved vampires component, which would be a shame because the regular, unmodded vampires are so boring!


I am running BG2 / ToB with the official patch, G3 fixpack, G3 tweakpack, G3 Unfinished Business, Kelsey, Saerileth, Widescreen Mod and SCSii (v. 20)


Any suggestions would be greatly appreciated.


Link to post



Quiet confident this has been reported before. Hagan fires his speech and does nothing more.


Hope you'll be able to look into this.


Cheers and thanks in advance

Link to post


This topic is now archived and is closed to further replies.

  • Create New...