Jump to content

Appearance bug Halfling/Gnome


Tanner

Recommended Posts

Hello,

 

I noticed a minor problem after creating a gnome character (i tried it many times, just to be sure). Global and paperdoll appearance used in-game are not the the models for gnomes, but for halflings. (cf screenshot)

 

Just to be sure, i also tried to install some of the 1PP material, in order to see if character model mods work on GemRB, but no changes were to be seen during the game.

 

I know, it's just a detail, and nothing that prevents to play the game.

 

My questions are:

Is it possible to fix this problem (or, in which directory are stored the models used by GemRB for the charactersi)?

 

Or is it a normal behaviour in the actual development state of the project? (well, i know time/limited ressources are often a big issue, i can understand it).

 

PS:

Gemrb version: 0.70 (from git)

Platform: GNU/Linux (Fedora 16)

Baldur's Gate II version: Gog

 

And, the most important thing: thanks for the amazing work!

post-3272-0-00599700-1333613552_thumb.png

Link to comment

I knew it couldn't be so easy: it doesn't work, but i'm sure i did something wrong, somehow. After Crtl+M on my pc (cleric/thief), i got the following lines in the gemrb console:

 

Mod[iE_ANIMATION_ID]: 0x6014 ResRef:cifb2

 

And CIFB2, following for link, gives the following appearance: C/I(Halfling)/F(Female)/B(?) - should maybe be C for cleric/2(Leather) , which is quite logical with what i get in-game :p .

 

So, i edited the 0x6014 line in the Gemrb override usr/local/share/gemrb/override/bg2/avatars.2da:

 

AT_1 AT_2 AT_3 AT_4 TYPE SPACE PALETTE SIZE

...

...

0x6014 CDFT1 CDFT2 CDFT3 CDFT4 0 2 0 S

 

With in mind, following the appearance codes: C/D(dwarf/gnome)/F(female)/T(thief) and 1-2-3-4 for the different armor types.

But it doesn't work:

 

[ResourceManager/ERROR]: Couldn't find 'cdft2g17.bam'.

[CharAnimations/ERROR]: Couldn't create animationfactory: cdft2g17 (6014)

 

The matching .bam files can't be found (but the gnome thief exists in the vanilla BG2). Any ideas about a solution?

Link to comment

It works partially using the cheats keys. Thanks! :)

 

But the problem with the gnome character paderdolls seems to be still here, i've been browsing all the possible apparences, but the paperdoll is always the one used for halflings. (in other words, apparently no gnomes in GemRB on my computer)

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...