Jump to content

[android] Planescape Torment Crashes - ASUS Transformer Prime


Recommended Posts

Greetings all,


I'm getting some very specific bugs and crashes in Planescape Torment, running on my Transformer Prime.


1. When I click on one of the character portraits on the bottom of the screen, the mouse cursor becomes the "move party member" icon, and all of the menus break. This happens immediately, every single time I click any character portrait, without fail. It effectively breaks the game, as, from that point on, I can't access the game menu to save or quit.


2. Game is crashing whenever I receive an item from a conversation, for example when you push over the zombie to get the severed arm in the mortuary, or take the leather straps from the skeleton upstairs.


Otherwise, the game is booting and running flawlessly. Just can't really make any progress through the crashes and menu breakage.


Thanks in advance for any helpful responses,


Link to comment

I don't experience the first, except that the controls are very sensitive and easily switch to the party order mode. Moving the mouse off the portrait icons removes the mode.

I will test the second case, as it is really specific.

Link to comment

gemrb version?


You're referring to the widescreen/GemRB patch? I tried a number of different resolutions/"builds" and they all had serious issues with the text/dialogue display; it was flickering and disappearing completely. It's possible that the version I have on my Pad is a fresh install. I'll double-check tonight.


@Avenger - But once you're done with party order mode, the menus still work?

Link to comment

Yes, they work. I vaguely remember some bug months ago, though.


Lynx asks you about your GemRB version, as this is an ongoing work, we might have fixed that bug.


I tested multiple dialogs where the creature dies (skeleton, zombie), but no crash.

Link to comment

the drag thing is a problem due to touch input sensitivity on some devices, but I don't remember if we can or did anything to change that. You'll have to wait for brad.


It's of course critical to use the same resolution in the widescreen mod and gemrb config.

Link to comment

UPDATE: I verified these bugs and crashes with a freshly patched copy. All the same bugs -- crashes when I get an item from a dialogue tree, and clicking on a character portrait sets party order mode and breaks all of the menus.


I am using the most current GemRB build from the Play Store.


EDIT: I installed the April 15 release of GemRB, and it eliminated the crashing problem. The character portrait/menu breakage bug is still there though. I'm quite happy though; the game is playable now without those crashes.

Link to comment

I had backed up the net.sourceforge.gemrb folder, and let GemRB create its folder heirarchy from scratch. Just ti be sure, I just tried downdloading the override files. It didn't change anything though; I'm still getting broken menus.


It's really quite annoying- if I hit a character portrait by accident while in the inventory, I can't leave the inventory. Sometimes I can move items between characters, sometimes it breaks the game.

Link to comment

I can confirm "move party member" icon bug on Samsung Galaxy Tab 10 with April build of GemRB

After pressing one of the characters portraits game become unusable.


Maybe it make sense, upon double click on the main area, restore ALL internal states and handlers, related to

button's processiog, to the default state.

Link to comment

Hi guys,


I have exactly the same problem on my HTC Doubleshot running ICS (virtuous inquisition).

Everything is working fine till the point I click on one of the characters. Then this "move party bug" takes over and I can´t use any menus...


Indeed the game becomes very unstable. Too bad :(

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...