Jump to content

some bugs

Ishad Nha

Recommended Posts

much the same, a compiler. There is a build system in place (based on cmake), so we don't have to write long command lines by ourselves and it can also generate various IDE's project files.


I forgot we have a buildbot, but it's a bit behind, so there's no fresh build there at the moment.

Link to comment

This seems to involve dealing with the source code. What compiles the code anyway? I am only used to simple pure C++ projects.

This doesn't differ from any pure c++ project. Aside from linking some libraries (SDL, Python, OpenAL).

Link to comment

It might be simpler if you just updated the buildbot. I am not much of a programmer.


Chapter text, hanging capital is obscured by the ordinary chapter text.

Wands from Irenicus dungeon are selling for around 2,500 each, that is way too high?

Gaelan Boyle, Chapter 2 intro happens twice, the first with the wrong picture.


Mages can't scribe spells, that is causing real trouble.

Hold Person holds the caster?

Link to comment

Cleric Hold Person holds the caster!

In Copper Coronet, door 17 is being blocked by a guard. GemRB is very restrictive in the area of moving around people.

I don't want Nalia testing my patience with her complaints about the party not heading immediately to the Keep, so I sent her on ahead.

Meantime I used the original game's multiplayer function to add a temporary Mage to replace Imoen. While I was at it I had the Mage scribe all the scrolls that could not be scribed in GemRB.

Spell disruption does not reliably happen, caster gets badly banged up then they can still cast.

Dessicated Hand is not being produced by the otyugh drain in the dungeon underneath the Copper Coronet.

Link to comment

which scrolls couldn't you scribe? What's the int of the mage?


spell disruption never failed me, so we'll need more concrete examples.


the drain bug has been fixed a while ago, so i'm pretty sure you're not running the latest code.

Link to comment

Unable to scribe any of the scrolls at all. Mage had high Intelligence, 18, so it was not the fail your Int check situation. There was no "You failed to copy the scroll" message, there was no message at all actually. The scroll was not consumed. Not one scroll out of fourteen was scribed.

Blood for Lilarcor was not obtained, I could not find it anywhere after killing the Crawler.

Carrion Crawler near Kobold Shaman, when it walks, its animation rotates!

Spell disruption has failed some times but not always, I don't know why. I can't see any pattern.

Link to comment

This worked: GemRB.CreateItem(1,"MISC5Q"). Same function also worked for Misc5S. After which I was able to obtain the sword Lilarcor.

Can't open GemRB save games in ShadowKeeper! Here I mean save games created by GemRB. Games created by the original game will open just fine.

"Failed to Open Game

Unable to open that saved game.

Error (1025): Missing CRE signature."

ShadowKeeper source code will be able to reveal the meaning of the 1025 error.

Link to comment

There was a really nasty crash after Hendak and the other slaves were freed. I think the quest did not start properly or something. Crash did not happen when I did the quest again. I will have to try and isolate what went wrong here.


You hear from a Gladiator, string 49848: "You slaving bastard! My family's blood still stains your hands!"

If only the protagonist goes near the Gladiator concerned there is no crash. Gladiator is near the entrance to the sewers under the Copper Coronet.

Errors listed:

[ResourceManager]: Searching for nboyh.2da...[ERROR]

[ResourceManager]: Searching for ngrlh.2da...[ERROR]

[ResourceManager]: Searching for chmb2.2da...[ERROR]

[ResourceManager]: Searching for copamb02.dlg...[NOT FOUND]

[ResourceManager]: Searching for copamb03.dlg...[NOT FOUND]

[ResourceManager]: Searching for copamb04.dlg...[NOT FOUND]

[ResourceManager]: Searching for copamb05.dlg...[NOT FOUND]

[ResourceManager]: Searching for chmb1.2da...[ERROR]


End of the printout, Abdel Adrian is the protagonist:

) oking up key:

Performattack for Copper Coronet Guard, target is: Abdel Adrian

[Attack]: (Main) Left: 1 | Next: 413119 [Missed]

Displaying string on: copamb02

Displaying string on: none

Link to comment

After the liberation one Gladiator remains, Glad2. He has dialog that is no longer relevant.

Another bad crash, this time near the front of the inside of the Slaver Compound. Currently I have no solutions to this one.

Gem Bag can't be opened in Shop dialog. Must be emptied out before you go into Shop mode.

Government District:

Viconia lynching, no Beshaba fanatics!

After her "rescue" her dialog goes into a loop:

[ResourceManager]: Searching for cefb1.2da...[ERROR]


One Invisible Stalker scroll disappears when you click on it, then reappears in the inventory of the next PC.

Xzar quest, Lucette turns hostile and has to be killed. After that the quest ended normally.

Jaheira curse quest went alright.


AR0906, Bottom floor of Slaver Compound in Temple District, Backstab, "KETTAATK": only the Nishruu wa summoned.





Magic draining attack of the Nishruu gives a scroll 0 charges, unequipping and re-equipping the scroll restores it. Funniness with potions too, a stack of potions is shown as 0 charges regardless of the situation.

Link to comment

Reform Party does not work, nothing happens.

Trying to replace the Sorceror in place 6, whom I created, with Aerie, no luck. PCs who are not official Bioware NPCs won't be removed when you try to add a new NPC. I could alter a script to have the same effect? I now can't get the original game to open GemRB save games, hence I can't use the original multiplayer function to resolve the problem.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...