Jump to content

some bugs

Ishad Nha

Recommended Posts

Reform Party, I got it to work, I only had 1 PC selected at the time. But it still won't remove custom NPCs. When all PCs are selected, it just exits to the game like the Return to Game button on the left side of the screen. If the game is paused it won't work until game is unpaused.

Scripts can remove a player by "Kill(Player#)", this works for custom PCs. Empty inventory before this happens, the departing PC will leave nothing behind him. I stuck this into the AR0903 script and it worked, PC was declared dead, there was a dialog and he left. I will move this code to the area script of a place I don't normally visit.

Link to comment

In theory you could alter the bit, though the game must know which PC is the protagonist. (That should be Player1 usually.)

Area AR0805 seems minimally used. Gravedigger initially hangs around outside this tomb. Good place to offload custom NPCs. This code worked:








Unfinished Business mod: Genie's Flask icon is way too big.


Cleric/Thief can't seem to Turn Undead. No provision for it in 12 buttons at the bottom of the screen. F12 button only brings up the Set Traps ability. Other Cleric types seem ok in this regard.

T assigned as a shortcut for Action: Turn Undead, in the original BG2, will this work in GemRB? Possibly not.

Link to comment

I don't think we are concerned about mod issues ATM.


the graphic could be too large because i think we make an assumption about what index in the BAM to use. (i may be making thinks up)

even if i am right, i don't have any idea where to look to get the correct index.


It could also be that the image really is too large and the original engine simply scales it?

Link to comment

most items have two sizes (the bigger one for when you're dragging it) and the original items have the bams frames in a predictable order. We haven't found any other logic governing which to use.


Ishad: what did the original sacrifice? The only cleric/thief screenshot I could find didn't have disarm/unlock/pickpocket, but I find that hard to believe.

Link to comment

Genie Lamp can be used (expended) immediately, no big hassle. I will have to worry about graphic later, it is only an Unfinished Business issue.


I will take a quick look at the Cleric/Thief issue in the original game. You could always use a custom shortcut key for it.


In the original game F5 was the Cleric/Thief key for Turn Undead. In GemRB it seems to be possible to use a shortcut key from the original game. I chose T as the shortcut in the original game, a quick test seems to show it working in Gem.


Biggest annoyance is the inability to Write Magic, I don't currently have a workaround.

Link to comment

Bodies of defeated enemies lie around long after they are killed, this is very obvious at the Copper Coronet.

Party sometimes enters in the wrong part of a map, like the north of the Keep.

Scripting not needed to remove a custom NPC, Ctrl + K shortcut actually works for GemRB. (Now about the X shortcut, which does not work.)

Can't get Write Magic to work. Game plan is to add all the spells in one hit to the Cre file, before the NPC joins the party. Now this saves messing with the save file later on. ShadowKeeper won't open the save game files, but it can alter the Cre files.

Nalia will be the test subject here. Nalia8.cre seems to be the file used at the Keep even though she is immediately promoted to level 10 courtesy of the Level 1 NPCs mod.

Link to comment

Giving Nalia spells via her Cre file worked okay.

Major problem: repeated crashes at the Keep, in the area where Daleson is. I have attached the command prompt printout in a zip file.*

There seems to be no pattern to the crashes. They make systematic exploration impossible.

* (File removed, it is no longer needed.)

Link to comment

"That logfile is not helping any. Maybe a savegame and instructions how to reproduce the crash."

Crashes are purely random, I can't see any pattern to them hence I can't see any way to give instructions. Here is the Quick Save file set.*


"maybe the altered CRE is causing the crashes?"

At one point, the game was saved with the multiplayer function of the original Black Isle game.


This is not a purely GemRB save file. What I can do is start over with a purely Gem game and see if that stops the crashes.



A purely Gem game still crashed in the front of the Slaver Compound.

I can uninstall the two mods, Level 1 NPCs and Unfinished Business and see if that stops the crashes.



* (File removed, it is no longer needed.)

Link to comment

I removed both the mods, crash still happened in the front part of the Slaver Compound. It seemed to happen when I targetted the Slaver Guard in front of the staircase, (446,1327). On a reload, the party walked up to him and attacked, no crash resulted. I used a new, wholly Gem, game for this.

When the crash happens, the last thing you see is a green Move cursor flashing on the red circle of the Slaver Guard. It looks like a PC is trying to move onto the space occupied by the Slaver Guard.


"symbolicated crash report?"

What does this mean?

Link to comment

When the crash happened yet again, the error dialog screen came up, I followed the messages:

"For more information about this error, click here."

"To view technical information about the error report, click here."

In the folder C:\Documents and Settings\Control\Local Settings\Temp there was a file dbc4_appcompat.txt, I copied it to another directory. Because when I closed the error dialog, the file was deleted.

I am not sure how useful it is but it is included here. (This file has been removed, it is no longer needed.)


Firstly, we need to make sure that the problems are not occurring only on my machine. Other people need to check these areas too.

Secondly, it is currently only two areas that are affected

AR0405 Slaver's Ship Building

AR1302 De'Arnise Keep 1st Floor

(NB: A lot of the areas have not been visited yet.)

Thirdly, I can't see any pattern to the crashes.


Areas where no problem was experienced:

Irenicus Dungeon (all three areas, apart from the Fennedan room crash)

Circus (all areas of it)

Copper Coronet AR0406, one crash did occur but it was curable.

Sewers AR0404

Harper HQ, Prebek's home

Pai Na's place

City Gates

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...