Jump to content

[android] Planescape crashes on new area


Recommended Posts


I recently installed PST on my Asus tf201, and after solving a few issues I got it working. I was able to play through the mortuary and first area of the Hive without issues, however on travelling to any new area in the hive, the game crashes to desktop. I am able to see the new area for about one second before this happen.

GemRB version installed from Google Play

The game is installed in /app-data/net.sourceforge.gemrb/Torment/


I've included the output from alogcat below as well as the config file (renamed .txt so it can be uploaded).


Any help would be much appreciated, thanks.



Link to comment

Please upload the savegame before entering the new area. Just teleporting there from the starting area, I can't reproduce a crash. I've been talking with various citizens and nothing problematic happened so far.

Did you see the exit movie? I also got some ghost animation cutscene, but that may also be due to my shortcircuiting.

Link to comment

next time please just zip it up, this was tedious to download and recreate.


I went south through the exit, walked around a bit, talked with the damsel in distress, levelled up and nothing. Do you do anything special to get the crash? Now it looks like an android specific bug, probably due to limited memory or somesuch.

Link to comment

I tried installing IWD today to see if that would run, and so far it runs (almost) flawlessly, I can move between areas and in general play the game normally. I don't know if this helps any at all, I just wanted to see if the problems were specific to PST.

Link to comment

Yes, I have both HoW and TotLS installed, and the .cfg file configured to how.


I just experimented some more with pst: this time I WAS able to move to the South Hive. I saved the game there, reloaded the autosave and travelled to the South Hive again, though this time the game crashed. Reloading the saved game in the South Hive I tried transiting back, no problem, I could also go back south again.

I then tried going to a new area from both the Central Hive and the South Hive, the game crashed.

Could it be some problem with the cache? Perhaps it allowed me to transit to the South Hive the first time as I had recently been running IWD? I will now try running IWD again, go back to PST and go to a completely new Hive area. I'll post back later.

Link to comment

the cache is cleared on each run anyway, so that was a red herring. The bug is likely related to the invalid read I saw (not fixed yet), so for now further debugging isn't needed.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...