Jump to content

Baldurs Gate 0.7 Android ssues


Recommended Posts


it´s so aweome to be able to play BG1 on android :-)

I have some issues though:


-Whenever I order my chars to attack, they all thart screaming their battle slogans altogether, which is quite annoying. Setting the voice volume in baldur.ini and GemBR.cfg to 0 doesn´t help, as well as disabling them in the options. Are there maybe files, which I can delete, it´s very annoying.


-The difficulty slider is set to the easiest setting, although the fireball harms my chars as well (I think the easist setting in original bg had the fireball not harm yourself). Is it possible to change the dificulty somehow, maybe within the ini file? Or do I have to change it to normal, or whatever I want, whenever I start the game?


-Same goes for Autopause, can I put it in the ini, so I don´t have to enable it every time after I started?



Link to comment

it's an old build, so 1. may have already been fixed. There will be a new release soon.


I doubt fireball was ever party-friendly. You can set the difficulty in the ini, as well as the Auto Pause State (it's a bitfield though, so it won't be trivial to get what you want).

Link to comment


I´ve got the latest version from android market, so I guess it´s 0.7.01?


In this thread: http://www.shsforums.net/topic/41577-baldurini-keys/ I found some infos.


Putting "Difficulty Level = 4" does not change anything.

From the disassembled exe there are things like this:


(StringData)"Difficulty Level"

:0068873F 68746DB200 push 00B26D74

(StringData)"Game Options"

:00688744 FF150453AA00 call dword[00AA5304]


Don´t have a clou if that´s helpful or not, or what to do with it ;-)

Link to comment

yes, something like: print GetVar("Auto Pause State")

in the console should work.


The difficulty level is currently pretty much only used for hp rolls on level up and spawn points. Damage +/- isn't implemented yet and there are probably some other effects of the setting. I'll go do the damage scaling now.

Link to comment

Ok, the newest Version got rid of the sounds and changes to Difficulty Level in the ini are used.

Unfortunately Auto Pause got worse. In the Options everything from Character Attacked to Enemy Sighted is checked. But it actually pauses on everything except Enemy sighted (which I only really need),I have to uncheck it to work.

All other settings can´t be turned off :(


print GetVar("Auto Pause State") I get a syntax error...

Link to comment

Well I tried it only on PC original BG, triplechecked the spelling ;-) On GemRB Android I don´t get the console to show. Any tip on how to?

I put Cheats=1 under Game Options, the same I did on PC. Then I mapped rctrl to physical key and TAB to the onscreen keyboard. But that doesn´t open op the console...

What do I do with [Python]: 8 ? Putting it in the ini doesn´t do anything...

Sorry for all the dumb questions ;-)

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...