Jump to content

SCS Antimagic tweak breaking SR spells ?


Tonton Fred

Recommended Posts

Hi,

 

I have just run into an issue with MGI not being taken down by Spell Thrust ; I have traced the issue to SCS component 1019 "Antimagic attacks penetrate improved invisibility -> Antimagic spells remain single-target, but affect the target creature whether or not it is invisible (default option): v20". This is on a BWP install, and the PDF seems to imply that SCS should have skipped the component since SR was present.

 

This is the change log on the relevant SPL :

 

Mods affecting SPWI321.SPL:
00000: /* from game biffs */ ~SPELL_REV/SETUP-SPELL_REV.TP2~ 0 0 // Spell Revisions: v3.1
00001: ~SETUP-D0QUESTPACK.TP2~ 0 1 // Creature & Area Improvements -> All Creature & Area Improvements: v2.3 (Feb 14, 2010) BWP Fix
00002: ~SETUP-SCS.TP2~ 0 10 // Initialise (required by almost all other mod components): v20
00003: ~SETUP-SCS.TP2~ 0 1019 // Antimagic attacks penetrate improved invisibility -> Antimagic spells remain single-target, but affect the target creature whether or not it is invisible (default option): v20
00004: /* acted upon in an indetectable manner */~GENERALIZED_BIFFING/GENERALIZED_BIFFING.TP2~ 0 0 // Generalized Biffing: v2.2
00005: /* acted upon in an indetectable manner */~GENERALIZED_BIFFING/GENERALIZED_BIFFING.TP2~ 0 0 // Generalized Biffing: v2.2

 

Putting the backup SPL from scs/backup/10/ into /override allowed Spell Thrust to take down MGI as intended. Is it a bug in the current code of either SR or SCS ? Or should this SCS component skip the install but for some reason didn't ? Finally, this component also affected SPWI704, 705 and 903, should I also restore their backup in order for them to work as intended ?

 

Thanks for a great mod,

 

Fred

Link to comment

SCS's antimagic is more up to day than SR's, and therefore is not supposed to skip that component.

 

Numerous people had problems with antimagic spells in the past, and more often than not the origin of the problem remained undiscovered. Same again, I'm playing with that SCS's component and Spell Thrust destroys MGoI all the time ???

 

It is possible that, since the backup from /10 worked, the issue is due to the Spell Shield tweak - which is odd, since it was fixed ages ago, and it doesn't explain why your game is broken while mine is fine.

 

I shall try to discover something new about it, but I'm not highly optimistic...

Link to comment

I have attached an export of the working MGI and the broken one to this post. The only difference I can see is that the working one applies its effects directly, while the broken one calls 2 other spells (SPWI321B and SPWI321C) to apply them. Also, the broken one has an additional flag (type 24 : unknown). Hope this helps,

 

Fred

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...