Jump to content
Sign in to follow this  
PandaOfMetal

Install error BG1 NPC wih BGT : buffer cannot grow

Recommended Posts

Hi everybody !

 

I tried deseperetly to install BG1 NPC on my BGT, without success,

I follow the directions given on this website : The part "essential components" managed to be installed correctly, as well as the shar-teel romance that i wanted. But during the installation of the main talk and discussion I get :

 

ERROR: problem saving [override/CORANJ.dlg] Failure <"Buffer.add : cannot grow buffer">

Stopping installation because of error

 

Have you already encounter this error ? I have a quite recent laptop with 4Go Ram, I don't see why it run out of memory: I tried in "Safe Mode" but it's the same.

 

here is my quite simple Weidu.log ( I play in french )

 

// Log of Currently Installed WeiDU Mods

// The top of the file is the 'oldest' mod

// ~TP2_File~ #language_number #component_number // [subcomponent Name -> ] Component Name [ : Version]

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #4 #0 // BG2 Fixpack - Correctifs principaux: v9.01

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #4 #100 // Gain d'experience si on envoie Keldorn se reconcilier avec Maria: v9.01

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #4 #101 // Animations des sorts amelioree: v9.01

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #4 #103 // Correction des dagues a usage mixte: v9.01

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #4 #104 // Correction des symboles divin (par Ghreyfain): v9.01

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #4 #106 // Penalite d'attaque des Geants contre les Petites-personnes, les Nains et les Gnomes: v9.01

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #4 #107 // Retire la restriction de jumelage des Archers et des Traqueurs: v9.01

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #4 #109 // Correction du comportement des demons convoques: v9.01

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #4 #110 // Correctifs additionnels pour les scripts: v9.01

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #4 #111 // Correction de la chanson du barde: v9.01

~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #4 #113 // Correctifs additionnels pour les alignements: v9.01

~SETUP-BGT.TP2~ #3 #0 // Baldur's Gate Trilogy - Composant principal: 1.10 (28 August 10)

~BG1NPC.TP2~ #2 #0 // BG1 NPC Project : modifications necessaires: v20

~BG1NPC.TP2~ #2 #13 // BG1 NPC Project : relation avec Shar-Teel, elements de base (contenu adulte): v20

 

Thank you for your help, and for this great mod !

 

Panda

Share this post


Link to post

Don't know the cause of your error but some general things:

 

First of all I would recommend that you use newer versions of the mods. BG2 Fixpack is at version 9.14 and BTG is at version 1.15.

 

Be sure to install outside the Program Files directory if on Windows (I use C:\Games) and disable your antivirus during installation to rule out problems with that.

Share this post


Link to post

Ok thank you, I will try that first. Considering that BG2 fixPack has to be install before BGT, How I can do the update ? do I have to uninstall everything ? can I update BGT without re-install it ? or endanger my saves ?

 

Thanks a lot !

 

Flo

Share this post


Link to post

You've got ToB installed, right? It can be that no one ever installed "only Shar-Teel romance" without "banters" and "quests", and that's why the component may cause troubles. Unlikely, though. In any case, I'd advise installing "banters" and "quests" components and seeing how it'll pan out. Also, in case it doesn't work, I must say I don't know stuff about BGT, so I can only recommend trying it again with Tutu v4, seeing how you'd need a French installation.

Share this post


Link to post

Yeah, I have BGT so, it's BG1, TotSC, BG2, ToB. I tried to install "banter and quest" (without success) before trying to install the Shar Teel Romance. Now in order to clean that mess, I un-install everything, (by the setup-bgtnpc.exe, then by deleting the bg1 npc file and folder) but shar-Teel still try to court me, or my NPC still talk to each other ! (And sometime some bug trap me in infinite loophole conversation) So it's really strange, i hope my save is not (too much) corrupted.

 

Someone now the process to update BGT without damage the saves ?

 

Thanks !

Share this post


Link to post

I am afraid you may need to check in with the BGT folks at SHS, or the bigg at PocketPlane on the WeiDU boards.

 

The error

ERROR: problem saving [override/CORANJ.dlg] Failure <"Buffer.add : cannot grow buffer">

is an internal processing error kicked out by WeiDU, basically saying that it has run out of memory space, I think - it is not mod-specific.

 

I would ask folks on those two sites. Someone there may know if this is a permissions issue or a physical memory space issue, or something completely different :)

 

edit: - hey - you do have several extra GB of space on the disc you are installing to, right? I know Easytutu likes to have lots of extra space during the install, even if it is told to remove the BG resources after install.

Edited by cmorgan

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...