Jump to content

Icewind Dale Kindle Fire


Recommended Posts

I've been attempting to get Icewind Dale to work on my Kindle fire for the better part of a week now, and I'm simply at a loss as to what else to try. I've got the Good Old Games copy of the game, and GemRB installed on my Kindle Fire. I've tried copying the contents of the Icewind Dale Complete folder into the I:\app-data\net.sourceforge.gemrb folder, and I've tried installing the BG2 demo (which ran fine) and then copying it over that.


For my game directory folder I've tried all of the following:







For the CD directories, I've tried the above and also with /Data, CD1/Data, CD2/Data, etc.


Nothing seems to work, yet it keeps giving me the "Change Device Configuration Error"


My latest .cfg can be seen here: GemRBTXT.txt

Link to comment

Alright, so, I seem to have gotten it working. The way I did it was as such:


I installed GemRB, and deleted GemRB out of it's folder (I:\app-data\net.sourceforge.gemrb) leaving the folder itself, but empty.

I then copied Icewind Dale's folder contents into that folder.

Then I reinstalled GemRB on my Kindle.

Then I edited the CFG to Gametype=how, and resolution to Wiidth=800 Height=600


The Good Old Games installation will load up the game, but show black screen, IWD cursor, and text entry box option (in the upper left), but without the intro videos. This seems to happen whether I turn the videos on or off with SkipIntroVideos=1


I cannot seem to get the Widescreen Mod to work on either the GOG version of the game or the standard version. When I load up the game, it crashes to "tablet-top" and alogcat tells me that the game cannot recognize a 1024x600 resolution (native Kindle Fire).


For now, I would be content if I could get 800x600 working without being distorted, but for some reason it is compelled into fullscreen mode, whether I set it to 1 or 0 in the cfg.


Still, it works.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...