Jump to content

IWD1 GemRB - No party sounds


Recommended Posts



I'm new to these forums, and to GemRB in general. Before I get to my problems, I believe you need some more info; I have a Samsung Galaxy S2, and Android version 4.0.3 and am using GemRB v., which I downloaded from the Play Store. I spent last weekend trying to get GemRB to work with Icewind Dale: Heart of Winter (Trials of the Luremaster installed), and finally managed to pull it off last night. Everything seemed to be working great at first, and I was very excited to finally get it working.


I hope this won't be too long-winded, but i'd like to give you as detailed a response about my issue as possible, and let you know what i've already tried myself. I've searched for an answer to this and couldn't really find anything related to this problem, save for these two posts:


The first post made in this topic:



And the issue the poster that created this topic seems (seemed?) to have:



The opening cinematic had stuttery sound here and there, which wasn't really a big deal. But even though all NPC voiced lines and the background noise/music in-game is there, I have no party selection/command sounds, attack sounds, casting voices (though the actual spell sound does trigger) or footsteps, while the party voices did work during the character creation.

I've tried opening the Character Sounds options, and ticking both the "always" and "seldom" boxes under Command Sounds and Selection Sounds, but was unable to.

I was, however, able to tick the "attack sounds" and "character movement sounds" boxes, but none of these sounds actually occured when they should.

When I quit the game and loaded a save, I noticed that the "attack sounds" and "character movement sounds" boxes were unticked again, and the music from the main screen kept playing for well over a minute after I loaded the save, after which the inn background noises started.

I'd like to add that I also had the exact same thing happen when playing the BG2 Demo that I tried on GemRB before installing my own games.


I tried modifying the icewind.ini to enable stuff like higher difficulty (which would revert to the left-most on the slider every time I loaded ) gore, weather, Infravision, footsteps, subtitles (all these boxes would be unticked automatically as well when I loaded quit GemRB and loaded it later) etc., and even though the boxes are now "ticked" in-game, I still don't actually hear the footsteps or weapon swings, whether the character hits or misses. On a hit, I do hear the actual "hit" sound. I also tried adding lines along the lines of Command Sounds Frequency=2 and Selection Sounds Frequency=3, both under the [Game Options] and [Program Options], just to be save that I tried it.


So my question is; how do I fix this, and get sound for my party and combat, if it is at all possible? If you need logs or a copy of my icewind.ini or whatever, i'll be happy to provide it.


A second, shorter question I have is about the grey lines near the edge of the game window. I noticed that these function as "buttons" with which to move the screen, but is there a way to make these invisible or at least more transparant? I tried using the on-screen keyboard transparency option, but that doesn't work.


Once again, excuse the long rant, but I hope I at least have given you a clear picture of what the issue is and gave you a clear rundown of what i've already tried.

Thank you in advance for the time and trouble to answer this!

Link to comment

Much of what you described has already been fixed, but the market version is old. The two people that did android builds have practically vanished, so it's hard to say when the next one will be available.


You can't do anything about the grey lines but disable the functionality all together.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...