Jump to content

[SOLVED(?)][Mac OS X] SCSII install failure, please help!


ericp07

Recommended Posts

Attempting to install v21 on my system (by running Setup-scsii.tp2 manually) results in an error:

 

Cannot resolve action 0x159

ERROR: [FINBALTH.bcs] -> [override] Patching Failed (COPY) (Not_found)

Stopping installation because of error.

Stopping installation because of error.

ERROR: [scsii/DS/oldfiles_asc.2da] -> [override] Patching Failed (COPY) (Not_found)

Stopping installation because of error.

Stopping installation because of error.

Stopping installation because of error.

 

ERROR Installing [initialise mod (all other components require this)], rolling back to previous state

Will uninstall 22 files for [setup-scsii.tp2] component 1000.

Uninstalled 22 files for [setup-scsii.tp2] component 1000.

ERROR: Not_found

PLEASE email the file Setup-scsii.DEBUG to davidw, Gibberlings3 forums

Using Language [English]

 

There is a file "finbalth.bcs" (all lower case) in my override folder, so I don't know what the problem is. If anyone can shed some light on this, and advise me on how to correct and install the mod, I'd greatly appreciate it!

 

I've installed and used SCSII v21 successfully in the past, and in this particular installation, I'm adding only those mods I consider to be "stable" (all things being relative).

Link to post

I had the same thing happen before, with a previous version of SCSII, but had to scrap the installation a long time ago. This time, there will be a solution, even if I have to stumble upon it myself (which could take several more months), but I'd prefer to prevail upon the wisdom and experience of the other Mac-savvy folks around :)

Link to post

The file finbalth.bcs is present in my override folder. I even renamed finbalth.bcs to FINBALTH.bcs, but the exact same error message occurs when I run weidu-mac to install the mod.

 

I have no clue what the problem is. The only thing I can think of now to try is to extract a fresh copy of the mod from the archive, place it in the BG2 folder, and try installing once more, but if that fails, I'll be out of ideas, and won't be able to install it in this particular installation.

 

TIA for any assistance!

Link to post

This might be a clue for the install failure: The file oldfiles_asc.2da in this mod has the following content:

 

FINABAZ

FINALUF

FINBABAU

FINBALOR

FINBALTH

FINBODH

FINBODHI

FINCAMB2

FINGLAB

FINGROM

FINILLA

FINIREN

FINMARIL

FINMEL

FINNABAS

FINSAREV

FINSEND

FINSOL04

FINSUCC

FINYAGA

 

There is no file named FINBALTH.bcs anywhere in the mod package (maybe it's not intended to be there?).

 

What is the installer trying to do, and why is it failing?

Link to post

Not_found has nothing to do with the existence of files. If a file is missing, WeiDU will unequivocally say it is missing. Not_found means something went wrong in the patchy code (it is an OCaml exception).

 

Okay, the next version of WeiDU will print an explicit error when it encounters an unset variable (of the one kind I know how to reproduce). This would previously result in an unhelpful Not_found error. Maybe this bug is one of those, maybe it isn't.

Link to post

That means an indefinite wait to even try to install the mod again, I guess...or should I try a version of SCSII prior to v21?

 

It's funny, when I see an OS X version of a mod, I expect it to install and work on a Mac ;)

Link to post

That means an indefinite wait to even try to install the mod again, I guess...

Why? You don't need a new WeiDU to debug this error. It might have sped things up a little, except that I was way off. Your problem is this:

Cannot resolve action 0x159

WeiDU is unable to find the action SetSequence() in your ACTION.IDS.

Edit: things to look into:

Is SetSequence() really missing?

Is one of your other mods responsible? SetSequence() is a ToB action, so it is conceivable it is missing because another mod overwrote ACTION.IDS with the SoA version, even though this would be mind-implodingly stupid.

Link to post

That means an indefinite wait to even try to install the mod again, I guess...

Why? You don't need a new WeiDU to debug this error. It might have sped things up a little, except that I was way off. Your problem is this:

Cannot resolve action 0x159

WeiDU is unable to find the action SetSequence() in your ACTION.IDS.

Edit: things to look into:

Is SetSequence() really missing?

Is one of your other mods responsible? SetSequence() is a ToB action, so it is conceivable it is missing because another mod overwrote ACTION.IDS with the SoA version, even though this would be mind-implodingly stupid.

 

That's encouraging, so I'll check into ACTION.IDS from my archive of the installation (I've since installed Generalized Biffing as the finishing touch, so now that .ids file is in one of the biffs and not in the override folder).

Link to post

Yes, that action is missing from the file. I suspect that Amber hosed this, as that mod regularly causes problems when I install it, requiring a bit of file-wrestling to get it to install and work properly.

 

Edit: Suspicion confirmed! The copy of action.ids in Amber's back-up folder includes that action (but this mod overwrites the .ids file with one that is missing actions numbered higher than 338). I added the line "345 SetSequence(I:Sequence*SEQ)" and saved ACTION.IDS to my installation's override folder, and will make an additional back-up of the file, then see about installing SCSII.

Link to post

All I need now is to know what exactly to comment out so that setup-scsii.tp2 doesn't try to install TobEx (install fails, of course, when it tries to patch bgmain.exe; I make do without it). Please advise...this just might do the trick :)

Link to post

Yes, that action is missing from the file. I suspect that Amber hosed this, as that mod regularly causes problems when I install it, requiring a bit of file-wrestling to get it to install and work properly.

 

Edit: Suspicion confirmed! The copy of action.ids in Amber's back-up folder includes that action (but this mod overwrites the .ids file with one that is missing actions numbered higher than 338).

Have you checked it is not one of the mods installed after Amber? The Amber mod itself only seems to append any missing stuff to the IDS files.

Link to post

The Amber mod also replaces the existing kitlist.2da with its own, which is vanilla plus her custom kit. This is a problem when you've already installed other kits, as it then requires manual editing of kitlist.2da to add her custom kit and preserve what else has been installed. I've done enough troubleshooting and checking to confirm that no other mod is causing the unwanted behavior.

 

In any case, my concern now is only in how to prevent SCSII from attempting to install TobEx.

 

Edit: Just now noticed/remembered that the way to do this is mentioned in one of the threads, so I edited scsii.ini following the instructions to disable TobEx and to disable .exe hacks. Will try another install and see what happens...

Link to post

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...