Jump to content

Low FPS on IOS


Recommended Posts

Hi Guys,


Thanks for keeping GemRB alive. It has resurrected the old gamer in me. I was able to install Baldur's Gate 1 and Icewind Dale 2 and got them running, but herein lies the problem. I'm only getting 6 FPS tops. Setting BPP to 16 didn't help. I lowered the resolution but still no joy. My device is an iPad mini with jailbroken IOS 6. I also have the latest GemRB version uploaded to sourceforge hours ago. I even closed all my running apps.


Can you advise me how to increase my FPS?

Link to comment

I have only ever seen GemRB run on an iPad 2, and it had no problem getting ~30 fps.


you are correct that bpp settings have no effect on the iOS version (it would actually slow gemrb down to go 16bpp with SDL2)

the only GemRB settings that would affect performance substantially are resolution (lower it to 640x480) and some setting for lowering the quality of the fog of war that I don't know off the top of my head.


You may want to try an older build of gemrb. Try one uploaded in April and let me know if its better or worse.


Edit: disabling audio might help too.

Link to comment

Thanks. I tried other versions, lowered the resolution and removed but still no joy :( As soon as I hit the main menu of the game, FPs is already at 6 FPS. I also closed all running apps but the same thing. It seems the problem is specific/isolated to my device only.


I guess I'll just keep installing the latest version, hoping the next one would fix it. Thanks again.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...