Jump to content

IWD Fixpack installation bug

Recommended Posts

I get this error message when I tried to install IWD fixpack v5..



C:\Games\Black Isle\Icewind Dale Complete>

ERROR: illegal 2-byte read from offset -655516548 of 3224-byte file chfc1inv.bam

ERROR: [chfc1inv.bam] -> [override] Patching Failed (COPY) (Failure("chfc1inv.bam: read out of bounds"))

ERROR: Failure("chfc1inv.bam: read out of bounds")

Assorted Fixes (Icewind Dale Fixpack) was not installed due to errors.



Any ideas?

Link to comment

From the problem I'm guessing the BAM is actually compressed, hence the crazy read offset. The path suggests this is a GOG copy of the game, but I didn't have the same issue with my own GOG install.


Do you know how to use NI or DLTCEP to extract game resources and, if so, could you attach the file? And is this a GOG install, or something else? Is 1PP installed?

Link to comment

CamDawg you are the best. Here's my weidu.log. I tried both on the DVD version and GOG version actually and got the same effect. I am using BWS as a front end to install everything. As you can see the 1pp fixes are happening first. You think that's the problem then?


I can use NI to extract game resources but kinda amateurish at it so if you want me to tell me what to do I should be able to do it.


// Log of Currently Installed WeiDU Mods
// The top of the file is the 'oldest' mod
// ~TP2_File~ #language_number #component_number
~SETUP-BWS.TP2~ #0 #0
~AB.TP2~ #0 #0
~AB.TP2~ #0 #1
~AB.TP2~ #0 #2
~AB.TP2~ #0 #3
~AB.TP2~ #0 #4
~AB.TP2~ #0 #5
~AB.TP2~ #0 #6

Link to comment

I don't think it's the cause of the problem here, but I would highly recommend not using Auril's Bane fixes (component 4 IIRC), as there's nothing in it that's not already covered by IWD Fixpack. 1PP fixes are fine; I was more curious if the mainline 1PP was installed, since it also fixes the paperdolls--if it's present, IWD Fixpack is supposed to skip this step. Both BWS and WeiDU itself shouldn't be messing with paperdolls, either.


This is frustrating because I have what I thought was all versions of the game. I've got three installs from the base 2CD IWD + HoW CD (base, HoW, TotLM) and the GOG version, and I tested this on all of them. I guess next version I'll just include the paperdolls instead of patching them.


As a workaround in the mean time, you can open setup-iwdfixpack.tp2 in a text editor and look for this block around about line 120:


// in case 1pp has been installed before us, don't f*&^ up their paperdolls

 ACTION_FOR_EACH pdoll IN chfc1inv chfc2inv chfc3inv chfc4inv chft1inv chft2inv chfw1inv chfw2inv chfw3inv chfw4inv BEGIN

// paperdoll fixes for human female clerics, thieves, and mages
COPY_EXISTING ~%pdoll%.bam~ ~override~
  READ_SHORT 0x08 frame_num
  READ_LONG  0x0c frame_off
  FOR (index = 0 ; index < frame_num ; index = index + 1) BEGIN
	WRITE_SHORT (frame_off + 0x04 + (index * 0x0c)) (THIS + 5)
	WRITE_SHORT (frame_off + 0x06 + (index * 0x0c)) (THIS - 4)




...and just delete it outright.

Link to comment


please correct me if i'm wrong. I have similar problem when i try to install IWD using: http://www.shsforums.net/topic/55904-big-world-setup-lets-call-it-gamma/page-3


If you look at the order of the instalation:


you will see that 1pp is installef after FixPack but the 1pp/1pp.tp2 file already exist because of an extraction of the 1pp mod.


So maybe the condition itself is wrong ?

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...