Jump to content

GemRB 0.8.0 released! (Fork Me edition)


Recommended Posts

The GemRB team is proud to announce a new major release.


It is a mix of new engine features, painstaking BG1 polishing, much improved IWD2/3ed support and hundreds of miscellaneus fixes. Almost a thousand revisions have been made since the previous release, so the following changelog does it no justice:

GemRB v0.8.0:
 New features:
- iwd2: Chapter 0+1 completable, full spellbook and ECL support
- multibyte font support (chinese, korean, japanese)
- favourite weapon/spell tracking, bg1 dreams
- most gemrb overrides were moved and are now moddable via game override
- initial bundled gemrb demo stubs

 Improved features:
- random encounters and spawns (properly difficult)
- iwd2 combat, stats, spells, skills, effects and actions
- animations, speech, input
- looting, worldmap, hotkeys (work everywhere), fatigue
- bugfixes


Gamewise, BG2 and IWD1 haven't received many changes, but for the first time IWD:ToTLM is playable to the end. IWD2 made the biggest strides and its Prologue can be played through with some minor caveats. BG1 got polished to make the whole TotSC a pleasant and complete(able) experience, something we thought we had already achieved. It turned out nobody tried Durlag's tower or told us of all its problems before. PST support had no major updates, but a playtesting attempt revealed most of the todos and that the plot can be followed far into the game.

The last two things would not be possible without extensive, reactive and documented testing by "traveler" and "chiv" respectively, which is greatly appreciated. This allowed the thralls to focus on actually fixing those problems and cursing at the idiosyncracies of the original implementations. While PST hasn't seen many changes, we now have a detailed list of gameplay issues to work on and test with. Interestingly, IWD2 support turned out to be much more complete than we had anticipated, so the doors are wide open to making it as nicely supported as BG2 in a release or three! We've also started a small dataset that is bundled with GemRB, a sort of demo. On that note, we're looking for help in any available form!


To make collaboration even easier, we moved our GIT code hosting to Github. Existing users of git gemrb don't need to restart the download, but just run git remote set-url origin git://github.com/gemrb/gemrb.git first and then continue updating as usual.


Exciting times!


Currently only the sources and some packages are available. You can get them from here (project page link!). Including a new Android build thanks to psch.


Release notes:

GemRBOverridePath was split, so it now contains only the few real gemrb
overrides. A new preset path variable has been introduced to hold the
remaining files, called GemRBUnhardcodedPath. It is searched after the
game paths, so its can be easily modified by being placed in the game's
override folder.

New optional dependency on iconv for chinese, korean and japanese
translations of the game (we need to convert their dialog.tlk).


Oh, just one more thing. ;) Many of the goodies in this release would not be possible without our newest mage "fizzle", so give him some praise.

Link to comment

For some reason the android version is force crushed every time I run it


could be, but its more likely you are assuming this because the new build doesnt have the gui config interface before hand and its exiting due to lack of valid configuration.


as lynx said, check the log.

Link to comment

Its still don't work. When I run the app there is a black screen and the app is shutting down


I have the exact same problem and it doesn't get as far as creating a log!


I've tried both updating my 0.7.2 and a fresh, clean install. Same result: ANR (app not responding).



Attempted to attach my traces.txt file, which means nothing to me but will hopefully help someone - but, it didn't work (from my tablet). If someone needs this or a logcat, let me know and I will upload it from my desktop.


Oh, and thanks guys! GemRB makes my tablet fun again. I love it.

Link to comment

Thanks to SyntaxError and psch for your hard work in getting a nice SDL2 + Android version available. I am really looking forward to try it out.

Fizzle, as mentioned, has been a machine in terms of fixing stuff so kudos to you!


Great to have the 0.8 version here at last. I wish you guys (and fuzzie) all the best!

Link to comment

Then do check the log, it should be available (sounds like missing data).

there is no log created. The app shuts down before any log is created


surely alogcat could produce a system log if there is no gemrb.log created


if possible, we ought to initialize the file log sooner...

Link to comment

Just wanted to share my findings regarding installing the non-crashing 0.8.0-android version:

When I start the app I see blackness, and then the app closes nicely.

As far as I can tell we do not get anything logged in the system log (checking with aLogCat)


Looking in the /storage/sdcard0/gemrb-folder i have the following file structure:


bg1\cache (empty)



The GemRB.log shows a lot of "invalid path given" (I would assume due to the fact that gemrb.ini does not exist), and the first one being /sdcard/gemrb/bg1/override.


Don't know if this helps, but I wanted to share my findings.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...