Jump to content

Black borders problem solution (Windows, ATI users only)

Recommended Posts

I've been having this issue since the first day I started using the Widescreen Mod and couldn't find any working solution until recently.

As far as I saw the problem presents itself on certain monitors along with desktop ATI (AMD) video cards and under certain resolution combinations in Windows only. Nvidia seems to avoid this particular one (though it's got other nasty issues reported) and normally laptops are not affected as well since their video drivers usually have a scaling/aspect ratio correction settings available. Also this problem is completely different to the visually similar issue in Wine (OSX, Linux). Additionally I am currently talking about a clean IE games installs with the Widescreen Mod alongside (no ddraw fixes, windowed modes, etc.)


Since I find almost no info that could help me resolve the issue I've decided to put it here for anyone who still suffers.


Steps to reproduce are:

1. While installing the Widescreen Mod set resolution several steps lower than your native one. For ex. our native resolution is 1920x1080 and we config the mod for 1280x720 maintaining the aspect ratio of 16/9 (it's not necessary to maintain the aspect ratio but it's a common practice for obvious reasons).

2. Run the game in full screen mode which will be 1280x720 and you'll see the black borders around a smaller than the expected resolution image. Example: http://img585.images...5/7750/hruz.jpg



1. Go to the CCC's Advanced View

2. Under "My Digital Flat-Panels" section go to the "Properties (Digital Flat-Panel)"

3. Turn ON the "Enable GPU scaling" option under "Image Scaling": http://imageshack.us...4/4633/rtdi.png

4. Now go to the "Scaling Options (Digital-Flat Panel)" screen.

5. Check that "Scaling options" are set to "Overscan" (0%) and "Use the scaling values instead of the customized..." is turned off: http://imageshack.us...41/600/2n79.jpg

6. Apply the changes


- Setting "Scaling options" to "Overscan" ~ 0% alone (as suggested by various posts found in the Web) does not resolve the issue.

- If you have more than one monitor select the correct display from the drop-down menu above after steps 2 and 4.

- This solution supposes that you have CCC v13.0 or later installed.


Also there is a bug with CCC and ATI drivers updates. If you upgrade the drivers from v12.x (or earlier) to v13.x the new default settings will not have effect since the v13 would try to keep previous settings disregarding the new features like scaling, etc. What I mean is that just entering the listed screens and applying the already correct settings may solve the problem.


Hope this helps and Regards

Edited by akaine
Link to comment

I followed the steps above but it didn't work for me with latest drivers. I found another solution however:

1. Download DxWnd and extract the archive.
2. Run dxwnd.exe.
3. Go to Edit > Add.
4. Under the Main tab, enter the path to bgmain.exe.
5. Under the Generic section, uncheck "Run in Window." This will restore your display resolution when the game is minimized.
5. Under the Input tab, Cursor handling section, uncheck "Correct mouse position."
6. Click OK.
7. Double click the newly created icon that appears within the DxWnd program window to run the game.

Link to comment

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...