Jump to content
Sign in to follow this  
DavidW

Final bugfix report on v7

Recommended Posts

IWD-in-BG2 v8 will be available in a few minutes, so here's my rundown of all the extant bugs on this forum from v.7.0-7.13. This is most (but not quite all) of what got fixed or tweaked in v8. As always, thanks to everyone who submitted reports, and in particular, huge thanks to Grogerson for exhaustive reporting.

 

Fixed in v8

Wall issues in AR6004, AR6013, AR8012, AR9700, AR9709, AR9710

The Eldathin now correctly use their spells.

Various creatures which were missed off the hidden-creature code now spawn correctly.

Fixed some glitches in Stoneskin conversion.

The bone talisman now has the right number of charges.

Difficulty-related spawning should now happen more smoothly.

Some more broken sahuagin crossbow-user animations, which were causing crashes, are fixed. This should resolve the crashes in the Sahuagin temple and the final battle with Icasaracht, which are (I hope) the last extant crashes.

Cavaliers can use gloves

Priest spells marked as unusable by LCneutral creatures are now correctly marked as unusable by GEneutral creatures.

Hjollder is no longer invisible when you return to Kuldahar.

Stair triggers in AR6004 work correctly.

Hobart isn't duplicated in the Whistling Gallows.

Luremaster's spectral heroes now spawn correctly.

Seth (and others) should now leave the area correctly when they try to.

Emmerich does not randomly appear in Lonelywood.

Moradin's Staff now works.

Projectiles aren't setting their targets right - Haste, Horror differ from their BG2 equivalents and at least Haste has noticeable consequences.

The thieves in Dorn's Deep near Seth are malfunctioning due to awkward interactions between IWD fixpack and IWD-in-BG2. IWD fixpack has radically recoded this since v7, so I think it should be good now.

 

Possible bugs that I've left unfixed

Various reports that pickpocketing gives slightly different results in IWD-in-BG2 than in vanilla. I'm not convinced I care.

 

Not Bugs/No Action

AR3000 - There is an actual Shadow, not a Lesser Shadow, near the entrance to K's tomb at about 3154.716. And it *does* drain strength.

AR3503 - Found two more actual Shadows, just inside the northern alcove. The other four along the walls are Lesser Shadows.

They're there in the vanilla game too. (I have a vivid memory of meeting the first shadow when I first played the game!)

Yuan-ti are sometimes transparent.

This is Chameleon Power; they're supposed to use it.

Winter wolves don't seem to use their breath weapon quickly enough when they attack. Most died biting without breathing.

So far as I can see it's functioning as it did in vanilla.

(AR9603)Ice Golems. They went hostile prematurely twice. The first time the thief went to disable the trap it stood upon. The second the thief simply stood next to it. They should be immovable and remain neutral until attacked.

This is intentional and is a limitation of the BG2 engine. In IWD you can't shoulder creatures out of the way; in BG2 you can. So the only way for the Ice Golems to function correctly (that I can think of) is for them to go hostile when you approach.

AR2113 - Gerth still doesn't buy keys, contrary to what he claims and vanilla does.

Unfortunately the BG2 "plot-critical" flag also makes items unsellable, unlike in IWD. So if the keys are made sellable, keys left lying around could disappear, which breaks the game. So I don't think I can fix this.

AR2101 - Orrick went hostile when a pickpocket failed. Is this vanilla behavior?

Yes, it's vanilla.

AR5202/03, AR5301/02 - The clerics and acolytes are enemy (red foot circles) when you enter, not neutral (blue foot circles). They don't act hostile until attacked. As I recall they are to become hostile when you move into certain areas in the room or attack them.

I can see a pretty good case for them being blue, but actually, they're red but non-hostile in the vanilla game. The ones in AR5202 and AR5203 don't attack unless attacked first (though Denainy in AR5201 gives you some motivation).

 

Cannot reproduce

Tried to rest in ar8001. Got interrupted by salamanders.

During the battle I got this message few times...

Salamander- Sleep outside in these parts, friend, and you'll die of exposure. Better find an inn if you want to rest.

At least they're polite and smart enough to know that they're not going to kill me...

Can't reproduce.

AR8009 - The three umber hulks hiding behind walls are visible and immobile if you restore from a save in the area. Had the same thing happen in Severed Hand.

Can't reproduce (and it *should* be impossible on the new version.)

AR2004 - Uligar's archer failed to go hostile the first time I fought the battle. Reran it and he did...

Can't reproduce, so I'll write it off as a glitch.

AR4003 - Undead Lieutenant at 2018.1504 didn't go hostile after dialog, but did when attacked. Possible failed dialog trigger?

Can't reproduce, and looking at the dialog files it oughtn't to be possible. If you can reproduce it let me know.

AR4001 - After dealing with a couple of spiders there I found a sword spider unable to move. It was hostile but immobile.

I've looked around, but I can't find it. If you can reproduce it, give me its coordinates.

AR6014 - I tried to re-enter Bandoth's lab after completing the Razorvine quest and Tiers of the Dead, intent on returning Kalabac's journal. All I get is a CTD. I had this in previous runs as well.

I can't reproduce this even using Grogerson's savegame, so I have no idea what's going on here. Graphics card issue of some kind? If anyone EXCEPT Grogerson gets this bug, I'd really like to know.

DRAGON'S EYE - In the southern area, I had two sword and two wraith spiders join in with the bombardier beetles. They should have remained in the alcove south of Erevain's body.

Their help script is restricted to that group and not shared with the beetles, so I *think* one of them must have been caught sight of or something. (If you can reproduce it, let me know.)

AR9718 - Two of the three slimes were overlapping and stopping each other along the far right wall.

They're all okay on my install.

The trapped chests in AR9705 all trigger, including the one with the scroll. I thought that one wasn't supposed to.

Can't reproduce.

water kin elementals in AR9603. All five appeared to be over the floor instead of in the water.

On my install they're over the water.

[various problems with wild mages]

They're fine on my install.

entering the Watchtower (AR8002). The access point was hard to get to and required three tries. Probably needs to be moved a bit.

It seems basically okay to me.

After the Burial Isle the spell Web didn't seem to work. I'd see the casting animation, it would say it was cast, but no indications it activated

Can't reproduce nor understand; if it happens again, send me a savegame.

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...