Jump to content

Recommended Posts

After 3 new installations this bug didn't occure any more. But i have a new problem, the same like chad.

If i return from the temple to arundel, i can't tell him the news of the stolen artefact.

Can i solve this with the console?

I allready solved my problem with Lysan on that way.

Edited by Fingolfin

Share this post


Link to post

If someone has the same problem:

 

open the shadowkeeper and enter in the last register:

 

AR3600_VISITED

AR3601_VISITED

AR3602_VISITED

AR3603_VISITED

 

Than you can proceed and speak with Arundel.

Share this post


Link to post

That solves heartstone stolen quest yes, but unfortunately there are some bugs later too.

At severend hand shadow elves keep appearing and disappearing which makes them one tough kill (and by that I mean it takes long time and much luck to kill them all - not how difficult battle is). Kaylessa seemed to not recognize me killing her friends upstairs even though both variables (soldiersdead 24, kaylessaquest 1) were right. Really weird as I checked dialogue conditions and it should kick in no problem. Had to kill her when she's blue circle (neutral) and not get any real reward for that :/ Also some big scary shadow on lower parts of Severed Hand should drop random treasure (or so) - either I was so unlucky to roll always the same or it really drops only one and the same item right now (mithril plate iirc, in vanilla game it used to drop some other items - or it's just how I remember it). Glacier - yes, salamanders etc. doesn't go all hostile when u let slaves go away. You can kill them group by group and trolls, wolves nearby won't interfere (or go hostile). You need to manually pick them as targets. UI is somehow wrong. For thieving skills top displayed skill has only "-" which actually doesn't work, also scrolls on skill description and skill list are reversed - so skill description (or lvl up description) scrolls skill list and vice versa - skill list scroll does the same for description. Unfortunately this one is serious as it doesn't allow any thief of getting past 35 (or so) pick pocketing. More serious problems appear to be in HoW/TotLM part of the game. Hobart dialogues (and for the record I believe all totlm related dialogues) are near blank. You can choose "blind" options if you know correct order and then proceed with quest but that's annoying one. And at the end there's also sahuagin matter - in the temple and at dragons den they might try to cast some spell or use some item which crashes the game. To end HoW I had to go with invisible thief and ctrl-y every one of them after few attempts to get them regular way :/

BTW somehow I wasn't able to use cleric scroll spells on either Cleric of Lathander, Undead Hunter (paladin kit) and Archer (ranger kit). Those are bugs I encountered in first time run with V8. I believe with them taken care off this mod along with tweaks and npcs might turn out to be quite great for ppl with no skills at dltcep :)

Cheers

Share this post


Link to post

Bugs:

- In dialogs the name of the NPC is unreadable.

- Sorcerers can not get "Protection from Petrification."

- Sorcerers can not get "Dimension Door".

Share this post


Link to post

 

On 11/10/2013 at 3:42 PM, c4eliquid said:

Can't get Lysan to show up in the Yeti caves

On 1/11/2014 at 12:42 PM, chad878262 said:

Lysan is not there again

On 11/14/2013 at 11:16 AM, decado said:

I had the same issue which I couldn't resolve. A full re-install and tons of playing with triggers achieved nothing. I ended up abandoning the game.

Hi everybody, I recently started to play "IWD in BG2" and today I had your same problem: Lysan not showing up in the yeti cave after speaking to Kresselak.

I searched the script but it ended up to be just fine: (I tried to edit it but still nothing happened) the problem is that the script is not linked to that area...

The solution is to put the file "AR3001.ARE" I am attaching there in the override folder (or you can edit and fix the AR3001 area with DLTCEP as I did)

Then you will find Lysan in the cave after telling Kresselak that you are going to kill her BUT onty if you never went in the cave before (in that save).

If you already went into the cave, you have to fix your save with NearInfinity and remove AR3001.ARE from BALDUR.SAV (like shown in NearInfinity.png)

 

I hope it helps you and other people with the same bug, until the author of IWD-in-BG2 will fix it.

Bye

IWDinBG2_bug_AR3001_Lysan.png

NearInfinity.png

ar3001.are

Share this post


Link to post

IWD-in-BG2 is defunct as a project (as noted on the pinned threads) - it was absorbed into Icewind Dale: Enhanced Edition.

I should probably have closed this thread; apologies. I'll do it now.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...