Jump to content

Pathing output in DLTCEP v7d


Recommended Posts

I upgraded to v7d, and for some reason I seem to be running into all sorts of trouble on both regular BGIi and BGII:EE - no matter how I play with administrator settings, pathing, etc. I keep running into



Any ideas on this? I have tried \ and no \, I have tried creating a new directory,. I don't have UAC enabled, and this happens whether I am on drive G:\ or BeamDog's enforced Program Files (x86).


At first I thought it was a permissions problem, but I think i have ruled that out (running as administrator).

Link to comment

Thanks - I tried, but still no love. In fact, I have tried several versions - no luck. I removed the BeamDog files and reinstalled them off of c:, I made sure everything is running as admin, and I attempted both BG2 and BGII:EE. I'm on Win7 x64... never had this problem before. I wish I knew what had changed; I used this two weeks ago on .dlg checking and decompilation, and it worked fine (it choked on script decompilation with the same error I have posted, but I figured it was me not configuring weidu correctly).


I set the path for output as E:\BeamDog\00546\scripts and as E:\BeamDog\00546\scripts\ - still not working.

I found the parser for DLTCEP, but can't figure out how it is setting the path specifically, or more specifically why on both .dlg and .bcs decompilation it throws this message. It seems to find and read the game files just fine.







tmpstr.Format("%s cannot be created as output path.",outpath);

MessageBox(tmpstr,"Dialog editor",MB_OK|MB_ICONSTOP);

return -1;


Link to comment






OK. It works. The problem is the age-old fight between







..\scripts fails.


../scripts works.


So, the answer for windows users is NOT to copy their address from the systems tools, as this will *fail* on DLTCEP:




whereas if you type it in,




it will work.


Not only that, but an actual positive - if you use




it jumps back a level and puts the decompiled content there. So it does not need to be a subdirectory - it looks like the positive side of this parsing change is that you can set an unrelated directory. This might be cool.


P.S.: I do not consider this a bug, and I am *not* complaining - I am expressing my amazement at my own stupidity at not thinking of this in the first place. The clue was staring me in the face each time I reset weidu options... it reads

"weidu\dialog.d" --tlkout "e:\beamdog\00546\lang/en_US/dialog.tlk" --log dltcep.log

which should have been a pretty obvious heads-up that the *first* thing to try should have been swap \ to / and see what happened.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...