Jump to content

GemRB on raspberry PI problem


Recommended Posts



Im new to gemrb and am trying to get things running on a Raspberry PI linux based computer. (running raspbian-debian based os)


Everything has compiled and runs well on the little system using sdl1.2 graphics


Im just having one minor problem with dialog text display.


When dialog is displayed in the bottom of the screen, eg when talking to NPCs, each new post is a little shorter. So when starting the game (bg1 or bg2) the first conversaion starts teh full length of the dialog box, by the end of the conversation things are displayed 1 word per line and scroll off the bottom of the window.


Ive tried various options to fix this , such as changing screen resolutions and using the widescreen mod on my install (both gemrb and infinityengine modes). Neither solve the problem.


Im wondering is this a known problem or perhaps im doing something wrong in the setup/compile ? Im compiling against python2.7 and sdl1.2.


Any help would be appreciated, thanks

Link to comment

known issue, however, we dont know what is causing it since none of the devs can reproduce it. It probably wont matter since the text display system is currently undergoing a ground-up rewrite, but that is still a month or so off from being merged in (depending on my free time).

Link to comment

I found that '-frerun-cse-after-loop' (added with '-O2') caused the text area to shink by about 10 chars on each message. Adding '-fno-rerun-cse-after-loop' to the CMAKE_*_FLAGS fixes this for me, and still allows you to run with '-O2'.


This is may be possibly caused by ARM defaulting to unsigned chars in GCC, as demonstrated here:



Finally, thank you for GemRB guys. Looking forward to the GL functionality.

Link to comment

Thanks! Following that, did you try with -fsigned-char? Sounds like a more proper fix and we could apply it everywhere. If that doesn't cut it, do you know how to detect rpi from cmake? I couldn't find anything useful on the net.

Link to comment

I would recommend usnig -fsigned-char also, i use it in all my arm builds. I will have to check my cmake files to see if i missed in on this one.

It also might be good to use stronger types and specify the sign i.e stdint.h types


SyntaxError: are your text change in yet?

Link to comment

bought myself a raspberry pi 2 and revisited this with 0.8.2


seems the -fno-rerun-cse-after-loop helped with BG1


originally i tried this in my .bashrc build variables but it didn't work

CXXFLAGS=-march=armv7-a -mfpu=neon-vfpv4 -mfloat-abi=hard -O2 -fno-rerun-cse-after-loop

so i tried it in gemrb/configure.in


CXXFLAGS="$CXXFLAGS -Wall -W -Wpointer-arith -Wcast-align -pedantic -Wno-format-y2k -Wno-long-long -fsigned-char -fno-strict-aliasing -fno-rerun-cse-after


text is looking a lot better now. thanks.


only other build change i had to make was Freetype include directories would not auto detect. i changed gemrb/plugins/TTFImporter/Cmakelists INCLUDE_DIRECTORIES ( /usr/include/freetype2 )


Many thanks to everyone who helped with this.

Link to comment

I've made an install script for the latest RetroPie project beta to install GemRB and setup simple paths/configs to get things running.

Tested on Raspberry PI 2. Any suggestions on further improving this would be appreciated!


forum post








Link to comment


This topic is now archived and is closed to further replies.

  • Create New...