Jump to content

Unearthed Arcana presents Scales of Balance: a post-hac tweak pack


Recommended Posts

Guest Juan Lopez

Thank you for the information, I'm new at modding so I have a few questions. I want to play the game with EET, SCS, Spell Revisions, and of course Scales of Balance, but since SCS and SR may not be updated to BG 2.6 soon, I'm using 2.5 version instead. Can I use the latest version of Scales of Balance or it isn´t compatible with 2.5 anymore?

Link to comment
Spoiler

ERROR: [weapprof.2da] -> [override/weapprof.2da] Patching Failed (COPY) (Invalid_argument("index out of bounds"))
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [SBO - Stat Bonus Overhaul], rolling back to previous state
Will uninstall 263 files for [SCALES_OF_BALANCE/SCALES_OF_BALANCE.TP2] component 200.
Uninstalled    263 files for [SCALES_OF_BALANCE/SCALES_OF_BALANCE.TP2] component 200.
ERROR: Invalid_argument("index out of bounds")
Please make a backup of the file: SETUP-SCALES_OF_BALANCE.DEBUG and look for support at: SubtleD
Using Language [English]

Install Component [SBO - Stat Bonus Overhaul]?
nstall, or [N]ot Install or [Q]uit?

Spoiler

ERROR: cannot convert bastard or %bastard% to an integer
ERROR: [weapprof.2da] -> [override/weapprof.2da] Patching Failed (COPY) (Not_found)
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [WPO - Systemic Proficiency Changes], rolling back to previous state
Will uninstall 554 files for [SCALES_OF_BALANCE/SCALES_OF_BALANCE.TP2] component 122.
Uninstalled    554 files for [SCALES_OF_BALANCE/SCALES_OF_BALANCE.TP2] component 122.
ERROR: Not_found
Please make a backup of the file: SETUP-SCALES_OF_BALANCE.DEBUG and look for support at: SubtleD
Using Language [English]

Install Component [WPO - Systemic Proficiency Changes]?
nstall, or [N]ot Install or [Q]uit? I

 

Im getting this errors when trying to install stat bonus or weapon profiecy changes 

im try to place origenal weapprof.2da  (Without any changes by any mod)  in to "override" folder on install time but get same error.

My modded weapprof file and weiDu.log in attachments.

What's could help in this situation?

weapprof.2da.txt WeiDU.log.txt

Edited by AweDeus
Link to comment

it's strange, because i was trying to install mod's in order that autor's shown on github, with SoB in the last.

Spoiler

image.png.b38e8a61ff5c188906191a5c318f400a.png


 

So, - you see only one prob, right? Well, then i don't know what to do, becuse i just tired to install and reinstall all those stuf.


(ahh, also it's seems that order in the log is not que right, because i've reinstall mod's by itself after, but trust me - those component did'nt fit when i run the fresh install first time anyway)

(How can i get my real mod orders list?)

Spoiler

24234234.PNG

Edited by AweDeus
Link to comment

I can’t tell what the problem is. I don’t get those errors when I do a test install. Possibly some of those mods are borking a file and then prevents SoB from reading it correctly? E.g. I’m pretty sure the IWDEEKit mod has not been updated since before the 2.0 update. Maybe some of the other ones, too. 

(Also, don’t install the standalone Mana Sorcerer, it is out of date and the newer version is in Tome & Blood. I should probably delete that repository...)

Link to comment
Posted (edited)
On 7/24/2021 at 9:30 PM, yakattack said:

With the weapon proficiency overhaul, is it correct that warriors no longer get APR at 7 and 13? Could be a good thing to add to the readme if so.

Correct, and I thought that is already mentioned?  I'll double-check. 

Meantime, the mod has been updated to v5.32, updating the YARAS component and the included semi-spontaneous casting function to work with v0.8 of the 5E-style spellcasting mod (or mods that use the same system, like TnB's Arcanist and MnG's bards)

The semi-spontaneous function library is shared by several of my mods. If you are using any 5E-style casting, you want to make sure you use the following mod versions (or later):

  • 5E Casting v0.8
  • Tome & Blood v0.9.12
  • Faiths & Powers v0.79.26
  • Might & Guile v4.12.1
  • Scales of Balance v5.32

Cheers.

Edited by subtledoctor
Link to comment

I just tried to install "Component 240: Poison Overhaul (MRO): Revised Poisons" from the mod and get the following error:

Copying and patching 1 file ...
[./override/U#DAGG01.ITM] loaded, 658 bytes
INSERT_BYTES out of bounds - file is long 658, point given is 1186
ERROR: [U#DAGG01.ITM] -> [override/U#DAGG01.ITM] Patching Failed (COPY) (Failure("INSERT_BYTES out of bounds"))
Stopping installation because of error.

This ITM (and the other attatched ITM with the same error) are from the Mod "Ruad Ro'fhessa Item Upgrade Mod" (latest Version 29.4.0).
https://github.com/SpellholdStudios/RuadRofhessaItemUpgrade

I have this problem trying to install the mod on BG2; on SOD i can install the mod without any problem. So this seems to be a problem with this to specific ITM. Do you have any idea?

 

 

u#dagg01.itm u#sw1h02.itm SETUP-SCALES_OF_BALANCE.DEBUG

Link to comment

It's possible those items are formatted in a weird way that defeats the mod's attempt to patch them; I have no experience with that mod.

But if that's the case then this might not work well anyway - the Poison Overhaul is pretty touchy, and prone to malfunctioning. I don't even use it myself anymore - instead I just use the alterations to Slow Poison and Neutralize Poison in my 'Random Tweaks' mod.

Link to comment

I was trying to install the stat changes that comes with this mod and I get this below. AT first I thought it was another mod, but when I try to install JUST this mod on a fresh install, the error still occurs. Any ideas?

 

In state 1389, I expected one of these tokens:
  [38] PLUS
  [48] BEGIN
  [64] LT
  [80] MINUS
  [105] BASR
  [135] GT
  [148] BXOR
  [158] DIVIDE
  [192] BLSR
  [216] BOR
  [222] BLSL
  [239] MODULO
  [243] QUESTION
  [246] TIMESTIMES
  [291] OR
  [312] AND
  [323] TIMES
  [331] EQUALSEQUALS
  [354] LTE
  [381] THEN
  [385] BAND
  [408] EQUALS
  [426] GTE
  [428] NOTEQUALS
Parse error (state 1389) at ~~

[scales_of_balance/lib/weapprof_dialogue.tpa] PARSE ERROR at line 152 column 8-51
Near Text: and
        GLR parse error

[scales_of_balance/lib/weapprof_dialogue.tpa]  ERROR at line 152 column 8-51
Near Text: and
        Parsing.Parse_error
ERROR: parsing [scales_of_balance/lib/weapprof_dialogue.tpa]: Parsing.Parse_error
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [SBO - Stat Bonus Overhaul], rolling back to previous state
Will uninstall 126 files for [SCALES_OF_BALANCE/SCALES_OF_BALANCE.TP2] component 200.
Uninstalled    126 files for [SCALES_OF_BALANCE/SCALES_OF_BALANCE.TP2] component 200.
ERROR: Parsing.Parse_error

Link to comment
Guest Juan Lopez

Hi, I want to make some changes to SoB. I wanted to change the penalty to casting time to casting failiure for wearing armor, but it seems to have some complex interactions with other mods like FnP, so instead I added it on top of the speed penalty. Next I wanted to merge short sword proficiency with ninjatos and wakizashis, and make them small size type so that they can be used as daggers when dual wielding, but this has been more difficult because it seems to be a little more complex than the armor component. I have no problem editing other things like damage and apr. Can someone help me please, to be precise with merging weapon categories and changing their size?

Link to comment
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...