Jump to content

[Bug Report] Cleric of Iyachtu Xvim, Lorekeeper of Oghma kits interfering with eachother, causing crashes


Recommended Posts

Alright, so-- I don't typically install ALL the kits when I'm installing DR because there are quite a few I'd never make characters for and so they'd just be dead weight on my kits list. So when I was installing the v8 beta (onto an EasyTutu install) I didn't install a few kits, and everything went fine until I chose not to install the Xvim kit and then installed the Oghma kit right after, as it comes next on the setup list. Then the errors started happening.




Despite this, I tested it out anyway just to see how much of a problem it really was... and there was a crash during character creation if you select the Lorekeeper kit and then hit "skills". A reproducible crash too, because it happens literally every time.


I took a look at the .tp2 and it seemed like there was a mistake in the lines about holy symbols under the Lorekeeper section (I don't have the line number available right now, sorry) wherein the values from the Xvim holy symbol section were typed in there instead of the Oghma ones--off the top of my head, the mistake was specifically with the strings that are passed to holysym.baf. Hence the error while installing without there being any Xvim kit to refer to! However when I tried to start over (clean install, then edit the .tp2 to include what I thought would be the appropriate Oghma-related values, then reinstall the mod) it didn't throw any errors during installation anymore but still crashed at "skills" during character creation.


I wouldn't be as bothered about this if I wasn't trying to specifically create a playthrough with a Lorekeeper character right now. But as it is I've had to revert back to using v7, which is a shame because I really wanted to take advantage of not having to use the sphere system.


In advance, no I don't have any other kit-adding mods installed, and while I was troubleshooting this it was in fact the ONLY mod I had installed at all. No point installing everything when I had to clean-install like 4 times in a row just to make sure nothing was buggy, y'know? But I figured somebody should take a look at this... plus I thought maybe someone might know an easy way it can be fixed so I can just do it myself until a new version of the mod comes out (whenever that might be).

Link to comment

Hello, Raiha


I found the same problem in the character creation of a lorekkeper, the gamecrashes during the skills assignement(not when clicking on "skills" but inmediately after the assignment of proficencies and spells, when you click on "done"). I look in the .tpa file and i found the same problem you mentioned about the holy symbol, and I tried to edit like you did, but the game always crash when i get to that skills point.


I have very little idea about modding so I'm afraid I can't help you. Just wanted to show some kind of solidarity and ask you if you managed to fix the problem somehow.


It's a pitty since this was a very interesting kit.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...