Jump to content
Sign in to follow this  
szkut

bgt and gemRB (my first time:))

Recommended Posts

Welcome,


I'm trying to gemrb some time on the Alcatel One Touch pixi 7. gemrb versions: with this link http://sourceforge.net/projects/gemrb/files/Other%20Binaries/android/0.8.0/ - did not work (black screen and crash to the desktop). Version gemrb_11bfc23_20120711.apk 2012-07-11 worked.


I put in it:


Download gemrb override and scripts

Date instalation location - default

gemRB.cfg.sample renamed the file on gemRB.cfg


I set in cfg:


Gametype = bg2

Screen width 960

Scren height 540

GamePath =. /

CD1 =. / Bg2 / data /

CD2 =. / Bg2 / data /

CD3 =. / Bg2 / data /

CD4 =. / Bg2 / data /

CD5 =. / Bg2 / data / (bg2 is the name of the folder with the game)


I tried to insert a folder bg2 to:

sdcard / app-data / here

and

sdcard / gemrb / here


I wanted to play in:

BGT, where bg2 is clean and bg1 has mods


All the modes are of the type WeiDU and instal them in the order:


Baldur's Gate II Fixpack

Baldur's Gate Trilogy

BG1 Unfinished Business

BG1 NPC Project

Widescreen Mod

Bigger Fonts


after turning gemRB - does not work crash to the desktop


GemRB version 0.8.3-alpha1-debug.apk-2015-07-12 - I have not tried



Share this post


Link to post

those older versions are not supported any more; too much has changed.

Share this post


Link to post

Can you upload GemRB.log somewhere?

Share this post


Link to post

were can i found logs?

 

/storage/sdcard0/gemrb/bg2/gemrb.log its empty (I looked him via notepad ++ application in tablet)

 

before installing the latest version gemrb I have formatted the card, so i dont have bg2 files on it.

Share this post


Link to post

hmm, is at least its timestamp (modification date) recent? Logs are written on the fly, so even force-killing gemrb should leave a trace (does so here). So perhaps android broke it in the wrapper, not later.

 

But why are you trying without a game? Either try with the gamedemo or put bg2 back on, since it can't work without data.

Share this post


Link to post

I thought to firstly fires up the program itself, then choose the game ... my bgt have almost 6gb and copies itself 5h :) - i will download demo version.

Share this post


Link to post

i just copy all files bg2 demo (without .exe) to:

 

/storage/sdcard0/gemrb/bg2/ here (not bg2demo folder but all files inside bg2demo folder)

 

run gemrb - black screen and crash to desktop.

 

/storage/sdcard0/gemrb/bg2/gemrb.log empty via tablet and windows

Share this post


Link to post

did you change your GamePath, CachePath and CD1(other cd paths don't matter) to point there or to its subfolder?

Share this post


Link to post
#GamePath=/storage/emulated/0/Android/data/net.sourceforge.gemrb/files/bg2/

#CD1=/storage/emulated/0/Android/data/net.sourceforge.gemrb/files/bg2/data

GamePath=/sdcard/gemrb/bg2

CD1=/sdcard/gemrb/bg2/data

# CD2=<CD2_PLACEHOLDER>

# CD3=<CD3_PLACEHOLDER>

# CD4=<CD4_PLACEHOLDER>

# CD5=<CD5_PLACEHOLDER>


CachePath=/sdcard/gemrb/bg2/cache


this is the path of the game: /sdcard/gemrb/bg2 i copy to bg2 folder not Baldurs Gate II Demo folder with subfolders but subfolders + the rest files - .exe

Share this post


Link to post

Try with 640x480 for a test. The builds worked in the emulator and for someone else, but I think we were both on pretty old android versions.

Share this post


Link to post

i dont change resolution id demo. there is a default resolution 640x480. i have 4.4.2 android

Share this post


Link to post

can you install alogcat and try to get useful debugging info from that?

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...