Jump to content

Help with Widescreen mod on Windows 7 GemRB BGT install


Recommended Posts

Hi all,

First time poster, LONG time lurker. However, the promises held by the latest version of GemRB has brought on registration and a forum post...

Long story short, I've completed a fairly heavily modded BGT install on Windows 7, and for the first time configured GemRB. No real problems so far, I can access both BG1 and BG2 games through GemRB, and I've tested a couple of mods which appear to be present and working. I've also successfully added the 10pp and sorcerer-monk GemRB mods, which also seem to work fine.

My main problem is with the Widescreen Mod. I cannot for the life of me figure out how to get this to work, and haven't yet managed to find a guide that explains the use of this with GemRB. I've always used Widescreen Mod in the past for a vanilla(ish) BGT or BG2 install, but nevre with GemRB so I'm in unexplored territory.

Basically I've tried installing it for both the regular Infinity Engine and for GemRB, but GemRB aways starts up in a 640x480 window. I've tried editing the gemrb.cfg file to use the screen resolution I've installed with Widescreen mod, but either get an error code relating to a GUIScript (start.py) or get a freeze and crash when GemRB tries to load guisvrb.bam. Can provide logs if required, but I feel this is something obvious that I'm missing.

Would appreciate any help or guidance.



Link to comment

First, congrats on the setup, we usually only hear when things don't work.


I haven't tried widescreen in a while, but your approach is fine (mod+cfg). I have a todo to merge the two modes before the next release, but that's about it. What is your target resolution?

Link to comment

Thanks - I was also pleasantly surprised! Admittedly I haven't gotten into the meat of BG1, BG2 or TOB yet, and I'm expecting bugs, but all the basics seem to be working fine (dialogue, combat, journal entries, cutscenes).


Target resolution is 1366x768. While I'm no Python scripter, I had a tinker with Start.py as LoadWindowPack appears to be coded to use a resolution of 640x480 rather than window resolution. Didn't have a lot of luck here though.


For reference' sake, I had a look at guisvrb.bam with NearInfinity, and it appears to be a small button (screen grab at http://imgur.com/i0XdtvO).



It's the last thing that shows up in GemRB.log prior to a freeze-crash, but I think the problem is more of a failure to config properly on my part rather than this specific file causing a problem. Is there a standard as to what the gemrb.cfg should look like when using the Widescreen mod?

Link to comment

...but either get an error code relating to a GUIScript (start.py) or get a freeze and crash when GemRB tries to load guisvrb.bam.

Are you trying to use the ToBEx mod ? Aka a mod that expands the BGMan.exe's usage... cause I would expect that you can't use that.

But then the GemRP already should have all the things it can already covered in most orderly fashion without the ToBEx.

Link to comment

as for the config, setting the same resolution is enough. The windowpack values in Start.py describe something else and I think widescreen only touches the in-ingame controls.


things changing bgmain.exe shouldn't matter, since we don't use it. Any accompanying data changes could though.

Link to comment

@Jarno With regards to TobEx, it appears that TobEx has been included with one of the mods I'm using (Rogue Rebalancing I think), though TobEx doesn't start and doesn't seem to need to start for me to actually load the game. To be sure this isn't causing a problem, I've uninstalled this mod and the TobEx files have subsequently disappeared from my BGII directly with no change


@lynx I've added in the following to my gemrb.cfg:


GemRB starts at the correct sized window, though the actual menus are still 640x480 within the game with a large black background. When I either start a new game or try and load an existing game, the regular BG loading bar gets about two thirds of the way full, then the game crashes - the latest line in the console is:
[ResourceManager]: Found 'guisvrb.bam' in 'chitin.key'.
This only occurs if I set the Width and Height in gemrb.cfg to anything other than 640 and 480 respectively, irrespective of whether the Widescreen mod is installed or not.
I've included a link to my GemRB.log: http://pastebin.com/TWVT5Qe7
Thanks for the help so far
Link to comment



Thanks to another post on this forum, I realised that the mod 'Bigger Fonts' was causing the issue. I removed this, re-installed the Widescreen Mod using the 'For GemRB' option, sorted the paths in the bg2.cfg file and everything works, including the 10pp and Sorcerer / Monk multiclass mod!


I'll carry on with this and see how I progress, but otherwise wanted to say good job GemRB team; with this working it's easy to see what an impressive technical achievement this is.





Link to comment


This topic is now archived and is closed to further replies.

  • Create New...