Jump to content
K4thos

Mod Compatibility List for EET

Recommended Posts

Plus is there any possible reason *not* to upgrade to 2.3.67.3 from 2.3.67.2??

Yes. OFFLINE play, you know, people that have computers do that sometimes.

Share this post


Link to post

 

Plus is there any possible reason *not* to upgrade to 2.3.67.3 from 2.3.67.2??

Yes. OFFLINE play, you know, people that have computers do that sometimes.
Umm, both of those versions allow offline play perfectly well...

Share this post


Link to post

 

 

Plus is there any possible reason *not* to upgrade to 2.3.67.3 from 2.3.67.2??

Yes. OFFLINE play, you know, people that have computers do that sometimes.
Umm, both of those versions allow offline play perfectly well...

 

 

Just out of curiosity, were I to install EET 7.0 on BG1/2/SOD 2.3.67.3, rather than 2.3.67.2, it would probably let me?

 

I was simply requesting that EET might notify when version check failed, to remove any guesswork, but it seems it's not so easy to implement. Thanks anyways guys!

Share this post


Link to post

Just out of curiosity, were I to install EET 7.0 on BG1/2/SOD 2.3.67.3, rather than 2.3.67.2, it would probably let me?

 

Yeah I believe it would.

 

I was simply requesting that EET might notify when version check failed, to remove any guesswork, but it seems it's not so easy to implement.

 

Ah. Eminently reasonable, and a good idea. Shame it won't work. On the other hand I suppose EET can just blare across the top of the Readme, "make sure you have the latest patch for all your EE games!!"

Share this post


Link to post
16

Yeah I hear ya. Perhaps we need just a little technical help with it's implemention. I'm sure the readme here on G3 says exactly what you said. BWS however is all automatic, different readme, and either way if you are even a 0.0.00.1 version off to the negative, EET_core stops without explaining why. It's a pretty easy guess, but in the future, most people will probably use BWS, as it results in way less bugs and scripting lag, especially for newbies.

Share this post


Link to post

First post updated with following mods:

 

Installed on BG:EE:

- Sharteel NPC mod for SoD

- Drake NPC

- Rough World

 

Installed after EET (native support, no patches needed):

- Lefreut's enhanced UI

- Sirene NPC for BG2:EE (should have full continuity if BG:EE version is present)

- Pai'Na NPC for BG2:EE

- Pale Master Sorcerer Kit (currently need to be downloaded from master Github branch)

- Mystic Fire Paladin Kit (currently need to be downloaded from master Github branch)

- Bardic-Wonders (currently need to be downloaded from master Github branch)

- Arcane Archer Fighter Kit (currently need to be downloaded from master Github branch)

 

--------------

 

there are also compatibility patches for TeamBG's Armor Pack and TeamBG's Weapon Pack: http://gibberlings3.net/forums/index.php?showtopic=28534

 

edit: thanks agb1, sent pull prequest for Pale Master Sorcerer Kit. No problems with other kits.

Edited by K4thos

Share this post


Link to post

The Pale Master kit tp2 does not include EET in the GAME_IS check, even on master branch. I did not check the other kit mods.

Share this post


Link to post

Installed after EET (native support, no patches needed):

- Pai'Na NPC for BG2:EE

 

 

There is a conditional issue between this mod and a subquest in SandrahNPC. It would only appear if you have Viconia AND Sandrah in your party AND the Viconia prosecution quest has started BEFORE you meet (and eventually let join) Paina.

 

In my episode, you will finally face Viconia's prosecutors in the hive below the cemetery. Paina appears as their ally and joins the fight against PC. Even if the modded Paina will stay neutral due to different DV, chances are that she gets killed in the high-level battle between the two opponents.

This may be avoided by adding a block to my mod that de-activates the mod-Paina during that sequence and activates her again afterwards...just a suggestion?

ActionOverride("C0Paina",Deactivate(Myself))

(The fact that she is mentioned as host and ally for the hostile drows may be explained in the way that she was forced to do that.)

 

 

Edited by Roxanne

Share this post


Link to post

berelinde's Keldorn Romance is (should! I didn't test it, only implemented your changes) be compatible with EET.

thanks :party: And don't worry, it will work if it already works for BG2:EE. All the patch does is swapping chapter numbers with variables and evaluating them during installation based on platform so there is no chance that something would be broken in either BG2:EE or EET. EET doesn't change BG2:EE content in a way that could conflict with mods like this. And of course I'm offering troubleshooting in case something is suspected to be related to EET.

Share this post


Link to post

Is there any particular reason for Gavin for BG1 and not Gavin for BG2 too being present in the BWS list?

Same thing for Valerie.

Edited by Blash2

Share this post


Link to post

Is there any particular reason for Gavin for BG1 and not Gavin for BG2 too being present in the BWS list?

Same thing for Valerie.

correct me if I'm wrong but I don't this Gavin is compatible with BG2:EE. Quote from readme:

This mod is designed to work with Baldur's Gate II: Shadows of Amn with or without the Throne of Bhaal expansion pack. The mod should be compatible with other WeiDU mods.

BG2:EE compatibility is needed to add EET support.

 

As for Valeire is there even BG2 version of the mod? Can't find it.

Share this post


Link to post

 

Is there any particular reason for Gavin for BG1 and not Gavin for BG2 too being present in the BWS list?

Same thing for Valerie.

correct me if I'm wrong but I don't this Gavin is compatible with BG2:EE. Quote from readme:

This mod is designed to work with Baldur's Gate II: Shadows of Amn with or without the Throne of Bhaal expansion pack. The mod should be compatible with other WeiDU mods.

BG2:EE compatibility is needed to add EET support.

 

As for Valeire is there even BG2 version of the mod? Can't find it.

 

There is not yet a BG2 part of Valerie (Although plans for it seem to exist since a long time.)

Only BG1 part of Gavin is made compatible with EET already.

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...