Jump to content
K4thos

Mod Compatibility List for EET

Recommended Posts

@jastey 

Yes, it was merged but notice the difference between the SHA-1 commit numbers: K4thos repository is 8f1588... while you repository is 6feb2f1.

So it seems that you repo was somehow altered after I've accepted you PR. Did you happen to do 'Force Push' from you local copy?

The thing is, you created the PR from K4thos/EET-Compatibility-List to Gitjas/EET-Compatibility-List so I was able to resolve this conflict. Now you have to accept Gitjas/EET-Compatibility-List/pull/3 on you side so you could do further PR's.

Regarding <<<<<< section:

Quote

I do not understand what I am to do with the <<<<<< section as it wants to change the master if I edit it.

The 'master' means name of the branch which contain the changes. All changes which will be done will be done inside you repository. Nothing to worry about. When it happens, delete the conflict markers <<<<<<<, =======, >>>>>>> and make the changes you want in the final merge. This page can give you more details: https://help.github.com/en/github/collaborating-with-issues-and-pull-requests/resolving-a-merge-conflict-on-github

Share this post


Link to post

Thank you very much for your help!

4 minutes ago, AL|EN said:

Did you happen to do 'Force Push' from you local copy?

I'm not aware I did but it's possible, of course.

Thanks for the links. What I missed in my conflicts page was the possibility to 4. "Decide if you want to keep only your branch's changes, keep only the other branch's changes(..).".

All I could do was edit the file with the <<<<< markers, which confused me.

Share this post


Link to post

So I'm finally getting ready for my first EET run. I used to prefer semi manual installs for BGT/BWP, pre-editing the install.bat file with my choices of mod order and components following the PDF guide. Since that one is not available for EE, I'm wondering how best to replicate that install method. Should I just manually install one mod after the other? And if so, what about mods not listed in the compatibility list here - tough luck? Or rely on Project Infinity, even though it smells a bit too much of BWS to my liking...

 

Would be grateful for anyone's brief advice!

Share this post


Link to post

There's no surefire way to do a multi-mod EET install, unfortunately. My personal procedure after several trial-and-error installs goes something like this:

- Manual download and installation of every mod I'm aiming for, and for each one (unless I'm extremely familiar with it) check forums for updates or recent bug reports/incompatibilities. 

- Roughly follow the latest BWP manual in terms of what types of mods go before other types. In my experience, very little about this changes with the EEs -- the BWP also usually gives a reasonable rationale for why something has to be installed before something else, or in separate parts, etc, giving you something to go on when deciding your own order. E.g, if a mod has to be installed in a more complicated manner to avoid conflict with another mod that you aren't going to install anyway, you can likely disregard the warnings.

- Check forums over at baldursextendedworld.com for bug reports. Regardless of other opinions about that site, it's a good source for general large-EET-install troubleshooting.

- Try to avoid or minimize the amount of mega-/large mods that add a lot of non-contained content or make sweeping changes. Double-check compatibility for any such mods that I do install, especially if they've recently changed. E.g, since the latest version of SCS adds a UI element for fine-tuning difficulty, it has become important to install UI mods prior to it.

- When possible, install the mods I'm more unsure about late in the process so they're easy to remove again if they create more trouble than they're worth.

 

With this I've grown fairly confident that I get a workable installation and can handle most subsequent bugs as they happen during the playthrough. As for mods not included for EET compatibility, one of the folders in the EET package contains information on how to check them for incompatibilities and how to instruct EET to import them from BG/SoD. For smaller/NPC mods it's usually fine, but if an NPC has content in both BG1/SoD and BG2 and comes with a separate install package for each game, this can cause some override issues.

It can also be added that this method is hardly fast -- mod selection, preparation and installation usually takes me the better part of a week. But then again I also find it rather enjoyable, like a kind of ritual in anticipation of the playthrough.

 

Share this post


Link to post

Thank you Shin, that seems like a good enough rule of thumb. 

 

I can't actually say yet for sure, Jastey. I'm going through my weidu.log now to see. It may well be that everything has been ported by now. :)

 

EDIT: At first glance, the following mods I noted to reinstall appear to be missing. Mind you, I have no idea if that actually means they are incompatible. Maybe this will help someone else make their decision between the platforms, so I might as well drop this list here. 

Jarl's Adventure Pack (I remember you mentioning its antiquated coding structure and all, but I'll really miss its BG1 late game additions)

1PP & Infinity Animations (to this day I haven't quite understood which of their components were ported to / are native to EE, but it does seem to me that EE paperdolls and some sprites lack the variety BGT with these mods sported)

Tashia and Amber NPCs (classics)

GB's Expanded Thief Stronghold, Wings (Aerie Expansion), Korgan's Redemption and Jan's Extended Quest in terms of must have content mods

Cliffette's Keyring, Homeward Bound, Game over only on party death, P5Tweaks / Klatu (item drop on imprisonment etc.) in terms of essential QoL features

Tortured Soul Quest, Herbs and Potions, Saga Master Ulrien of Cormyr, Alcool, Turnip Golem (all of them small but fun encounters)

Edited by Isewein
missing mods

Share this post


Link to post

@Isewein 1PP will be updated but won't be EE compatible as most of its content has been integrated into EE engines. IA is quite finished and will be EE compatible, but that's a tough job because every IE game package does not contain the same files and mostly because there are a lot of inconsistencies in the code.

Share this post


Link to post

I see I see - I really hate to be nagging, but is there any chance you could give me an ETA for IA ? If it's any time soon I would just hold off on my EET playthrough - those take a good year for me, on average...

Share this post


Link to post
Guest Henanigan

Hi, I hope that this is the right place to ask:

Re the 'Mods installed on BG:EE previous to installing EET on BG2:EE' list vs. the 'Mods installed after EET main component on BG2:EE' list. It's clear of course that the first list of mods cannot go after EET. But is it also the case that the second list cannot be installed before EET? It's not clear to me if BGEE mods with 'native' EET compatibility could go in either list, or if those on the first list are the only ones supported. There are mods that go on top that should be installed after mods that go below, according to their readmes (e.g. bgqe - bg1npc - bg1re - bg1ub). What to do in this case: install bgqe, bg1npc, bg1ub first on BGEE and then bg1re after EET; or install bg1re on BGEE as well, even though it's not listed as compatible? EET has a compat folder with a list of mods that overlap the Previous list, including bg1re and gavin. Does this mean that 'compat' mods may go either previous or after, whereas any BGEE mods not in the compat folder must go 'after'? Or does it mean something else altogether.

Sorry if this has been covered elsewhere, but I could not find a clear answer.

Share this post


Link to post
Guest Henanigan

Endarire, I suspect that you'd get different answers depending on who you ask.

I compared the lists, just for fun. There are quite a few differences. Some of them though are due to sorting only, e.g. "Sir Ajantis" vs. "Ajantis, Sir"; or "Ascalon's Breagar" vs. "Breagar, Ascalon's". (The maintainers of this list may want to have a look at 'Wizard Slayer Rebalancing' sorted after Y, and 'Iylos NPC' sorted before Imoen.) Several differences are due to higher version numbers in Roxanne's version, e.g. 'Adrian NPC v4.0' > 'Adrian NPC v4.3', 'Almateria's Restoration Project v8.2.7 or above' > 'Almateria's Restoration Project v8.4 or above', and so on. I find this a bit odd, because if an older version of the mod was found to be compatible, then probably it did not stop being compatible just because there's a new version out. In any case, to put it simply you should be safe using the latest version of the mod listed.

Disregarding such differences, though, it turns out that rather than one version of the list being more recent than the other, the lists are simply out of sync. Some late additions to the original list are missing from Roxanne's version, whereas Roxanne has a number of mods added from her own repo. Simply put, you cannot trust the 'last updated' date.

=======

I'll repeat my own question, in case someone is reading this thread. The compatibility list has two parts, let's call them 'pre-EET' and 'post-EET'. For the BG:EE mods found in the post-EET part, which of the following is true?
a/ They may be installed pre-EET as well, not just post-EET (if so, perhaps this could be documented in some way)
b/ They must be installed post-EET (the lists are to be taken literally)
c/ Some of them (those in the 'compat' folder?) may be installed pre-EET, but this is not guaranteed to work for all of them (if this is the case, which ones do work?)

Taken literally, the doc has BG1RE installed after BG1UB which is incorrect according to the readmes. (Some crossmods are affected as well, I think.)
Once again, I'm asking specifically about BG:EE mods listed as post-EET, not all mods listed as post-EET.

Share this post


Link to post
23 minutes ago, Guest Henanigan said:

In any case, to put it simply you should be safe using the latest version of the mod listed.

Be careful, though: Roxanne made inofficial own mod versions of other people's mods and gave them new version numbers. The original mods might have a lower version number, but that is because Roxanne's versions are inofficial ones. The original mod versions are still to be preferred and are up to date.

To make it short: the list from k4thos lists links to the original mods.

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...