Jump to content

SCS will not install on EE v2.0 - UPDATE: solved!


subtledoctor

Recommended Posts

As discussed here, with a .debug quoted:
https://forums.beamdog.com/discussion/49016/patch-2-0-and-tthe-scs-compability#latest

Anyone able to figure out a hotfix? I tried, couldn't figure it out.

2.0 is required for SoD...
and SoD is required for EET...
and I highly doubt anyone wants to play EET without SCS. So this is kind of important.

UPDATE: this has been solved. Get the hotfix here:
https://forums.beamdog.com/discussion/comment/732385/#Comment_732385

Link to comment

Tried the linked hotfix, still getting Error: Not_found on the AI initialize component, and SCS will not install.

 

This is a clean install with the new patch.

 

Tried re-installing, didn't change anything.

 

Tried without the hotfix, also doesn't work.

 

That's with SCSv30, freshly downloaded.

 

===============

 

EDIT: Manually editing the code as posted here http://gibberlings3.net/forums/index.php?showtopic=27910 worked!

Link to comment

?? I just tested and it works fine.

You might fail to see that as there's more than one fix you need to apply, and none of them have them all in a single set, none of them actually work alone. But if you apply all of them by hand, of course they work.

Link to comment

There's also an issue with the component "Reduce the number of Arrows of Dispelling in stores", I am not sure if it's 2.1-specific or 2.x in general.

 

The fix seem to be fairly simple (unless there are store files that do not actually end with ".sto"): change line 5 of item/dispelling_arrows.tpa to COPY_EXISTING_REGEXP ".*\.\sto" "%workspace%"

 

I don't know if the fix is maintained by anyone (subtledoctor?), but if it is, it should probably be included as well until DavidW comes back and updates the mod properly.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...