Jump to content
Sign in to follow this  
Talys

New BG:EE Update seems to kill Gavin

Recommended Posts

Greetings,

 

I'm playing BG:EE on Steam and use Gavin mod. Until now eveything was fine, but yesterday they was an update of the game for the release of Siege of DragonSpear,and now Gavin has no portrait, he's called "invalid 34053" and all he says is "invalid", well you get the idea. Anyone with this problem ? Anyone with an idea ?

 

(Ps: I'm using game with text in french and french translation of Gavin.)

Edited by Talys

Share this post


Link to post

Greetings,

 

I'm playing BG:EE on Steam and use Gavin mod. Until now eveything was fine, but yesterday they was an update of the game for the release of Siege of DragonSpear,and now Gavin has no portrait, he's called "invalid 34053" and all he says is "invalid", well you get the idea. Anyone with this problem ? Anyone with an idea ?

 

(Ps: I'm using game with text in french and french translation of Gavin.)

When you update a game in that way, you cannot use saved games (all the dialog.tlk references will be wrong).

Share this post


Link to post

When you patch the base game, you need to reinstall all mods. Clear out the override folder, update the game, then reinstall all mods.

 

And as Roxanne said, your old saved games will have incorrect dialog.tlk references. So, you probably need to start a new playthrough.

Share this post


Link to post

I'm having the same issue, only Gavin has never worked. I tried everything suggested in the thread and he is present in my game but spouts random dialogue. I own Dragonspear, so I'm going to try reinstalling BG:EE without it in a last ditch attempt to play the game.

 

Is Gavin compatible with Dragonspear? If not, any plans for compatibility in the future?

 

Any suggestions for dealing with this problem?

Share this post


Link to post

I'm having the same issue, only Gavin has never worked. I tried everything suggested in the thread and he is present in my game but spouts random dialogue. I own Dragonspear, so I'm going to try reinstalling BG:EE without it in a last ditch attempt to play the game.

 

Is Gavin compatible with Dragonspear? If not, any plans for compatibility in the future?

 

Any suggestions for dealing with this problem?

Have you installed the modmerge tool yet ? If you have the game from steam or Gog(read the second post in the later case).

Share this post


Link to post

I haven't installed the modmerge tool. Gavin is now working after uninstalling Dragonspear, so the issue seems to be compatibility with Dragonspear. I suppose for now I will play through without Dragonspear and then play through it without Gavin in my party when the time comes.

Share this post


Link to post

If you have SoD from Steam or GOG, you need to run the tool Jarno linked to be able to install mods. I don't think this will change anytime near.

EDIT: So, it's not compatibility with SoD per se. If SoD is modable (I.e. if it is either from BeamDog Client or prepared with the tool if from GoG or Steam) the mod (all mods) should work as normal.

Edited by jastey

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...